Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 8 von 8

Thema: ProTool Fehlermeldung E3499 Interner Fehler?!

  1. #1
    Registriert seit
    07.05.2004
    Ort
    Campbelltown
    Beiträge
    2.437
    Danke
    131
    Erhielt 276 Danke für 86 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Kann da einer etwas mit anfangen?

    Projektdaten werden synchronisiert (Generieren).

    Synchronisation (Generieren) beendet.



    Projektdaten werden synchronisiert (Speichern).

    Synchronisation (Speichern) beendet.



    OP170B Compiler-Version 6.020

    E3499 Interner Fehler: Keine Protool Daten für PT-Instanze (17,358,-1) erhalten.
    E3499 Interner Fehler: Keine Protool Daten für PT-Instanze (17,358,-1) erhalten.

    Generierung mit Fehler abgebrochen
    Das steht in der Hilfe
    Diese Meldung darf im Normalbetrieb nicht auftreten.

    Abhilfe

    Setzen Sie sich mit dem Support-Center in Verbindung. Hierzu bitte den als <wichtige Info> ausgegebenen Text notieren und dem Support-Center mitteilen.

    ProTool Online-Hilfe (C) 1998 SIEMENS AG
    Habe schon den techsupport angeschrieben, aber vieleicht ist hier ja einer schneller

    Gruß pt
    Zitieren Zitieren ProTool Fehlermeldung E3499 Interner Fehler?!  

  2. #2
    plc_tippser ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    07.05.2004
    Ort
    Campbelltown
    Beiträge
    2.437
    Danke
    131
    Erhielt 276 Danke für 86 Beiträge

    Standard

    Das war ein Problem mit der symbolischen Anbindung, die ihre Referenz verloren hatte. Nach dem löschen und neu anlegen der Var klappte es wieder.

    Gurß pt

  3. #3
    Registriert seit
    28.07.2004
    Beiträge
    36
    Danke
    4
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Ich hatte dieses Problem ebenfalls.
    Siemens bat mich daraufhin, mein Projekt einzusenden. Es wurde daraufhin bereinigt und ich bekam es wieder.
    Später bekam ich folgende Info:

    ich habe gestern noch einmal mit dem Simensianer gesprochen, der unser
    ProTool-Problem bearbeitet hat.
    Er sagte, der Fehler läge in der System-SW. Die internen Querverweise wären
    durcheinandergeraten. Sie kennen das Problem, wissen aber nicht genau,
    wodurch es entsteht und haben den Fehler in ihrer System-SW noch nicht
    100%ig gefunden. Sie vermuten inzwischen, dass der Compiler, mit dem der
    ProTool-Compiler übersetzt wird, fehlerhaft ist und werden ihn für die
    Folge-SW nicht mehr verwenden. Der nächste ProTool-SW-Stand soll besser
    laufen, aber sie können nicht garantieren, dass dieser interne Daten-Fehler
    100%ig beseitigt ist.
    Zitat Ende.
    Ich habe die Version 6.0 SP2 benutzt. Das einzige was an meinen Projekt erkennbar verändert wurde, waren die ANzahl der Gruppierungen die ich angelegt hatte.
    Es lag wohl an zuvielen Gruppierungen...?

    Lothar

  4. #4
    plc_tippser ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    07.05.2004
    Ort
    Campbelltown
    Beiträge
    2.437
    Danke
    131
    Erhielt 276 Danke für 86 Beiträge

    Standard

    Fast die gleiche Antwort wie bei mir, nur das alles der C++ Compiler schuld ist

    Ich hatte die fehlerhafte Var selber schon gefunden, gelöscht und neu angelegt, bevor Siemens mir das Projekt ebenfalls lauffähig zurückgeschickt hat.

    pt

  5. #5
    Registriert seit
    20.10.2006
    Beiträge
    68
    Danke
    13
    Erhielt 19 Danke für 7 Beiträge

    Standard

    Hallo

    Gut dass das Problem bereits gelöst. Falls wieder mal auftritt probier mal folgendes.

    Geh in Protool auf die Variablenansicht:
    --> Rechte Maustaste ... Querverweis.
    --> in der Ansicht Querverweis
    --> CTRL + Rechte Maustaste. ... "Scan all Logerror".
    --> Repair all Error"

    Jetz neu sichern und compilieren, jetzt sollte es wieder passen.

    Zur Sicherheit wäre jetzt ein Projketarchiv, kein Fehler.

    Hilft zu 90%. Sollte bei grossen Projketen ab zu gemacht werden.

    P.s Schöne Weihnachten an alle !

  6. #6
    Registriert seit
    03.11.2006
    Beiträge
    370
    Danke
    2
    Erhielt 75 Danke für 67 Beiträge

    Standard

    Dann mach nur weiter mit dem "rebuild all", aber wunder Dich nicht wenn Du Dir Dein Projekt komplett abschiesst.
    Für die Bereinigung solcher fehlerhaften Querverweise gibt es eine bestimmt Vorgehensweise, aber wer auf solche Aussagen baut brauch sich am Ende nicht wundern wenn selbst Siemens das Projekt nicht mehr zum laufen bekommt.

  7. #7
    Registriert seit
    28.06.2006
    Ort
    Königreich Neuseeland
    Beiträge
    2.027
    Danke
    133
    Erhielt 96 Danke für 76 Beiträge

    Standard

    Zitat Zitat von Sandman Beitrag anzeigen
    Dann mach nur weiter mit dem "rebuild all", aber wunder Dich nicht wenn Du Dir Dein Projekt komplett abschiesst.
    Für die Bereinigung solcher fehlerhaften Querverweise gibt es eine bestimmt Vorgehensweise, aber wer auf solche Aussagen baut brauch sich am Ende nicht wundern wenn selbst Siemens das Projekt nicht mehr zum laufen bekommt.
    Hmmmm...
    Du bist ja ein ganz schlauer.
    Endlich haben wir auch so einen.

    Die Vorgehensweise von FKJ ist richtig.
    Damit hab ich mir noch nie ein Projekt abgeschossen,
    aber schon viele Fehler bereinigt!

    Wird übrigens auch von Siemens empfohlen.

  8. #8
    Registriert seit
    20.10.2006
    Beiträge
    68
    Danke
    13
    Erhielt 19 Danke für 7 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Sandmann

    Erfahrungsgemäss sollte man ein Archiv des letzten Standes machen bevor man größere Aktionen startet. Aber das ist, so glaube ich jedem klar der je ein Progamm geschrieben hat.

Ähnliche Themen

  1. Interner Fehler in Baustein - SPS schaltet ab
    Von Vaninger im Forum Sonstige Steuerungen
    Antworten: 9
    Letzter Beitrag: 11.04.2009, 21:55
  2. interner Fehler beim Transferieren!
    Von sago im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 09.02.2009, 13:20
  3. wincc flexible interner FEHLER
    Von sali im Forum HMI
    Antworten: 13
    Letzter Beitrag: 23.07.2008, 12:23
  4. Antworten: 2
    Letzter Beitrag: 03.05.2005, 07:36
  5. pdiag - interner fehler
    Von sbbb im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 23.03.2004, 20:16

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •