Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 15

Thema: Probleme Kommunikation PC und S7-313C-2DP

  1. #1
    Registriert seit
    30.11.2007
    Ort
    Eifel
    Beiträge
    82
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Servus Leute,
    ich hab da ein kleines Problem. Ich möchte gerne meine S7-313C-2DP über den PC halt programmieren. Ich verwende einen Netlink lite 700-880-MPI01 Adapter für die Kommunikation. In diesem muss ich ja eine IP-Adresse vergeben was mir auch gelungen ist. Ich kann diesen Adapter auch mit dem ping-Befehl finden. Also bis dorthin komme ich.
    Aber weiter nicht. Jedesmal wenn ich mir die erreichbaren Teilnehmer anzeigen lassen will gibt es keine, besser gesagt es kann keine Kommunikation aufgebaut werden. Habt ihr da vielleicht einen Rat an nen blutigen Anfänger?
    Zitieren Zitieren Probleme Kommunikation PC und S7-313C-2DP  

  2. #2
    Registriert seit
    27.10.2005
    Ort
    Schwäbisch Gmünd
    Beiträge
    5.235
    Danke
    634
    Erhielt 955 Danke für 769 Beiträge

    Standard

    Auf welcher Schnittstelle steckt der Adapter? Wie sind die Busparameter im NetLink eingestellt? Wie sind die Busparameter bei der S7 eingestellt? Wird er bei "Netlink suchen" auch gefunden? Ist er im selben Segment wie der PC? Sind irgendwelche Ports gesperrt?
    Rainer Hönle
    DELTA LOGIC GmbH

    Ein Computer kann das menschliche Gehirn nicht ersetzen. Engstirnigkeit kann unmöglich simuliert werden. (Gerd W. Heyse)

  3. #3
    Registriert seit
    30.11.2007
    Ort
    Eifel
    Beiträge
    82
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Danke für die Rückmeldung.
    Also der Netlink wird beim suchen auch gefunden und die IP ist im gleichen Segment wie die des PCs. Aber wie find ich die Kommunikationsparameter raus damit ich die gleichen bei dem Netlink einstellen kann? Der Adapter steckt auf der Schnittstelle MPI auf der SPS.

  4. #4
    Registriert seit
    27.10.2005
    Ort
    Schwäbisch Gmünd
    Beiträge
    5.235
    Danke
    634
    Erhielt 955 Danke für 769 Beiträge

    Standard

    Ist der NetLink dann auf die MPI-Parameter eingestellt? Welche Adresse hat der NetLink am Bus? Welche Parameter hat der NetLink genau (gespeicherte Parameter ansehen!)?
    Rainer Hönle
    DELTA LOGIC GmbH

    Ein Computer kann das menschliche Gehirn nicht ersetzen. Engstirnigkeit kann unmöglich simuliert werden. (Gerd W. Heyse)

  5. #5
    Registriert seit
    30.11.2007
    Ort
    Eifel
    Beiträge
    82
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Servus, danke für Rückmeldung.
    Werd ich mir morgen früh in aller Ruhe mal anschauen und nochmals abgleichen. Vielleicht hab ich da einen Dreher drin.

  6. #6
    Registriert seit
    30.11.2007
    Ort
    Eifel
    Beiträge
    82
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Sorry aber ich hab da nen Mamutbaum vor dem Denkkasten. Wie bekomme ich raus wie die Konfigurationseinstellungen für MPI in der SPS sind damit ich den Kommunikationsadapter angleichen kann? Dämliche Frage, ich weiß, aber ich bin blutiger Anfänger.

  7. #7
    Registriert seit
    27.10.2005
    Ort
    Schwäbisch Gmünd
    Beiträge
    5.235
    Danke
    634
    Erhielt 955 Danke für 769 Beiträge

    Standard

    Standardeinstellung bei den SPSen ist bei MPI 187,5 kBaud, Adresse 2, bei der HSA denke ich ist es 31. Einfach den Netlink auf Adresse 0 mit MPI-Profil und entsprechender Baudrate stellen. Was zeigt er bei erreichbare Teilnehmer an? Was zeigt die Diagnose an? Sind diese Parameter im Netlink gespeichert oder nur in dem Treiber eingestellt?
    Rainer Hönle
    DELTA LOGIC GmbH

    Ein Computer kann das menschliche Gehirn nicht ersetzen. Engstirnigkeit kann unmöglich simuliert werden. (Gerd W. Heyse)

  8. #8
    Registriert seit
    30.11.2007
    Ort
    Eifel
    Beiträge
    82
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hahahaha, selten so gelacht. Ich hab alles überprüft doppelt und dreifach. Die blöde CPU313C-2DP ist nicht in meiner S7-Software enthalten. Schon enthalten, aber die Artikel-Nr. stimmte nicht mit meiner überein. Hab jetzt ne CPU315-2DP angeschlossen und siehe da es funktioniert.

    Jetzt stoß ich auf ein weiteres Problem. Mein OP7 befindet sich nicht im Hardwarekonfigurator. Wollte die GSD-Datei nachträglich installieren. Mir fehlt leider die Diskette dazu. Wollte die runterladen aber find sie bei Siemens nicht. Entweder bin ich zu blöd oder ...

    Die Nummer lautet: 607-1JC20-0AX1

    Wisst ihr vielleicht ne Adresse wo ich sowas runterladen kann?

    Wünsche allen einen schönen Samstag abend.

  9. #9
    Registriert seit
    20.10.2003
    Ort
    Biberach
    Beiträge
    5.081
    Danke
    963
    Erhielt 1.471 Danke für 929 Beiträge

    Standard

    Zitat Zitat von Black Scorpion Beitrag anzeigen
    ...Die Nummer lautet: 607-1JC20-0AX1

    Wisst ihr vielleicht ne Adresse wo ich sowas runterladen kann?
    Z. B. hier: OP7-17_DP.ZIP
    Beste Grüße Gerhard Bäurle
    _________________________________________________________________

    Die Signatur ist den allgemeinen Sparmaßnahmen zum Opfer gefallen.

  10. #10
    Registriert seit
    14.08.2007
    Ort
    Erlangen
    Beiträge
    31
    Danke
    0
    Erhielt 2 Danke für 2 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    ein OP7 brauchst auch nich in der HW-Konfig projektieren. Wenns um Kommunikation geht isses n aktiver Teilnehmer (ähnlich PG) du solltest es nur in dem Projekt anlegen, in Netpro ans Netz projektieren damit der TN im Bus und bei der Berechnung der Tokenumlaufzeit berücksichtigt wird.
    Das OP kommuniziert aktiv selbst mit der 313.

    Du brauchst die .gsd nur wenn du bei einer S7 die Direkttasten vom OP nutzen willst oder es als Slave an eine S5 über DP hängst.
    Ein Problem ist halb gelöst, wenn es klar formuliert ist.
    John Dewey
    (20.10.1859 - 1.6.1952)

Ähnliche Themen

  1. S7-200 CPU 214 Probleme mit Kommunikation
    Von drunkenmunky im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 26.09.2016, 17:47
  2. S7-Kommunikation 313C
    Von Farinin im Forum Simatic
    Antworten: 13
    Letzter Beitrag: 03.11.2011, 10:51
  3. CPU 313C, Et200M Kommunikation über Profinet
    Von ALBundy im Forum Feldbusse
    Antworten: 0
    Letzter Beitrag: 14.03.2009, 15:09
  4. Probleme mit der Kommunikation einer et200l
    Von Klappi im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 28.05.2008, 18:20
  5. Kommunikation UTICOR OP mit S7 313C
    Von Anonymous im Forum HMI
    Antworten: 0
    Letzter Beitrag: 16.11.2005, 09:50

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •