Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 8 von 8

Thema: Panel speicher keine Archive mehr

  1. #1
    Registriert seit
    19.12.2007
    Ort
    91522 ansbach
    Beiträge
    70
    Danke
    30
    Erhielt 0 Danke für 0 Beiträge

    Frage


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ich hab folgendes Problem auf der Arbeit. Nach ca. 4 Tagen speichert das Panel keine Archive mehr auf dem entfernten, durch Netzwerk verbundenen Rechner. Starte ich das Panel neu, fängt es auch wieder an zu speichern. Die Daten werden im Excel-Format archiviert.
    Wir zeichnen damit Kurven von Füllständen und Durchfluß auf.
    An was kann das liegen?

    (Also das Panel ist ein MP370 und winnCC Flexible 2005 (RT?) v.101.0.334.1)
    Geändert von Pau1e (19.12.2007 um 17:41 Uhr)
    Zitieren Zitieren Panel speicher keine Archive mehr  

  2. #2
    Registriert seit
    18.09.2004
    Ort
    Münsterland/NRW
    Beiträge
    4.718
    Danke
    729
    Erhielt 1.158 Danke für 969 Beiträge

    Standard

    Mehr Details bitte.
    Also welches Panel, Softwarestand usw.

  3. #3
    Registriert seit
    12.04.2007
    Beiträge
    140
    Danke
    5
    Erhielt 24 Danke für 22 Beiträge

    Standard

    interesant wäre auch noch um was für ein archiv es sich handelt.
    Kann ja sein das es voll ist und deswegen nichts mehr archivieren kann...
    und in flexible kann konfiguriert sein das das archiv beim neustart des panels gelöscht wird und neu anfängt zu archivieren ( einstellungen im archiv ). das würde auch erklären warum es beim neustart wieder funktioniert.

  4. #4
    Registriert seit
    19.12.2007
    Ort
    91522 ansbach
    Beiträge
    70
    Danke
    30
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Die Daten werden als name0.csv gespeichert und setzen sich dann fort in name1.csv, name2.csv,...
    Komischerweise hab ich gestern (18.12) entdeckt, dass einige solcher *.csv Dateien mit ihrem Speicherdatum (Windows Details) von heute waren... (19.12.). Das Panel hat aber schon richtige Datum/ Zeiteinstellungen...
    Geändert von Pau1e (19.12.2007 um 17:41 Uhr)

  5. #5
    Registriert seit
    12.04.2007
    Beiträge
    140
    Danke
    5
    Erhielt 24 Danke für 22 Beiträge

    Standard

    ...das ist aber noch keine antwort auf die gestellten fragen zu dem panel das du benutzt, bzw um welche archive es sich handelt...

  6. #6
    Registriert seit
    19.12.2007
    Ort
    91522 ansbach
    Beiträge
    70
    Danke
    30
    Erhielt 0 Danke für 0 Beiträge

    Standard

    sorry, hast vielleicht übersehen: Ich hab das erste posting, also die Frage an sich editiert und das steht etz ganz oben mit drinne... dachte, das wäre am besten...
    Wer n Witz oder Rechtschreibfehler findet, darf sich das abschreiben und dann zu Weihnachten schenken

  7. #7
    Registriert seit
    05.10.2005
    Beiträge
    188
    Danke
    31
    Erhielt 16 Danke für 14 Beiträge

    Standard

    ich habe viel mit archieven zu tun, die ich irgenwo hinschreibe. meist auf netzfestplatten oder auf irgendwelche server. flex hat das GROßE prob, das es mit windoofs ce arbeitet. d.h. keine weis genau wann welche script wann verdisch ist. hatte das prob auch schon. ein paar kleine tipps:

    tipp 1: schalte ein kleines script vor, welches den pfad auf vorhanden sein überprüft. (dran denken das ce einfach nur intern den explorer aufmacht und sich den zugriff speichert. also immer im wechsel überprüfen ob die eine oder die andere datei da ist)

    tipp 2: immer nur ein speicherscript ausführen und kleine watezeit für das nächste script. (sonst geht es tausenmal gut und dann kommt nur noch müll da raus)

    tipp 3: setze dir ein bit wenn das script ausgeführt worden ist. (einfach einen bool´schen wert setzen als überwachung nach deinen ausführungsbefehlen)


    tipp 4: bau die eine hilfsschleife ein, um zu gewärleisten das er die daten immer wegschreibt. d.h. schreibe in datei X. ist datei X nicht vorhanden, erstelle sie und schreib dann in X.

    ich hatte mal bei einer anlage die aufgabe auftragsnummer wegzuschreiben. bei neueingabe sollte dann kontroliert werden ob die nummer schon mal vergeben war. geforderte archivlänge: unendlich. nach etwa 100 einträgen, in die csv, hat mein pannel für die kontrolle etwa 12sec gebraucht. das lustige: für 1000 einträge auch etwa 12sec. war nen mp370.

    mfg Fanta-Er

    p.s. rechtschreibfehler sind gewollt. wer sie findet darf sie behalten.
    Zitieren Zitieren Flex eben  

  8. #8
    Registriert seit
    19.12.2007
    Ort
    91522 ansbach
    Beiträge
    70
    Danke
    30
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Tja, also das Problem haben wir gelöst: Wir schliessen jetzt täglich um 9:44 Uhr alle Archive und öffnen wieder alle um 9:45. Funktioniert!!!
    Danke an alle!
    Wer n Witz oder Rechtschreibfehler findet, darf sich das abschreiben und dann zu Weihnachten schenken

Ähnliche Themen

  1. Antworten: 0
    Letzter Beitrag: 04.05.2011, 20:59
  2. Keine Datenübertragung mehr
    Von Lubro im Forum Simatic
    Antworten: 9
    Letzter Beitrag: 09.12.2008, 16:42
  3. Antworten: 4
    Letzter Beitrag: 23.10.2008, 22:51
  4. Interner Speicher im Touch Panel?
    Von mercury_26 im Forum HMI
    Antworten: 4
    Letzter Beitrag: 17.04.2008, 11:17
  5. Logo hat keine Uhr mehr ?!
    Von Nachbar im Forum Sonstige Steuerungen
    Antworten: 2
    Letzter Beitrag: 17.11.2004, 09:19

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •