Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 4 von 4

Thema: ProTool/pro Probleme mit Bereichszeigereinstellung

  1. #1
    Registriert seit
    20.01.2007
    Ort
    Grünkraut
    Beiträge
    103
    Danke
    31
    Erhielt 19 Danke für 16 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Gemeinde,

    ich muss für eine Erweiterung in einer bestehenden Anlage ein OP270 mit ProTool/ProCS (V 6.0 SP2) integrieren. Das Anlegen der Bereichszeiger für Störmeldebereich und Quittierungsbereich-OP funktioniert. Wenn ich einen weiteren Quittierungsbereich-SPS dazuparametriere, oder auch nur den Bereichszeiger Quittierungsbereich-SPS wird die anschliessende Generierung des Projekts abgebrochen.

    Fehlerbeschreibung:
    <Zitat>
    Bereichszeiger:
    Der Quittierungsbereich SPS Nr.1 muss hinter dem Störmeldebereich Nr.1 liegen.
    Fehler bei Synchronisieren (Generieren)
    </Zitat>

    Die Bereiche liegen im Datenbaustein hintereinander, ein verlegen in den Merkerbereich hat auch die gleiche Fehlermeldung zur Folge.

    Woran kanns liegen??

    Gruss Corrado
    Zitieren Zitieren ProTool/pro Probleme mit Bereichszeigereinstellung  

  2. #2
    Registriert seit
    30.03.2005
    Beiträge
    2.096
    Danke
    0
    Erhielt 673 Danke für 541 Beiträge

    Standard

    Der Bereichszeiger Quittierung-SPS muss bei der Adressierung direkt hinter dem Bereichszeiger Störmeldungen liegen.

    Code:
    Folgende Adressierung funktioniert:
     
    Störmeldungen   - DB1 DBW0 Länge 1 Wort
    Quittierung-SPS - DB1 DBW2 Länge 1 Wort
    Quittierung-OP  - DB1 DBW4 Länge 1 Wort
     
    Folgende Adressierungen funktionieren nicht:
     
    Störmeldungen   - DB1 DBW0 Länge 1 Wort
    Quittierung-OP  - DB1 DBW2 Länge 1 Wort
    Quittierung-SPS - DB1 DBW4 Länge 1 Wort
     
    Störmeldungen   - DB1 DBW0 Länge 1 Wort
    Quittierung-SPS - DB1 DBW4 Länge 1 Wort
    Quittierung-OP  - DB1 DBW8 Länge 1 Wort
    Gruß Kai

  3. Folgender Benutzer sagt Danke zu Kai für den nützlichen Beitrag:

    corrado (04.01.2008)

  4. #3
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.218
    Danke
    533
    Erhielt 2.696 Danke für 1.948 Beiträge

    Standard

    Hier auuch mal ein Bild dazu:



    Von unten her zu betrachten .
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  5. Folgender Benutzer sagt Danke zu Ralle für den nützlichen Beitrag:

    corrado (04.01.2008)

  6. #4
    corrado ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    20.01.2007
    Ort
    Grünkraut
    Beiträge
    103
    Danke
    31
    Erhielt 19 Danke für 16 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Danke für die Tips, genau da lag der Hund begraben. Der SPS-Quittierungsbereich muss DIREKT hinter dem Störungsbereich liegen, hatte ihn hinter den vorhandenen OP-Quittierungsbereich gelegt.

    Merci nochmals.
    Corrado

Ähnliche Themen

  1. Probleme mit VBS und ProTool
    Von RMA im Forum HMI
    Antworten: 26
    Letzter Beitrag: 01.07.2009, 16:29
  2. Protool probleme
    Von Adenauer im Forum HMI
    Antworten: 0
    Letzter Beitrag: 10.03.2006, 21:30
  3. protool probleme version 5.1
    Von dingdong im Forum HMI
    Antworten: 1
    Letzter Beitrag: 07.09.2005, 15:50
  4. Probleme mit Bitmaps in Protool
    Von guenni im Forum HMI
    Antworten: 2
    Letzter Beitrag: 27.08.2004, 16:43
  5. Probleme mit ProTool Pro Runtime
    Von wupper-sps im Forum HMI
    Antworten: 2
    Letzter Beitrag: 20.01.2004, 14:04

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •