Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 9 von 9

Thema: Meldefenster bei TP177A

  1. #1
    Registriert seit
    05.05.2007
    Beiträge
    280
    Danke
    14
    Erhielt 2 Danke für 2 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen,

    ich habe eine Anlage mit nem TP177A projektiert und versuche jetzt gerade das Meldefenster richtig zu projektieren.
    Wie leg ich mir das Meldefenster an das es sich in jedem Fenster öffnet wenn ne Fehlermeldung ansteht.
    Bis jetzt hab ichs so das ich ein eigenes Bild mit Meldefester projetiert habe. Aber das macht ja keinen Sinn jedes mal in das Bild zu springen um zu sehen ob ne Meldung anliegt.

    Wär super wenn mir jemand helfen könnte.

    Gruß Markus
    Zitieren Zitieren Meldefenster bei TP177A  

  2. #2
    Registriert seit
    30.01.2004
    Ort
    Erfurt
    Beiträge
    961
    Danke
    42
    Erhielt 109 Danke für 87 Beiträge

    Standard

    Mach einfach die Meldeanzeige in die Vorlage, dann wirds überall verwendet, wenn Du in den Eigenschaften der anderen Bilder die Verwendung der Vorlage gestattest...
    __
    Mit freundlichem Gruß Peter

    ...Wir sind Alle Zeitreisende. Die überwiegende Mehrzahl schafft allerdings täglich nur einen Tag.... (Jasper Fforde: "In einem andern Buch")

  3. Folgender Benutzer sagt Danke zu PeterEF für den nützlichen Beitrag:

    settelma (02.04.2008)

  4. #3
    Registriert seit
    11.10.2005
    Ort
    Pirmasens
    Beiträge
    401
    Danke
    158
    Erhielt 74 Danke für 54 Beiträge

    Standard

    Hi,
    schau dir das mal an da steht eigentlich alles drin http://www.sps-forum.de/showthread.php?t=18317
    ansonsten die First Steps zu winccflex da ist ein beispiel zu TP177A drin!

    HDD

  5. Folgender Benutzer sagt Danke zu HDD für den nützlichen Beitrag:

    settelma (02.04.2008)

  6. #4
    settelma ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    05.05.2007
    Beiträge
    280
    Danke
    14
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Soweit war ich schon, jetzt hab ich nur das Problem das die Meldeanzeige
    jetzt immer im Hintergrund ist. Wie mach ich das das die Meldeanzeige im Vordergrund ist. Die Meldeanzeige erscheint auch nicht wenn die Meldung
    anliegt, sie ist immer "offen".

  7. #5
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.222
    Danke
    533
    Erhielt 2.697 Danke für 1.949 Beiträge

    Standard

    Ich habs gerade am Simulator probiert, es geht, wie Peter es sagt. Meldefenster in die Vorlage (bitte das Meldefenster!!!). Bitmeldung projektieren, Störungs- und Quittierungsvariable, fertig. Wenn eine Störung kommt, blendet das Meldefenster auf, nach dem Quittieren ist es wieder weg.
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  8. #6
    settelma ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    05.05.2007
    Beiträge
    280
    Danke
    14
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Ja wunderbar, es klappt. Wofür brauch ich eigentlich den Meldeindikator?.
    Das mit dem Fester klappt ja jetzt, nur das mit dem Quitieren noch nicht.
    Ich schreibe mir die Fehlermeldung in einen DB (db3.dbx0.0). Dann habe ich eine Bitmeldungen angelegt und mit dem Störmelde Db (db3.dbw0) verknüpft.
    Und das mit dem Bit 8. Ist auch etwas was ich nicht verstehe,das die Bytes vertauscht sind, aber es klappt zumindest.
    Dann hab ich in den Bitmeldungen unter "Allgemein" bei Meldegruppe "Quitiergruppe 1", bei Meldeklasse "Fehler" eingetragen.
    In den Eigenschaften hab ich jetzt die Variable (db3.dbw0) eingesetzt und das Bit 9 ausgewählt.
    Wenn ich aber jetzt am Panel die Quitiertaste drücke wird das Bit 9 nicht nicht gesetzt.

    ???

  9. #7
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.222
    Danke
    533
    Erhielt 2.697 Danke für 1.949 Beiträge

    Standard

    Ich hab für jede Meldung ein eigenes Quittierbit, das wird mit bei der Meldung im Eigenschaftsfenster eingetragen. Es gibt ein Quittierbit für Quittierung am OP und eins für Quittierung von der SPS.
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  10. Folgender Benutzer sagt Danke zu Ralle für den nützlichen Beitrag:

    settelma (02.04.2008)

  11. #8
    settelma ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    05.05.2007
    Beiträge
    280
    Danke
    14
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Ich hab meine Variable bei " Qittiervariable schreiben" eingetragen.
    Das funktioniert nicht. Was heist den "Qittiervariable lesen"?

  12. #9
    settelma ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    05.05.2007
    Beiträge
    280
    Danke
    14
    Erhielt 2 Danke für 2 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ich habs doch noch rausbekommen.
    Ich muss die das Feld "Quittiermeldungen lesen" verwenden um ein Bit in
    er Variablen zu setzten.

    Wunderbar.

    Vielen Dank an alle die mir geholfen haben.

    Gruß Markus

Ähnliche Themen

  1. Meldefenster und Bildbausteine
    Von skyvan im Forum HMI
    Antworten: 0
    Letzter Beitrag: 06.07.2011, 13:29
  2. Meldefenster ausblenden
    Von Iserlohner im Forum HMI
    Antworten: 5
    Letzter Beitrag: 18.08.2009, 16:26
  3. Meldefenster / Filterung
    Von Thomas R im Forum HMI
    Antworten: 3
    Letzter Beitrag: 09.03.2007, 20:25
  4. Meldefenster in TP170B
    Von papabär im Forum HMI
    Antworten: 2
    Letzter Beitrag: 29.01.2007, 13:25
  5. Meldefenster-vorlage
    Von Kalle im Forum HMI
    Antworten: 0
    Letzter Beitrag: 31.01.2005, 14:42

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •