Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 5 von 5

Thema: OP3 und Datenbaustein

  1. #1
    Registriert seit
    15.06.2008
    Ort
    Bei Nürnberg
    Beiträge
    3
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Frage


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    ich habe ein Problem mit dem auslesen von Datenbits aus einem Datenbaustein mit dem OP3. Eine Variable mit z.b. DB1.DBX0.0 bis DBX 0.7 funktioniert problemlos aber ab DBX1.0 meldet das OP3 das der Datenbaustein nicht vorhanden ist.
    Mit ProTool RT an der gleichen Steuerung funktioniert es übrigens.

    Hat jemand eine Idee was ich da falsch mache?


    Danke und Gruß,
    Bigfoot
    Zitieren Zitieren OP3 und Datenbaustein  

  2. #2
    Registriert seit
    22.03.2007
    Ort
    Detmold (im Lipperland)
    Beiträge
    11.710
    Danke
    398
    Erhielt 2.397 Danke für 1.997 Beiträge

    Standard

    Wie groß ist dein Datenbaustein denn insgesamt ? Kann es sein, dass nach DB1.DBX1.7 Schluß ist ...?

    Du darfst ein OP3 nicht mit einer ProTool-Runtime vergleichen ...

  3. #3
    Bigfoot ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    15.06.2008
    Ort
    Bei Nürnberg
    Beiträge
    3
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Der DB geht bis DBX1.6, aber warum kann ich DBX1.0 bis 1.6 nicht abrufen mit dem op3?

  4. #4
    Registriert seit
    22.03.2007
    Ort
    Detmold (im Lipperland)
    Beiträge
    11.710
    Danke
    398
    Erhielt 2.397 Danke für 1.997 Beiträge

    Standard

    ... die Daten-Kommunikation geht Byte (oder möglichweise sogar) Wort-weise. Es wird warscheinlich funktionieren, wenn du in dem DB noch ein (oder 2) Reserve-Wort(e) hinter deinem letzten Bit anlegst.
    Nach deiner Beschreibung hast du warscheinlich aber zusätzlich noch einen Adressendreher drin. Schau mal nach, ob du nicht noch etwas oberhalb von Bit1.6 adressiert hast ...

    Gruß
    LL

  5. Folgender Benutzer sagt Danke zu Larry Laffer für den nützlichen Beitrag:

    Bigfoot (15.06.2008)

  6. #5
    Bigfoot ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    15.06.2008
    Ort
    Bei Nürnberg
    Beiträge
    3
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Daumen hoch


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Kleine Ursache, große Wirkung , hab den Adressbereich im DB Erweitert und es geht. Sowas muss man halt wissen.

    Vielen Dank für die Hilfe.

Ähnliche Themen

  1. Datenbaustein
    Von Serdar G im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 29.10.2009, 16:22
  2. Datenbaustein
    Von SPS_NEU im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 10.03.2009, 10:59
  3. Datenbaustein
    Von cpu315 im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 21.02.2008, 20:56
  4. Datenbaustein
    Von BastiMG im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 06.10.2006, 12:15
  5. Antworten: 4
    Letzter Beitrag: 23.08.2006, 15:02

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •