Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 5 von 5

Thema: betriebsmeldungen....

  1. #1
    Registriert seit
    17.06.2004
    Ort
    Offenau
    Beiträge
    3.746
    Danke
    209
    Erhielt 421 Danke für 338 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    hab gerade eine protool proejtierung am pc laufen, will dort eine betriebsmeldung einbinden welche ein bit setzt, das sie übertragen wurde (wird zur chargenprotokollierung verwendet). nun, die betriebsmeldung kommt, bei dem kommen ereigniss habe ich die funktion bit_setzten geschrieben, aber das bit wird nicht gesetzt! wieso?? mfg. jochen
    ---------------------------------------------
    Jochen Kühner
    https://github.com/jogibear9988/DotN...ToolBoxLibrary - Bibliothek zur Kommunikation mit PLCs und zum öffnen von Step 5/7 Projekten
    Zitieren Zitieren betriebsmeldungen....  

  2. #2
    Registriert seit
    20.10.2004
    Beiträge
    650
    Danke
    5
    Erhielt 26 Danke für 26 Beiträge

    Standard

    hallöchen

    ich rate mal

    * kann es sein das das bit von deiner cpu wieder überschrieben wird
    * hast du eine verbindung zu deiner steuerung
    * bist du nicht im simu modus

  3. #3
    Registriert seit
    17.06.2004
    Ort
    Offenau
    Beiträge
    3.746
    Danke
    209
    Erhielt 421 Danke für 338 Beiträge

    Standard

    * kann es sein das das bit von deiner cpu wieder überschrieben wird
    habe extra nen neuen db aufgemacht, dieser wird garantiert nicht verwendet.

    * hast du eine verbindung zu deiner steuerung
    aber die betriebsmeldung kommt ja, nur das bit welches bei kommen ergniss der betriebsmeldung gesetzt werden soll kommt nicht!

    * bist du nicht im simu modus
    hää?? ne bin nicht im simu modus, soll ja nicht simuliert werden. es läuft das normale protool runtime..
    ---------------------------------------------
    Jochen Kühner
    https://github.com/jogibear9988/DotN...ToolBoxLibrary - Bibliothek zur Kommunikation mit PLCs und zum öffnen von Step 5/7 Projekten
    Zitieren Zitieren antowrten  

  4. #4
    Anonymous Gast

    Standard

    hi jochen könnte es sein das diese funktion so nicht möglich ist?
    mit ereignissen finde ich nichts entsprechendes



    Bit setzen (Funktion)

    Funktionsname

    Bit_setzen

    Verwendung

    Mit dieser Funktion setzen Sie eine Variable vom Typ BOOL auf den Wert 1 (TRUE).

    Projektierbare Objekte

    Objekt
    Ereignis

    Variable
    Wertänderung
    Grenzwert überschritten
    Grenzwert unterschritten

    Taste
    Systemtaste
    Taste drücken
    Taste loslassen

    Bild
    Bild aufbauen
    Bild abbauen

    Feld
    Feld anwählen
    Feld verlassen

    Meldung
    Meldung kommt
    Meldung geht
    Meldung quittiert
    (nur Störmeldung)
    Meldung bearbeiten
    (für Betriebsmeldungen)

    Wecker
    Zeit abgelaufen

    Archiv
    Überlauf Variablenarchiv
    Überlauf Meldungsarchiv

    Bildobjekt
    Drücken
    Loslassen
    Klicken
    Zustandänderung

    Skript
    immer projektierbar

    Global
    Pufferüberlauf
    Passwortänderung
    Bildwechsel


    Parameter

    Bit
    Variable vom Typ BOOL, die auf TRUE gesetzt werden soll.


    mfg th@mas

  5. #5
    Registriert seit
    17.06.2004
    Ort
    Offenau
    Beiträge
    3.746
    Danke
    209
    Erhielt 421 Danke für 338 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    habe es für meldung kommt bei einer betriebsmeldung programmiert....

    aber wie es aussieht darf man das ja nur bei einer störmeldung...

    mal sehen wie ich das dann löse... mus ich wohl noch ne zusätzlich variable anlegen...

    danke
    ---------------------------------------------
    Jochen Kühner
    https://github.com/jogibear9988/DotN...ToolBoxLibrary - Bibliothek zur Kommunikation mit PLCs und zum öffnen von Step 5/7 Projekten
    Zitieren Zitieren ahha....  

Ähnliche Themen

  1. Betriebsmeldungen 145 GLEICHZEITIG ???
    Von mr__mines im Forum HMI
    Antworten: 2
    Letzter Beitrag: 19.09.2007, 22:21
  2. Störmeldungen und Betriebsmeldungen
    Von Merlin115 im Forum Simatic
    Antworten: 14
    Letzter Beitrag: 13.11.2006, 13:42
  3. Mobile Panel 170 / Betriebsmeldungen
    Von Anonymous im Forum HMI
    Antworten: 1
    Letzter Beitrag: 07.12.2005, 16:13

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •