Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 4 von 4

Thema: OP270 "hängt" sich auf

  1. #1
    Anonymous Gast

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen,
    bei einer Anlage bestehend aus 4 CPU 315-2 DP und 3 OP270, wobei die OP´s über MPI mit allen CPU´s verbunden sind (ein DP Bus ist auch aufgebaut) besteht folgendes Problem:
    Eines der OP´s (und nur dieses eine, welches nicht am Ende der Strecke liegt) hängt sich irgendwann mal auf. Es reagiert dann auf keine Tastendrücke auch wenn es keine AG Aufträge sind. Der Fehler lässt sich nicht provozieren, es ist also keine direkte Ursache zu sehen. Die anderen OP´s funktionieren dann weiter wie gewohnt, das SPS Programm scheint auch nicht beeinflusst zu sein. Wird die Stromversorgung am OP weggenommen und wieder aufgeschaltet, so kommt es wieder normal "hoch" und arbeitet korrekt weiter. Die Baudrate am MPI ist 187,5 kbits/s.
    Vor einiger Zeit war ein ähnliches Verhalten bei einem MP370 zu beobachten, es war jedoch keine Zeit für Ursachenforschung und das Ganze wurde auf DP umgestellt dabei wurde jedoch auch die Hardwareaufteilung geändert, so dass nicht direkt gesagt werden konnte, dass nur die Umstellung auf DP das Problem aus der Welt geschafft hätte.

    Hat jemand so etwas schon gesehen, und weiss eine definitive Ursache für dieses Verhalten?
    Gruß, Rafikus
    Zitieren Zitieren Gelöst: OP270 "hängt" sich auf  

  2. "Hallo Rafikus,

    falls das betroffene OP von einem anderen Netzteil versorgt wird, sollte man dieses auch in Betracht ziehen. Kurze Spannungsspitzen, wie sie auch von kleinen Gleichspannungsschützen erzeugt werden können (Schutzbeschaltung?), könnten auch eine Ursache sein.

    Viel Glück

    Gruss, Onkel"


  3. #2
    Registriert seit
    27.01.2004
    Ort
    Ösi-Land
    Beiträge
    312
    Danke
    0
    Erhielt 8 Danke für 6 Beiträge

    Standard

    Du könntest versuchen die OP's zu vertauschen. Somit stellst fest obs an der Projektierung, am Platz im Netzwerk oder am Gerät liegt.

    Ansonsten kann ich nur sagen die Teile laufen eben mit Windows. Warum das dann abstürzt musst du den alten Billy fragen.

    smoe

  4. #3
    Anonymous Gast

    Standard

    Das OP wurde schon gegen ein Neues ausgetauscht, die Projektierung ist im Grunde identisch mit den anderen. Daher die Vermutung, dass es am Bus selbst liegt. Die anderen OP´s verrichten Ihre Arbeit ganz normal. Der Kunde meint, der Fehler tritt erst seit einem Gesamt-Stromausfall auf - da muss es aber keinen Zusammenhang geben. Ich habe vor mir das komplette Buskabel vorzunehmen, also testen und tauschen. Einen Repeater werde ich auch versuchen, das OP hängt zwar irgendwo im Bus, aber ... man weiss ja nie.
    Schlimm ist es nur, wenn die Sache dann wieder funktioniert wird sich wahrscheinlich nicht mehr nachvollziehen lassen, wo der Fehler lag.

    Gruss, Rafikus

  5. #4
    Registriert seit
    06.10.2003
    Beiträge
    3.450
    Danke
    454
    Erhielt 509 Danke für 411 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Rafikus,

    falls das betroffene OP von einem anderen Netzteil versorgt wird, sollte man dieses auch in Betracht ziehen. Kurze Spannungsspitzen, wie sie auch von kleinen Gleichspannungsschützen erzeugt werden können (Schutzbeschaltung?), könnten auch eine Ursache sein.

    Viel Glück

    Gruss, Onkel

Ähnliche Themen

  1. LibNoDave aktuelle Version "hängt"
    Von Lazarus™ im Forum Hochsprachen - OPC
    Antworten: 1
    Letzter Beitrag: 24.02.2011, 22:58
  2. CX hängt sich manchmal auf bei "Route hinzufügen"
    Von karlheinzsps im Forum CODESYS und IEC61131
    Antworten: 17
    Letzter Beitrag: 03.03.2010, 13:15
  3. Antworten: 7
    Letzter Beitrag: 17.11.2006, 22:41
  4. Antworten: 1
    Letzter Beitrag: 08.11.2006, 14:53
  5. lokale Variable "hängt sich auf"
    Von Dodo im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 27.03.2006, 08:20

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •