Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 14

Thema: WinCC Flex 2008 Rezepturprobleme

  1. #1
    Registriert seit
    02.09.2008
    Beiträge
    132
    Danke
    38
    Erhielt 6 Danke für 6 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hi

    habe schon ne weile gesucht hier aber ich finde leider nichts zu dem speziellen Problem.

    Problem:

    Das problem gestaltet sich folgendermaßen. In der Visu haben wir eine Rezepturverwaltung eingebaut( Standard Seite von WinnCC) wenn wir jetzt die Visu starten und auf datenverwaltung gehen kommt immer die Fehlermeldung "datensatz 0 nicht vorhanden" dazu muss man sagen das wie gesagt wir diesen datensatz gar nicht haben und auch nicht benutzen wollen. Habe den ordner in dem WinCC die Datensätze speichert auch schon gelöscht hat leider kein erfolg gebracht.

    Mittlerweile haben wir es zwar soweit das die Änderungen gespeichert und an dei SPS übertragen werden aber es taucht halt immer die Fehlermeldung auf was beim kunden natürlich nicht kommen soll.

    Und der aktuelle Datensatz name wird auch nicht angezeigt bzw ab und zu mal wie das Programm gerade lust hat.

    Das projekt wurde sowhl im Simulator als auch an der tatsächlichen maschine gestestet bei der beiden ist der gleiche Fehler.

    Desweiteren aus aktuellen Anlass die Frage ist es möglich aus der Variablenliste in WinCC die variablen in die rezeptur zu kopieren ohne das umständliche von hand einfügen.

    So hoffe ihr könnt mich verstehen weiß grad nicht wie ich das Problem anderster ausdrücken soll.

    MFG
    Zitieren Zitieren WinCC Flex 2008 Rezepturprobleme  

  2. #2
    Registriert seit
    13.10.2007
    Beiträge
    12.039
    Danke
    2.790
    Erhielt 3.273 Danke für 2.159 Beiträge

    Standard

    Hallo Matthias,
    ich kenne das, wenn ich über die Datensatz-Variablen bei Wertänderung das Rezept lade und in dieser Variablen steht "0" oder eine Nr. die noch nicht als Rezept vergeben ist.

    gruß Helmut
    - - -
    Wer als Werkzeug nur einen Hammer hat, sieht in jedem Problem einen Nagel.

  3. Folgender Benutzer sagt Danke zu rostiger Nagel für den nützlichen Beitrag:

    MatthiasH24 (14.11.2008)

  4. #3
    MatthiasH24 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    02.09.2008
    Beiträge
    132
    Danke
    38
    Erhielt 6 Danke für 6 Beiträge

    Standard

    Also entnehme ich jetzt deiner Antwort das wenn noch kein Datensatz eingerichtet ist das dann die fehlermeldung bei dir kommt!?

    Es ist aber so das die immer kommt auch wenn ich einen neuen anlegt habe

    BZW heipt das wenn ihn einem EA Feld nicht eingetragen ist als 0 das dann die Meldung auch kommt!? Das wäre ja bescheiden
    Geändert von MatthiasH24 (10.11.2008 um 10:38 Uhr)

  5. #4
    Registriert seit
    13.10.2007
    Beiträge
    12.039
    Danke
    2.790
    Erhielt 3.273 Danke für 2.159 Beiträge

    Standard

    Matthias, du hast doch bestimmt an deiner Rezepturanzeige eine Variable angebunden...? Wenn mit dieser Variablen das Rezept geladen werden soll und es steht "0" drin kommt es zu dieser erscheinung.
    D.h. deine Rezepturverwaltung versucht den Datensatz "0" zu laden, "0" geht aber nicht nur werte von 1 - 65535 sind zulässig und das Rezept was geladen werden soll muß vorher angelegt, also vorhanden sein.

    gruss Helmut
    - - -
    Wer als Werkzeug nur einen Hammer hat, sieht in jedem Problem einen Nagel.

  6. Folgender Benutzer sagt Danke zu rostiger Nagel für den nützlichen Beitrag:

    MatthiasH24 (14.11.2008)

  7. #5
    Registriert seit
    01.10.2007
    Ort
    Waiblingen
    Beiträge
    3.317
    Danke
    767
    Erhielt 536 Danke für 419 Beiträge

    Standard

    Einen Datensatz mit der Nummer 0 kann man nicht anlegen. Die Datensätze haben die Nummern 1 bis ...

    Deiner Schilderung versuche ich zu entnehmen, dass Du bei den allgemeinen Eigenschaften der Rezepturanzeige für den Datensatz Variable Nummer/Name eine Variable angegeben hast. und in dieser Variable der Wert Null steht. (sehe gerade, dass das Reparatur soeben auch schrieb)

    Desweiteren aus aktuellen Anlass die Frage ist es möglich aus der Variablenliste in WinCC die variablen in die rezeptur zu kopieren ohne das umständliche von hand einfügen.
    Diese Möglichkeit suche ich bisher auch vergebens ...

  8. Folgender Benutzer sagt Danke zu Perfektionist für den nützlichen Beitrag:

    MatthiasH24 (14.11.2008)

  9. #6
    MatthiasH24 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    02.09.2008
    Beiträge
    132
    Danke
    38
    Erhielt 6 Danke für 6 Beiträge

    Standard

    Also ich werde eure antworten jetzt mal überprüfen wie es bei mir aussieht. Danke schonmal

    Update. Also wenn ich im WinCC schaue dann ist bei unser Variable die für den Dateinname zuständig ist der Standardwert 10 eingetragen kann den aber nicht ändern bzw ist es der wert den ihr meint? Die Variable ist vom TYp String

    Desweiteren hat die Rezeptur bei allgemeine Einstellungen die Nummer 1
    Geändert von MatthiasH24 (10.11.2008 um 11:21 Uhr)

  10. #7
    Registriert seit
    01.10.2007
    Ort
    Waiblingen
    Beiträge
    3.317
    Danke
    767
    Erhielt 536 Danke für 419 Beiträge

    Standard

    mach doch mal ein paar Screenshots, damit wir mal eine Grundlage haben ...
    Angehängte Grafiken Angehängte Grafiken

  11. Folgender Benutzer sagt Danke zu Perfektionist für den nützlichen Beitrag:

    MatthiasH24 (14.11.2008)

  12. #8
    MatthiasH24 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    02.09.2008
    Beiträge
    132
    Danke
    38
    Erhielt 6 Danke für 6 Beiträge

    Standard

    ja ich würde en paar screens machen aber da ich im Firmennetz bin kann ich nichts hochladen...

    Also in dem bild was du geschickt hast sthet folgendes:
    XXXX : vertrauliche Daten

    Rezepturname : XXXX
    bei Variable ist nichts eingetragen
    und kein häckchen bei "Auswahlfeld anzeigen"

    Datensatz:
    variable String[24]
    Häckchen bei bearbeiten freigegeben
    kein häckchen bei Tabelle anzeigen

    Anzeigentyp

    Erweiterte ansicht

  13. #9
    Registriert seit
    01.10.2007
    Ort
    Waiblingen
    Beiträge
    3.317
    Danke
    767
    Erhielt 536 Danke für 419 Beiträge

    Standard

    also, ich würde nun erwarten, dass der Generator bereits die Variable string [24] anmeckern würde - dort sollte normalerweise eine Variable vom Typ INT stehen ...

  14. Folgender Benutzer sagt Danke zu Perfektionist für den nützlichen Beitrag:

    MatthiasH24 (14.11.2008)

  15. #10
    Registriert seit
    13.10.2007
    Beiträge
    12.039
    Danke
    2.790
    Erhielt 3.273 Danke für 2.159 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    @Perfektionist
    ...string geht auch...!
    - - -
    Wer als Werkzeug nur einen Hammer hat, sieht in jedem Problem einen Nagel.

  16. Folgende 2 Benutzer sagen Danke zu rostiger Nagel für den nützlichen Beitrag:

    MatthiasH24 (14.11.2008),Perfektionist (10.11.2008)

Ähnliche Themen

  1. Antworten: 3
    Letzter Beitrag: 01.07.2010, 17:24
  2. Antworten: 4
    Letzter Beitrag: 28.01.2010, 10:38
  3. WinCC Flex 2008 SP1 direktinstallation ?
    Von Waelder im Forum HMI
    Antworten: 4
    Letzter Beitrag: 12.03.2009, 17:29
  4. WinCC flex 2008 zu 2007 ?
    Von CrackerJack1 im Forum HMI
    Antworten: 2
    Letzter Beitrag: 12.03.2009, 11:41
  5. WinCC flex 2008 HF2
    Von dalbi im Forum HMI
    Antworten: 2
    Letzter Beitrag: 08.01.2009, 17:05

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •