Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Results 1 to 7 of 7

Thread: TP177 A...DB's sichern und dann geht nix mehr...Hilfe!!!

  1. #1
    Join Date
    30.01.2009
    Location
    Rees
    Posts
    2
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo!
    Bin neu hier...ist mein erster Beitrag. Ich hoffe ihr könnt mir das folgende Problem erklären! Oder ich hoffe zumindest auf jemanden, der das Problem auch schonmal hatte!

    Also...ich betätige im TP einen Button, der veranlasst, das alle DB's auf der MMC Karte gespeichert werden (mittels der SFC 84 in Step 7). Das funktionierte auch schon unzählige male...doch heute nicht.
    Erst sah alles aus wie immer, doch nach einem "Restart" des TPs, sagt das ding mir, das einige Variablen nicht mehr zur SPS übertragen werden können. "Wertübernahme in Steuerung nicht möglich" oder so in der art.
    Hab dann in WinCC flex. alle Variablen mal neu verbunden...brachte auch nix.
    Dann hab ich mal die Spannungsversorgung vom TP genommen. Nach der Spannungswiederkehr gings dann wieder.
    Wollte wissen ob man das reproduzieren kann...also nochmal db's gespeichert...und wieder das gleiche!
    Und es reicht wieder nur kurz die Spannung vom TP zu nehmen damit wieder alles OK ist.
    Was ist das????
    Kennt jemand so ein Problem???
    Reply With Quote Reply With Quote TP177 A...DB's sichern und dann geht nix mehr...Hilfe!!!  

  2. #2
    Join Date
    22.03.2007
    Location
    Detmold (im Lipperland)
    Posts
    12,737
    Danke
    442
    Erhielt 2,631 Danke für 2,173 Beiträge

    Default

    Hallo,
    so richtig werde ich aus deinem Problem nicht schlau ... aber - hast du mal den Standard-Trick angewandt : Temporäre Dateien löschen und neu generieren und dann übertragen ?

    Gruß
    LL

  3. #3
    Join Date
    17.10.2007
    Location
    35043 Marburg
    Posts
    176
    Danke
    4
    Erhielt 30 Danke für 29 Beiträge

    Default

    Hallo,

    hast du dir schon mal die Hilfe zum SFC 84 durchgelesen?
    Quote Originally Posted by Step7Hilfe
    Hinweis:
    Die SFC 84 eignet sich nicht dazu, Variablen häufig (bzw. zyklisch) im Ladespeicher zu schreiben, da auf eine Micro Memory Card technologiebedingt nur eine bestimmte Anzahl von Schreibzugriffen möglich ist. Siehe Referenz-Handbuch "SIMATIC Automatisierungssystem S7-300 CPU-Daten: CPU 31xC und CPU 31x".
    Aber das es nach Spannung Ein/Aus wieder funktioniert, ist schon eigenartig. Hast du zufällig die CPU auch mit abgeschalten?
    Könnte ja sein das die in Störung gegangen ist, und deswegen keine Verbindung mehr da war?
    Grüße...
    Paradox ist, wenn sich jemand im Handumdrehen den Fuß bricht.

  4. #4
    Join Date
    08.11.2006
    Location
    Uckermark
    Posts
    913
    Danke
    201
    Erhielt 256 Danke für 208 Beiträge

    Default

    Quote Originally Posted by Simatiker View Post
    Hallo,

    hast du dir schon mal die Hilfe zum SFC 84 durchgelesen?

    Quote Originally Posted by Step7Hilfe
    Hinweis:
    Die SFC 84 eignet sich nicht dazu, Variablen häufig (bzw. zyklisch) im Ladespeicher zu schreiben, da auf eine Micro Memory Card technologiebedingt nur eine bestimmte Anzahl von Schreibzugriffen möglich ist. Siehe Referenz-Handbuch "SIMATIC Automatisierungssystem S7-300 CPU-Daten: CPU 31xC und CPU 31x".
    ........
    Das sollte aber kein Problem darstellen, wenn er die SFC84 mit der Pos. Flanke des Buttons aufruft (es sei denn, er stellt sich neben das Panel und drückt den lieben langen Tag und Monat für Monat ununterbrochen wiederholt auf den Knopf).

    Also mit der SFC84 kann ich das Verhalten des Panels nicht so recht in Verbindung bringen.
    .
    Neue Ideen begeistern jene am meisten, die auch mit den alten nichts anzufangen wussten.
    Karl Heinrich Waggerl (1897-1973)

  5. #5
    Mechi00 is offline Neuer Benutzer
    Themenstarter
    Join Date
    30.01.2009
    Location
    Rees
    Posts
    2
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Default

    Die Daten werden ja nicht zyklisch auf die Karte geschrieben, sondern nur ein einziges mal beim betätigen des Buttons.
    Die CPU war nicht auf Störung, zumindest zeigte sie keine an!
    Die Spannung hab ich nur vom TP genommen (Stecker am TP abgezogen).
    Und wie gesagt, das ganze hat schon zig mal funktioniert...das wird bei uns seit jahren so gemacht. Nur dieser Fehler ist noch nie aufgetreten!

  6. #6
    Join Date
    27.05.2004
    Location
    Thüringen/Berlin
    Posts
    14,038
    Danke
    793
    Erhielt 3,227 Danke für 2,288 Beiträge

    Default

    Ist vielleicht die MMC und es wurde etwas anderes lebenswichtiges überpinselt? Komisch ist das schon, mit dem TP würde ich das auch nicht in Verbindung bringen, das stößt ja die Sache nur an und macht selbst dann gar nichts. Keine Fehlparametrierung am SFC möglich?
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  7. #7
    Join Date
    17.10.2007
    Location
    35043 Marburg
    Posts
    176
    Danke
    4
    Erhielt 30 Danke für 29 Beiträge

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    meine Frage bezog sich auf folgende Aussage:
    Quote Originally Posted by Mechi00
    ...das alle DB's auf der MMC Karte gespeichert werden (mittels der SFC 84 in Step 7).
    Im Handbuch steht etwas von 3 Aufträgen...
    Aber deswegen sollte das Panel ja nicht komisch machen!?

    Was meinst du mit "RESTART"?
    Quote Originally Posted by Mechi00
    Erst sah alles aus wie immer, doch nach einem "Restart" des TPs, sagt das ding mir, das einige Variablen nicht mehr zur SPS übertragen werden können. "Wertübernahme in Steuerung nicht möglich" oder so in der art.
    Könnte es vielleicht sein das der Datenbaustein gerade vom Panel gelesen oder beschrieben werden soll, die CPU den DB aber gesperrt hat??? Und nun das Panel die Information "Wertübernahme in Steuerung nicht möglich" erst nach Verbindung abbauen/aufbauen wieder "vergisst". Ach ich weiß es doch auch nicht!
    Grüße...
    Paradox ist, wenn sich jemand im Handumdrehen den Fuß bricht.

Similar Threads

  1. Replies: 4
    Last Post: 21.07.2016, 18:03
  2. Step 7 Hilfe => S7-PLCSIM geht nicht mehr
    By RON_87 in forum Simatic
    Replies: 15
    Last Post: 12.08.2013, 10:43
  3. Replies: 13
    Last Post: 22.10.2010, 22:22
  4. Float Wert to Dword und dann zu DINT geht das?
    By mcmatthew in forum Simatic
    Replies: 5
    Last Post: 11.12.2009, 16:50
  5. Belkin F5D7130 nach Firmware Update geht nix mehr
    By Nethacks in forum PC- und Netzwerktechnik
    Replies: 0
    Last Post: 05.04.2006, 17:29

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •