Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 2 von 2

Thema: Rezepturen - Rätselhaftes verhalten

  1. #1
    Registriert seit
    19.06.2003
    Ort
    Im Staub ...
    Beiträge
    337
    Danke
    115
    Erhielt 26 Danke für 23 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Guten Morgen,

    erst mal zur Technik ...
    CPU-315-2DP
    Am Profibusanschluss hängt ein PC mit WinCCFlex 2007 Runtime, auf dem Rezepturen gespeichert sind.

    Jetzt zum Problem.
    Ich habe 2 Rezepturen angelegt.
    Rezept 1 mit 468 Rezepturelementen - geht in den DB510
    Rezept 2 mit 458 Rezepturelementen - geht in den DB511

    Die CPU soll über den Steuerungsauftrag 70 (Schreibe_Datensatz_in_Steuerung) das Rezept 1 bzw. 2 holen.
    Code:
    Rezept 1 klappt wunderbar.
    Hier der Ablauf ...
      Rez.Nr. = 1 -> Par1 (Bereichszeiger Steuerungsauftrag)
      DS.Nr. = 1 -> Par2 (Bereichszeiger Steuerungsauftrag)
      70 -> Auftragsnummer (Bereichszeiger Steuerungsauftrag)
          PC nimmt den Auftrag entgegen und löscht den Steuerungsauftrag.
      Kurz darauf kommt im Bereichszeiger Datensatz ...
        Rez.Nr. = 1
        DS.Nr. = 1
        Status = 2 (Übertragung läuft)
      Nach einiger Zeit geht Status auf 4 (Übertragung Fehlerfrei beendet), und wird dann von CPU wieder auf 0 gesetzt.
    Soweit alles OK.
     
    Jetzt zum Rezept 2.
    Hier der Ablauf ...
      Rez.Nr. = 2 -> Par1 (Bereichszeiger Steuerungsauftrag)
      DS.Nr. = 1 -> Par2 (Bereichszeiger Steuerungsauftrag)
      70 -> Auftragsnummer (Bereichszeiger Steuerungsauftrag)
        PC nimmt den Auftrag entgegen und löscht den Steuerungsauftrag.
    Das wars dann.
    Keinerlei Antwort im Bereichszeiger Datensatz.
    Ich habe in WCF nochmal alle Rezepturelemente überprüft - keine Fehler.
    Alle Variablen sind OK.
    Die Rezeptnummer stimmt.
    Der Datensatz ist vorhanden.
    Beide DB's sind vorhanden und lang genug.
    Im Moment steh ich ziemlich auf dem Schlauch.

    Irgendeine Idee woran das liegen könnte?

    Danke für Eure Hilfe.

    Gruß.
    Zitieren Zitieren Rezepturen - Rätselhaftes verhalten  

  2. #2
    Avatar von ssound1de
    ssound1de ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    19.06.2003
    Ort
    Im Staub ...
    Beiträge
    337
    Danke
    115
    Erhielt 26 Danke für 23 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Fehler gefunden - habe in der Rezeptur den Haken bei "Synchronisieren" vergessen.
    Manchmal ist es auch ganz einfach.
    Danke für Eure Zeit.

Ähnliche Themen

  1. VKE-Verhalten bei SPA
    Von The Blue im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 18.07.2010, 19:47
  2. PNIODIAG - Verhalten
    Von Shettyman im Forum HMI
    Antworten: 0
    Letzter Beitrag: 24.06.2010, 08:23
  3. PT1- Verhalten
    Von Craash im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 05.10.2008, 21:33
  4. Rätselhaftes Phänomen
    Von rnovak im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 22.04.2008, 14:23
  5. CPU-Verhalten bei Profibusfehler
    Von Ekkehard im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 07.03.2008, 00:17

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •