Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 3 von 4 ErsteErste 1234 LetzteLetzte
Ergebnis 21 bis 30 von 37

Thema: Störmeldeanlage

  1. #21
    bastler ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    03.10.2008
    Beiträge
    232
    Danke
    8
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    suppy, jetzt klappts, danke.

  2. #22
    bastler ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    03.10.2008
    Beiträge
    232
    Danke
    8
    Erhielt 1 Danke für 1 Beitrag

    Standard

    So, jetzt hab ich noch ne Frage, hoffe es ist die letzte. In meiner Testumgebung nutze ich ein OP170B. Alles läuft soweit ohne Probleme, benutze zum quitt. der Meldung die ACK-Taste. Diese setzt mir die Meldung im OP auf quittiert und per zugwiesener Variable wird in der SPS die Meldung auch quitt. Liegt eine Meldung an leuchtet die LED der ACK-Taste. Wenn die Meldung eher wieder geht, als sie quittiert wurde, dann kommt es vor, das die LED nach Betätigen der ACK-Taste nicht ausgeht. Das Meldefenster schließt, also liegt auch keine Meldung mehr an, nur dies LED leuchtet noch. Das ist allerdings auch nicht immer, meistens hab ich das beobachtet, wenn mehrere Meldungen eingelaufen sind. An was kann das liegen?

    MfG
    bastler

  3. #23
    Registriert seit
    13.10.2007
    Beiträge
    12.033
    Danke
    2.788
    Erhielt 3.269 Danke für 2.157 Beiträge

    Standard

    Wenn du eine meldeseite eingerichtet hast solltest du
    mal nachschauen ob wirklich alle Meldungen quittiert sind.
    Was ich auch festgestellt habe, sporadisch kann es passieren
    das alle Meldungen als quittiert angezeigt werden, nicht alle
    entsprechenden quittierbits in der Steuerung ankommen...ich
    schieb das mal auf flex. Das ganze führt zu den Problemm, ohne
    Quittierung auf steuerungsseite, setze ich die Störung nicht
    zurück! Dafür habe ich dann extra eine Taste angelegt wo alle
    Störmeldebits gelöscht werden, nicht schön aber hilfreich.
    - - -
    Wer als Werkzeug nur einen Hammer hat, sieht in jedem Problem einen Nagel.

  4. #24
    bastler ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    03.10.2008
    Beiträge
    232
    Danke
    8
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Versteh ich nicht ganz. Alle Meldungen in der Steuerung werden bei mir durch das selbe Bit zurückgesetzt, nämlich das, welches beim Drücken der ACK-Taste(SetzeBitSolangeTasteGedrückt) gesetzt wird. Wenn ich alle Störmeldebits in einer Variablentabelle anschaue, sind die auch alle auf false.
    Trotzdem ist die ACK-LED manchmal noch an.
    Im Handuch hab ich gelesen, das zu jeder Meldung ein Quittierbit gesetzt wird, wie bekomme ich das denn in die Steuerung, ebenso wie bekomme ich das LED_Abbild in die Steuerung? Oder hab ich da was ganz und gar falsch verstanden?

    MfG
    bastler

  5. #25
    Registriert seit
    13.10.2007
    Beiträge
    12.033
    Danke
    2.788
    Erhielt 3.269 Danke für 2.157 Beiträge

    Standard

    Das ist richtig, lese noch mal Beitrag #11 & #12 und schau dir die
    Screenshots genau an
    - - -
    Wer als Werkzeug nur einen Hammer hat, sieht in jedem Problem einen Nagel.

  6. #26
    Registriert seit
    13.10.2007
    Beiträge
    12.033
    Danke
    2.788
    Erhielt 3.269 Danke für 2.157 Beiträge

    Standard

    HMI - Störmeldungen zuordnen.JPG

    Noch einmal zur zuordnung der Variablen zun den Störmeldungen.
    Die Störmeldungen und die Quittierbit's stehen ja in entsprechenden
    Arrays, um nun die richtigen Bit's zu zuordnen gibt es einen Zeiger.
    Im Beispiel ist die Störmeldung "001 - Störung Luft" das 9te Bit im
    Array "002-DB.Stoermeldungen". Dementsprechen befindet sich das
    Quittierbit im Array "002-DB.Quit_OP" und ist auch dort das 9te Bit.
    Sinn gemäß kann mann dann auch der Störmeldung eine Nr geben
    die in der Oberfläche später angezeigt wird im unseren Fall die 1009.
    Das hat den Vorteil wenn der Kunde später mal sagt "Ich habe da
    eine Störmeldung", kann mann einfach nach der Nr. fragen und
    findet das schneller im Programm wieder.

    In deinen fall solltest du beim testen darauf achten das du die
    Störmeldung setzt, dann Quittierst und dann dir den Status
    der Meldungen anschaust.
    Erst jetzt solltest du das Signal der Störung zurücknehmen.
    - - -
    Wer als Werkzeug nur einen Hammer hat, sieht in jedem Problem einen Nagel.

  7. #27
    bastler ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    03.10.2008
    Beiträge
    232
    Danke
    8
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Hallo Helmut vdR

    Wie ich schon schrieb, quittiere ich die Meldungen per ACK-Taste mit enentsprechender Variable. Hab mir deine Vorschläge nochmal angeschaut. Du hast ja für jede Meldung eine Quittierbit und das bei "Quittierbit Lesen " eingetragen. Bei "Quittierbit Lesen "hab ich noch nichts eingetragen.
    Wenn ich nun die Variable, die meiner ACK-Taste zugeordnet ist nehme und die bei "Quittierbit Lesen "eintrage, ist das doch das gleiche oder?

    MfG
    bastler

  8. #28
    Registriert seit
    13.10.2007
    Beiträge
    12.033
    Danke
    2.788
    Erhielt 3.269 Danke für 2.157 Beiträge

    Standard

    Nein das ist nicht das selbe, flex quittiert mit der "ACK"
    Taste die Meldung die oben in der Liste steht und meldet das
    mit den entsprechenden Quittierbit an die Steuerung selbst-
    ständig. Darum must du dich nicht kümmern, nur die richtige
    Nr eintragen.
    - - -
    Wer als Werkzeug nur einen Hammer hat, sieht in jedem Problem einen Nagel.

  9. #29
    bastler ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    03.10.2008
    Beiträge
    232
    Danke
    8
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Habe jetzt alles soweit am Laufen, doch eine Frage hätte ich doch noch.
    Bei reinen Störmeldeanlagen wird ja unter Erst- und Neuwert unterschieden.
    Also kommt eine Meldung, wird das Meldesignal akustisch abgestellt. Geht diese Meldung bevor sie quittiert wurde und kommt erneut, muß die akustische Mldung wieder zugeschalten werden. Kann man dieses Verhalten auch an einem OP nachstellen?

    MfG
    bastler

  10. #30
    Registriert seit
    13.10.2007
    Beiträge
    12.033
    Danke
    2.788
    Erhielt 3.269 Danke für 2.157 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    ich denke das geht nicht wenn die meldung nicht quittiert ist,
    vielleicht muß du dann die quittierung von der Steuerung aus
    durchführen. Es gibt ja zwei Quittierbreiche.
    Den einen kennst du ja schon Quittierbereich OP, der andere
    wäre dann der Quittierbereich SPS, die du dann auch anlegen
    must. Dh du bekommst zu jeder Störmeldung noch mal zusätztlich
    ein Quittierbit, das du von der Steuerung aus setzen kannst.
    - - -
    Wer als Werkzeug nur einen Hammer hat, sieht in jedem Problem einen Nagel.

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •