Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 10 von 10

Thema: WinCC flexible, Problem mit der Darstsellung vom An.Wert

  1. #1
    Registriert seit
    31.10.2005
    Beiträge
    116
    Danke
    10
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Leute,

    das MPanel 377 zeigt einen Analog-Wert mit ###.
    Projektiert als E/A Ausgabe-Feld, Variable als MD200, Darstellung Dezimal oder Hex!
    Komunikation (und bin. Werte) ist OK!

    Die SPS S7_300 Baugruppe mit 8Kanälen, 12Bit, Meßart: 2DMU, Meßbereich: 4 -20mA

    Zum Skalieren wird der FC105 verwendet:
    "1" auf EN
    "0" auf Bipolar
    LO mit 4.0e+002
    HI mit 2.0e+000
    IN mit PEW256 (oder EW256 - genau weiss ich nicht!)
    OUT mit MD200
    parametriert


    Wo liegt der Fehler?

    Fragende GRüße
    Ricko
    Zitieren Zitieren WinCC flexible, Problem mit der Darstsellung vom An.Wert  

  2. #2
    Registriert seit
    03.11.2006
    Ort
    Niedersachsen
    Beiträge
    1.126
    Danke
    170
    Erhielt 303 Danke für 259 Beiträge

    Standard

    Dein normierter Wert ist okay?
    Was ist in den Eigenschaften deines Ausgabefeldes unter
    Darstellungsformat angegeben?
    Dein Wert hat vlt mehr Stellen als hier angegeben deshalb siehst du nur ###.
    Geändert von crash (15.12.2009 um 21:45 Uhr)
    Gruß
    crash

    Ich bin nicht bekloppt,
    ich bin verhaltensoriginell!

  3. #3
    Ricko ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    31.10.2005
    Beiträge
    116
    Danke
    10
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Halo Crash!

    als Format: habe ich gewählt 99 und 999 und 99.1 immer ###

    Online im Simatic Manager kann den Wert vom Analoggeber sehen!"

    Ricko

  4. #4
    Registriert seit
    03.11.2006
    Ort
    Niedersachsen
    Beiträge
    1.126
    Danke
    170
    Erhielt 303 Danke für 259 Beiträge

    Standard

    wie groß ist denn dein Wert?
    Gruß
    crash

    Ich bin nicht bekloppt,
    ich bin verhaltensoriginell!

  5. #5
    Ricko ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    31.10.2005
    Beiträge
    116
    Danke
    10
    Erhielt 0 Danke für 0 Beiträge

    Standard

    ich möchte eigentlich Druck vom 0 bis 6 bar darstellen! Signal vom MU oder Analogeber 4 bis 20mA!
    Zur Testzwecken habe ich verschiedene Werte (als LO und HI ) und Darstellungen gewählt!

    Grüße
    Ricko

  6. #6
    Registriert seit
    03.11.2006
    Ort
    Niedersachsen
    Beiträge
    1.126
    Danke
    170
    Erhielt 303 Danke für 259 Beiträge

    Standard

    Dann musst du auch von 0 bis 6 skalieren.
    Lo 0.0e+000
    HI 6.0e+000
    Gruß
    crash

    Ich bin nicht bekloppt,
    ich bin verhaltensoriginell!

  7. #7
    Ricko ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    31.10.2005
    Beiträge
    116
    Danke
    10
    Erhielt 0 Danke für 0 Beiträge

    Standard

    danke für die Antworten,

    werden gleich Morgen testen und berichten !!

    Grüße
    Ricko

  8. #8
    Registriert seit
    04.04.2006
    Beiträge
    239
    Danke
    31
    Erhielt 61 Danke für 51 Beiträge

    Standard

    Ich verwende zwar den FC105 nicht, dieser gibt aber glaube ich den Ausgangswert als REAL aus. Hast du deine Variable MD200 in Flex als REAL deklariert? Nach meiner Meinung ist die Ein/-Ausgabe von Variablen in Merkerworten oder Merkerdoppelworten scheiße. Schreib deine Analogwerte in einen Datenbaustein und deklarier das Format im Datenbaustein. Dann hast du auch keine Probleme in Flex, wenn du diese Variablen aus dem DB übernimmst.

  9. #9
    Registriert seit
    15.12.2007
    Beiträge
    712
    Danke
    84
    Erhielt 105 Danke für 94 Beiträge

    Standard

    Zitat Zitat von Ricko Beitrag anzeigen
    LO mit 4.0e+002
    HI mit 2.0e+000

    Wo liegt der Fehler?

    Fragende GRüße
    Ricko
    Der Fehler leigt darin das der LO nen höheren Wert als der HI hat würde ich sagen. evtl. mag das der FC105 nicht. (Aber noch nich selber probiert.)
    Pass also erstmal wie schon vorher geschrieben deine Skalierungen an.

  10. #10
    Ricko ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    31.10.2005
    Beiträge
    116
    Danke
    10
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    @all

    das mit LO > HI war ein Tippfehler (nicht im SPS!

    Im WinCC, -> Variablen.. habe ich den Format als DW eingegeben da OUT im FC105 ein MD (MD200) war.

    Nachdem ich dort REAL (so wie Grenzen LO und HI) wählte, war alles OK!



    Ricko

Ähnliche Themen

  1. Antworten: 13
    Letzter Beitrag: 10.01.2011, 07:42
  2. Wert WinCC flexible 2005
    Von waldy im Forum Suche - Biete
    Antworten: 3
    Letzter Beitrag: 21.11.2010, 10:50
  3. Antworten: 1
    Letzter Beitrag: 22.04.2010, 10:45
  4. WinCC flexible - BOOLEAN Wert setzen
    Von Fluffi im Forum HMI
    Antworten: 3
    Letzter Beitrag: 17.02.2008, 10:43
  5. Problem mit WinCC Flexible
    Von Jojo im Forum HMI
    Antworten: 8
    Letzter Beitrag: 09.02.2006, 07:45

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •