Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 6 von 6

Thema: $ 304 Auftrag ungültig

  1. #1
    Registriert seit
    02.02.2007
    Beiträge
    4
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,
    Ich habe seit ein paar Tagen ein Problem mit einer Anlage.
    Eingesetzt ist eine 315 2DP mit einem OP7 am Profibus.

    Die Anlage war über den Winter außer Betrieb jetzt bei der Wiederinbetriebnahme erscheint die Meldung $ 304 Auftrag ungültig am Display.
    Es wurde aber nichts verändert oder erneuert, sprich die Anlage lief bis zum Winter ohne Probleme.

    Was kann ohne Änderungen an der Anlage diese Fehlermeldung hervorrufen?
    Die Erklärung in der OP7 Doku ist auch nicht gerade hilfreich.

    Habt Ihr eine Erklärung zu diesem Fehler?

    Grüsse, stromengl
    Zitieren Zitieren $ 304 Auftrag ungültig  

  2. #2
    Registriert seit
    24.09.2009
    Beiträge
    70
    Danke
    0
    Erhielt 8 Danke für 8 Beiträge

    Standard

    Hallo

    Hier das Handbuch zum OP7:

    http://cache.automation.siemens.com/...HB/Op717_d.pdf

    Die Begründung zum Fehler (auf Seite 147) ist dürftig, deutet aber auf einen missglückten Steuerungsauftrag hin. Ich würde die SPS-Software mal nach Steuerungsaufträgen absuchen (wahrscheinlich Uhrzeitsynchronisation mit der Steuerung)

    Markus

  3. #3
    stromengl ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    02.02.2007
    Beiträge
    4
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Danke für Deine Antwort.

    Das komische ist, es wurde nichts an der Anlage geändert.

    Vor ein paar Jahren wurde mal das OP7 gewechselt, seit dem gab es keinerlei Änderungen an der Anlage.
    Und wie gesagt funktionierte die Anlage bis zum Winter ohne Probleme.
    Vorige Woche bei den Vorbereitungsarbeiten zur Wiederinbetriebnahme fiel dem Bedienpersonal die Fehlermeldung am Display auf (die Anlage ist im Winter immer außer Betrieb).
    Die Anlage wurde 2002 gebaut und 2003 wurden die letzten Änderungen am Programm vorgenommen.

    Ich selbst bin kein Programmierer (komme aus der Instandhaltung) und habe nur Grundkentnisse in Step7.
    Mit Protool hatte ich überhaupt noch keinen Kontakt.
    Gibt es noch etwas, das ich testen oder versuchen könnte, oder am Besten gleich einen Programmierer vor Ort schicken?

    Danke und Grüsse, stromengl

  4. #4
    Registriert seit
    24.09.2009
    Beiträge
    70
    Danke
    0
    Erhielt 8 Danke für 8 Beiträge

    Standard

    Stromengl

    Ich vermute mal, dass die CPU eine Batterie hat und diese erschöpft ist. Wahrscheinlich ist irgendwo in der SPS-Software eine Uhrzeitsynchronisation mit dem OP7 via Steuerungsaufträge programmiert. Durch den Ausfall der Batterie ist die Uhrzeit auf einen Wert weit in der Vergangenheit gesetzt worden. Der Code welcher die Synchronisation macht schreibt wahrscheinlich nun falsche Uhrzeitwerte (Programmierfehler? --> Stichwort Jahr 2000-Wende) in die Parameterdaten des Panels und löst den Steuerungsauftrag aus, was wiederum die Fehlermeldung provoziert.

    Sollte es sich um so einen Fall handeln, hilft nur das checken der Software und allenfalls online beobachten bzw. richtigstellen vor Ort.

    Markus

  5. Folgender Benutzer sagt Danke zu MarkusP210 für den nützlichen Beitrag:

    stromengl (24.03.2010)

  6. #5
    stromengl ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    02.02.2007
    Beiträge
    4
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Danke erstmal,

    Eine Batterie ist gesteckt und der Batteriefehler an der CPU leuchtet nicht (habe aber keine Ahnung, wer und wann die Batterie das letzte mal getauscht wurde).

    Was mir aber unlängst an einer anderen Anlage aufgefallen ist (S7 200 und TP 170):
    Es ist ein Fenster programmiert, in welchem die Betriebsstunden aller Antriebe jeweils für ein Jahr abgerufen werden können.
    Beim Jahreswechsel von 2009 auf 2010 ist die Anzeige aber auf das Jahr 2016 gesprungen und speichert die 2010er Betriebsstunden im Jahr 2016 (die Jahre 2010 - 2015 enthalten keine Betriebsstunden).
    Scheinbar hat sich da irgendwo ein Fehler beim Zahlenformat eingeschlichen (Hex, Dez).

    Könnte sowas auch in meinem aktuellen Fall die Ursache sein?

    Danke und Grüsse, stromengl

  7. #6
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.192
    Danke
    925
    Erhielt 3.292 Danke für 2.661 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von stromengl Beitrag anzeigen
    Scheinbar hat sich da irgendwo ein Fehler beim Zahlenformat eingeschlichen (Hex, Dez).

    Könnte sowas auch in meinem aktuellen Fall die Ursache sein?
    Bingo!
    Da hat der oder die Programmierer wohl dezimal und BCD nicht beachtet.

    Erste Anlage: Wenn die CPU die Jahreszahl dezimal in den Steuerungsauftrag schreibt statt BCD, dann wird der Steuerungsauftrag ab 2010 ungültig.
    Zweite Anlage mit den Betriebsstundenzählern: hier ist es genau umgekehrt, die Jahreszahl im Datum ist BCD und der Programmierer hat sie als dezimal ausgewertet.

    Da wirst Du wohl einen Programmierer an die Anlagen schicken müssen, der den Fehler ausbügelt.

    Gruß
    Harald
    Geändert von PN/DP (25.03.2010 um 01:47 Uhr) Grund: "ab 2010" zugefügt

  8. Folgender Benutzer sagt Danke zu PN/DP für den nützlichen Beitrag:

    stromengl (24.03.2010)

Ähnliche Themen

  1. Steuerungsauftrag ungültig
    Von giro im Forum HMI
    Antworten: 4
    Letzter Beitrag: 19.06.2011, 15:48
  2. IP 246 S5 unerlaubter Auftrag
    Von mitchih im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 18.11.2010, 18:33
  3. Adresse ungültig in HW-Konfig ?!?
    Von Sinix im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 15.03.2010, 15:45
  4. Baugruppen Datenbasis ungültig?
    Von vollmi im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 28.09.2009, 13:32
  5. Antworten: 18
    Letzter Beitrag: 22.01.2009, 21:39

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •