Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 3 von 5 ErsteErste 12345 LetzteLetzte
Ergebnis 21 bis 30 von 45

Thema: Erfahrungsbericht zu atvise-HMI

  1. #21
    Registriert seit
    15.04.2010
    Beiträge
    92
    Danke
    11
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Stoffel
    Hab jetzt selber ein paar Erfahrungen mit Atvise WebMI2ADS Visu gesammelt.
    Schau dir das mal an.
    Für die Variablendeklaration würde ich vorschlagen du legst diese alle in ein Struct und ruft du diese Global auf (als Array oder auch nicht...)
    ftp.jpgCerhost config.jpgStartMan.jpg

  2. #22
    Registriert seit
    31.07.2006
    Beiträge
    50
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Wollte den demo server bei mir aufsetzten und bekomme nur die fehlermeldung, hat jemand ein ähnliches problem?

    2016-01-27 20:08:11.307 webmi root : C:\webMI2ADS\webMI2ADS
    2016-01-27 20:08:11.307 tpy file : C:\TwinCAT\3.1\Boot\Plc\Port_851.tpy
    2016-01-27 20:08:11.307 data directory : C:\webMI2ADS\webMI2ADS\data
    2016-01-27 20:08:11.307 variables : all
    2016-01-27 20:08:11.307 login method : form based
    2016-01-27 20:08:11.307 http port : 80 (IP address: all)
    2016-01-27 20:08:11.307 https port : 443 (IP address: all)
    2016-01-27 20:08:11.317 AMS Net Id : 10.0.0.27.1.1
    2016-01-27 20:08:11.317 AMS port : 801
    2016-01-27 20:08:11.317 ADS timeout : 5000 ms
    2016-01-27 20:08:11.317 poll after : 400 items
    2016-01-27 20:08:11.317 max publish queue: 2048 items
    2016-01-27 20:08:11.317 max sessions : 128
    2016-01-27 20:08:11.317 max subscr items : 8192
    2016-01-27 20:08:11.317 file 'webMI_cert.pem' not found, SSL not available
    2016-01-27 20:08:11.317 file 'webMI_private_key.der' not found, using temporary RSA key
    2016-01-27 20:08:11.493 startup finished
    2016-01-27 20:08:11.493 error 6 reading PLC state, no communication, trying again later
    2016-01-27 20:08:11.650 write problem: -1, 10054
    2016-01-27 20:08:12.013 Tearing session 00000001 down
    2016-01-27 20:08:18.130 Tearing session 00000002 down
    2016-01-27 20:08:24.128 Tearing session 00000003 down
    2016-01-27 20:08:30.008 Tearing session 00000004 down
    2016-01-27 20:08:36.079 Tearing session 00000005 down
    2016-01-27 20:08:42.091 Tearing session 00000006 down
    2016-01-27 20:08:48.132 Tearing session 00000007 down
    2016-01-27 20:08:54.024 Tearing session 00000008 down
    2016-01-27 20:09:01.072 Tearing session 00000009 down
    2016-01-27 20:09:08.002 Tearing session 0000000a down
    2016-01-27 20:09:15.043 Tearing session 0000000b down
    2016-01-27 20:09:23.071 Tearing session 0000000c down
    2016_01_27_21_00_35_atvise_next_generation.jpg

  3. #23
    Registriert seit
    02.03.2014
    Beiträge
    3
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo aus Tirol
    Bin gerade dabei eine Atvise Visu mit Atvise zu erstellen. Ich greife dabei auf ein bestehendes InTouch System ein bzw zu. Die Adressen der Aktoren und Sensoren sind in Wörtern definiert. Jedes einzelne Bit im Wort hat eine Funktion (zb. Agg gestört, in Betrieb, Hand, Auto...) hat sich jemand schon mal beschäftigt mit Atvise einzelne Bits in Wörtern zu schreiben und zu lesen ?

    Wäre über jeden noch so kleinen Tip dankbar

  4. #24
    Registriert seit
    01.03.2008
    Beiträge
    487
    Danke
    3
    Erhielt 43 Danke für 39 Beiträge

    Standard

    Hallo,

    also ich mache das fast nur mit den bits.
    Nur noch Analogwerte gehen als eigene Variable über den bus.

    Ich arbeite übrigens nur noch mit den Objekt-Typen (die grauen Kästen unten im Builder). Das spart enorm viel Zeit und sorgt für fehlerfreies Arbeiten.

    Um die Bits auszuwerten musst du in der Animation unter "Formel" das entsprechende Bit aus der Variable maskieren und kannst dann mit dem maskierten Wert weiterarbeiten.
    Schreiben mach ich auf diese weise nicht nicht. Eher lege ich eine "Schreibvariable" an z.B. als 16INT und habe dann einen FB, der je nach Wert eine Aktion auslöst und die Variable zurücksetzt. Funzt prima...

    Arbeite mit Objekt-Typen und das Ergebnis wird toll werden.

    MfG CAS
    www.cas-solution.de

    Alles geregelt...


    Weltraumflug in den USA zu gewinnen!
    Kratze hier ▒▒▒▒▒▒▒▒▒▒▒▒ mit einer Münze,
    und finde heraus, ob Du der Gewinner bist!

  5. #25
    Registriert seit
    14.05.2014
    Beiträge
    74
    Danke
    2
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Zitat Zitat von cas Beitrag anzeigen
    Hallo,

    ich habe hier die Software atvise (Web-HMI) installiert auf einer CX9000.

    Funktioniert sehr gut !

    Falls Fragen sind, einfach fragen

    MfG CAS
    Hallo,

    inzwischen stehe ich unmittelbar vor demKauf einer Lizenz und habe tatsächlich eine riesige Menge an Fragen.

    Zum Beispiel da du schreibst:

    installiert auf einer CX9000
    Wie und was installiert man auf einer CX1030?

    Auf dem Laptop das zur Programmierung der Visu hergenommen wird, wird die gleiche Software installiert?

    Die Atvise Doku finde ich wenig hilfreich...

    EDIT:

    Ein Tutorial wäre natürlich super.
    Geändert von controlmyhome (19.02.2017 um 17:05 Uhr)

  6. #26
    Registriert seit
    13.06.2007
    Ort
    Amberg
    Beiträge
    89
    Danke
    15
    Erhielt 9 Danke für 9 Beiträge

    Standard

    Hallo,

    wir benutzen atvise als SCADA - System, was möchtest Du den machen?

    Tip: Es gibt auf youtube Tutorials.

    Gruß GFI

  7. #27
    Registriert seit
    14.05.2014
    Beiträge
    74
    Danke
    2
    Erhielt 1 Danke für 1 Beitrag

    Standard

    was möchtest Du den machen?
    Ich möchte per Android Tablet meine Rolläden, Gartenbeleuchtung, Heizungsfunktionen, etc. bedienen.

    Ob das ein SCADA System wird, ist oder sein sollte , kann ich überhaupt nicht beurteilen. Ich bin Maschinenbeuingenieur - kein Programmierer.

    Die Tutorials habe ich teils schon gesehen.

    Da heisst es dann "lizenzieren sie nach erfolgter Installation..."

    Na toll - und wie installiere ich was auf der CX1030? Das Ding hat kein CD Laufwerk...

    Kann ich atvise auf USB Stick downloaden und dann quasi eine setup.exe ausführen?

    Dann den Lizenzschlüssel manuell eintragen den ndie CX1030 kriegt keinen Internetzugang. Klappt das so?

  8. #28
    Registriert seit
    14.01.2010
    Beiträge
    7
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo,

    schön, dass das Thema wieder aufgegriffen wird.

    Die Web-Oberfläche bekomme ich zum laufen und ein Display konnte ich in der Demo-Version auch anlegen und auf die CX9020 übertragen. Das ganze kann ich auch über den Browser aufrufen.

    Leider kann ich keine Variablen einbinden. Immer wenn ich im atvise builder versuche die Variablen zu importieren bekomme ich folgende Fehlermeldung:
    Fehler.png

    Ich verzweifel langsam, aber wie lassen sich die Variablen so verknüpfen, dass ich sie im atvise builder nutzen kann?

    Ich hoffe, hier kann mir jemand weiterhelfen. Für Tipps wäre ich dankbar.

  9. #29
    Registriert seit
    14.05.2014
    Beiträge
    74
    Danke
    2
    Erhielt 1 Danke für 1 Beitrag

    Standard

    So, ich habe nun eine Lizenz atvise webMI2ADS geordert.

    Da ich wie erwähnt die Installationsanleitung vermisse, wäre ich sehr dankbar wenn sich hier jemand dazu äußern könnte.


    Meine Beckhoff CPU ist eine CX1030 mit Windows Embedded Standart. Hier muss wohl das webMI2ADS Tool installiert werden. Aber wie? Die CX hat kein CD-Rom...

    Programmiert werden soll die Visu auf einem Laptop. Ich nehme an, auf letzterem wird dann der atvise Builder installiert.

  10. #30
    Registriert seit
    15.04.2010
    Beiträge
    92
    Danke
    11
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hier findest du alles was du brauchst....
    https://www.atvise.com/en/component/...y/76-webmi2ads

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •