Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 10 von 10

Thema: TD200 V3 Problem mit Sprachumstellung

  1. #1
    Registriert seit
    04.11.2008
    Beiträge
    25
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    habe eine S7/224 CPU V02.00 mit einen TD200 V3 Display.
    Wie kann ich die Sprache im Datenbaustein umstellen?
    Der Assistent funktioniert nicht, da immer ein Übersetzungsfehler auftritt:
    Datenseite ANWENDER1:Zeile 13, FEHLER 2770er angegebenen Adresse wurde bereits ein Wert zugewiesen, und das in Zeile 14, 18 und 19 auch.
    Die Micro/Win Version ist 4.0.0.81.

    Bitte um dringende Hilfe, DANKE!!!!
    mfg
    mac2005
    Zitieren Zitieren TD200 V3 Problem mit Sprachumstellung  

  2. #2
    Registriert seit
    19.06.2008
    Ort
    Ostalbkreis
    Beiträge
    3.140
    Danke
    201
    Erhielt 553 Danke für 498 Beiträge

    Standard

    Morgen,


    z.B.: VB2 16#20 =Englisch
    VB2 16#10 =Deutsch

    Je nach dem wie dein DB angelegt ist



    Grüße

  3. #3
    mac2005 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    04.11.2008
    Beiträge
    25
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Danke!
    Hab versucht das zu ändern, ok.
    Leider kommen wieder die oben genannten Fehler beim Übersetzten und das Programm lässt sich nicht einspielen.

    Wer kann mir helfen?
    DANKE!!

  4. #4
    Registriert seit
    19.06.2008
    Ort
    Ostalbkreis
    Beiträge
    3.140
    Danke
    201
    Erhielt 553 Danke für 498 Beiträge

    Standard

    Stell doch mal den "fehlerhaften" Code hier rein.

  5. #5
    mac2005 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    04.11.2008
    Beiträge
    25
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Datenseite ANWENDER1:Zeile 13, FEHLER 2770 der angegebenen Adresse wurde bereits ein Wert zugewiesen
    Datenseite ANWENDER1:Zeile 14, FEHLER 2770 der angegebenen Adresse wurde bereits ein Wert zugewiesen
    Datenseite ANWENDER1:Zeile 18, FEHLER 2770 der angegebenen Adresse wurde bereits ein Wert zugewiesen
    Datenseite ANWENDER1:Zeile 19, FEHLER 2770 der angegebenen Adresse wurde bereits ein Wert zugewiesen

  6. #6
    Registriert seit
    19.06.2008
    Ort
    Ostalbkreis
    Beiträge
    3.140
    Danke
    201
    Erhielt 553 Danke für 498 Beiträge

    Standard

    Folgende Fehler werden erst nach dem Übersetzen angezeigt:

    · Doppelte Adreßzuordnungen (wenn Sie z.B. die Zeile "VB1 249, 250" eintragen, ordnen Sie implizit den Wert 250 zu VB2 zu — Sie dürfen dann an keiner anderen Stelle der Adresse VB2 einen Datenwert zuordnen).

    · Überschneidungen von Adressen (wenn Sie z.B. ein Doppelwort wie 65536 zu VD0 zuordnen, können den Adressen V1, V2 und V3 keine Datenwerte zuordnen, weil sie bereits belegt sind: diese Adressen sind Teil des Doppelworts, das an VD0 beginnt).
    Kontrolliere mal Deine Zuordnungen oder schreib den DB hier rein

  7. #7
    mac2005 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    04.11.2008
    Beiträge
    25
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Standard

    VB0 'TD'
    VB2 16#10
    VB3 16#70
    VB4 50
    VB5 0
    VW6 32
    VW8 12
    VW10 0
    VB32 'COUNTER PRESET '
    VB47 16#18
    VB48 16#10
    VW49 16#0000
    VB51 ' $00$00$00'
    VB52 'COUNTER ACTUAL '
    VB67 16#18
    VB68 16#10
    VW69 16#0000
    VB71 ' $00$00$00'
    VB72 'FEED LENGTH '
    VB84 16#18
    VB85 16#10
    VW86 16#0000
    VB88 ' mm '
    VB92 'RAM DWN TIME'
    VB104 16#10
    VB105 16#10
    VW106 16#0000
    VB108 'mSEC'
    VB112 16#18
    VB113 16#10
    VW114 16#0000
    VB116 ' '
    VB132 16#18
    VB133 16#10
    VW134 16#0000
    VB136 ' '
    VB152 16#18
    VB153 16#10
    VW154 16#0000
    VB156 ' '
    VB172 16#18
    VB173 16#10
    VW174 16#0000
    VB176 ' '
    VB192 16#18
    VB193 16#20
    VD194 16#00000000
    VB198 ' '
    VB212 16#18
    VB213 16#10
    VW214 16#0000
    VB216 ' '
    VB232 ' SERIENSTANZE'
    VB252 'MANUAL MODE '
    VB272 ' AUTO MODE '
    VB283 16#00
    VB284 16#10
    VW285 16#0000
    VB287 ' '
    VB292 'EMERGENCY PRESSED '
    VB312 'HYD MOTOR MPCB TRIP '
    VB332 'HYD MOTOR RUNNING '
    VB352 'SELECT AUTO MODE '
    VB372 'PRESS HYD MOTOR PB '
    VB392 'PRESS CY.STOP TO '
    VB412 'COUNTER RESET '
    VB432 ' '
    VB452 ' '
    VB472 ' '
    VB492 ' '
    VB512 ' '
    VB532 ' '
    VB552 ' '
    VB572 ' '
    VB592 ' '
    VB612 ' '
    VB632 ' '
    VB652 ' '
    VB672 ' '
    VB692 ' '
    VB712 ' '
    VB732 ' '
    VB752 ' '
    VB772 ' '
    VB792 ' '
    VB812 ' '
    VB832 ' '
    VB852 ' '
    VB872 ' '
    VB892 ' '
    VB912 ' '
    VB932 ' '
    VB952 ' '

  8. #8
    Registriert seit
    19.06.2008
    Ort
    Ostalbkreis
    Beiträge
    3.140
    Danke
    201
    Erhielt 553 Danke für 498 Beiträge

    Standard

    Code:
    VB51 ' $00$00$00' <---Überlappung mit VB52 ?
    VB52 'COUNTER ACTUAL '
    VB67 16#18
    VB68 16#10
    VW69 16#0000
    VB71 ' $00$00$00'  <---Überlappung mit VB72 ?
    VB72 'FEED LENGTH '

    Zeile 13-14 = VB51/VB52 bitte prüfen

    Zeile 18-19 = VB71/VB72 bitte prüfen

  9. #9
    mac2005 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    04.11.2008
    Beiträge
    25
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Wie gehe ich da vor? Was muß ich prüfen? Bitte um eine kurze Beschreibung, DANKE!


  10. #10
    Registriert seit
    19.06.2008
    Ort
    Ostalbkreis
    Beiträge
    3.140
    Danke
    201
    Erhielt 553 Danke für 498 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    VB51 ' $00$00$00' //kein Plan was das gerade ist aber 4byte Speicher
    VB52 reserviert
    VB53 reserviert
    VB54 reserviert

    es geht erst bei VB 55 ohne Fehler weiterweiter
    VB55 ....



    LG

Ähnliche Themen

  1. Problem mit TD200
    Von Sashimi im Forum Simatic
    Antworten: 12
    Letzter Beitrag: 20.03.2011, 20:29
  2. Problem mit Ausgabe auf TD200
    Von mr.blue im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 16.02.2011, 09:26
  3. Sprachumstellung Sinumerik 810D
    Von Air-Wastl im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 26.10.2010, 17:57
  4. Antworten: 2
    Letzter Beitrag: 08.12.2006, 09:36
  5. Sprachumstellung in MS-Project
    Von RalfS im Forum Stammtisch
    Antworten: 2
    Letzter Beitrag: 16.10.2006, 09:03

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •