Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 15

Thema: Negative Zahlen anzeigen?

  1. #1
    Registriert seit
    18.12.2008
    Beiträge
    255
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo, ich brauche mal bitte eure Hilfe...

    Auf einem Panel wird in einem MW das Gewicht von einer Siwarex-Wägezelle angezeigt. Jetzt ist der Fall eingetreten, dass die Waage ohne Belastung –3g anzeigt. In der Visualisierung erhalte ich dadurch jedoch eine Anzeige von ca. 30kg – vermutlich deshalb, weil eine negative Darstellung nicht angezeigt werden kann.

    Abgesehen davon, dass die Waage justiert werden sollte – wie schaffe ich es, dass in dem MW der Visualisierung auch negative Einträge dargestellt werden können? Habe dazu in WinCC flex unter "Allgemein" Nichts gefunden.

    Vielen Dank!
    Grüße
    petzi
    Zitieren Zitieren Negative Zahlen anzeigen?  

  2. #2
    Registriert seit
    13.10.2007
    Beiträge
    12.038
    Danke
    2.789
    Erhielt 3.273 Danke für 2.159 Beiträge

    Standard

    Hallo Petzi,
    was hast du den für ein Zahlenformat was du zur Visu überträgst, wenn
    du z.b. DINT nimmst, werden Negative Zahlen richtig dargestellt.

    gruß Helmut
    - - -
    Wer als Werkzeug nur einen Hammer hat, sieht in jedem Problem einen Nagel.

  3. #3
    Registriert seit
    21.12.2006
    Ort
    Wiener Neustadt
    Beiträge
    931
    Danke
    154
    Erhielt 169 Danke für 127 Beiträge

    Standard

    Du mußt bei Allgemein - Darstellung - Darstellungsformat die auswählen, die mit "s" beginnen. - Hab ich mal gehört.
    zB "s999,9"
    Gruß
    M

    Handbook not read error...
    Klare Frage - klare Antwort

  4. #4
    petzi ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    18.12.2008
    Beiträge
    255
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Danke für euer Antworten.

    Das SPS-Programm ist sehr aufwendig und nicht von mir...

    @Helmut:

    Im DB, in den das Gewicht geschrieben wird steht der Typ INT eingetragen.

    @Manfred:

    Ein vorangestelltes s wird an dieser Stelle nicht genommen, bzw. gibt es keine in der Liste mit einem s.
    Grüße
    petzi

  5. #5
    Registriert seit
    13.10.2007
    Beiträge
    12.038
    Danke
    2.789
    Erhielt 3.273 Danke für 2.159 Beiträge

    Standard

    wenn du in flexibel bei dem Ausgabefeld Dezimal ausgewählt hast
    sollte das klappen. Da es für dich ein fremdes Projekt ist, versuche
    doch mal folgendes. Lade deinen Wert in der Steuerung auf ein freies
    MW um. Dann machst du in der Oberfläche ein neues Ausgabefeld, mit
    diesen MW.
    Diese beiden Werte beobachtest du. Vlt hat der Programmierer von
    der Anlage irgendwo eine wilde Rechnung gemacht, die du noch nicht
    gefunden hast.
    - - -
    Wer als Werkzeug nur einen Hammer hat, sieht in jedem Problem einen Nagel.

  6. #6
    Registriert seit
    20.06.2003
    Ort
    Sauerland.NRW.Deutschland
    Beiträge
    4.850
    Danke
    78
    Erhielt 800 Danke für 543 Beiträge

    Standard

    das sollte eigentlich problemlos funktionieren
    mw200 ist in wccf als int deklariert
    Angehängte Grafiken Angehängte Grafiken
    .
    mfg Volker .......... .. alles wird gut ..

    =>Meine Homepage .. direkt zum Download

    Meine Definition von TIA: Total Inakzeptable Applikation

  7. #7
    petzi ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    18.12.2008
    Beiträge
    255
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Hm, habe keine Änderung bekommen.

    Habe jetzt mal folgendes gemacht:

    L DB231.DBW10 // Hier steht das Gewicht mit Typ INT
    T MW200

    Auf der Visu werden noch immer keine neg. Zahlen angezeigt.
    Grüße
    petzi

  8. #8
    Registriert seit
    13.10.2007
    Beiträge
    12.038
    Danke
    2.789
    Erhielt 3.273 Danke für 2.159 Beiträge

    Standard

    schau dir das bei Volker mal an, da funktioniert es. Was steht den in
    deinen Merkerwort drin, bitte den Online Status anschauen.
    - - -
    Wer als Werkzeug nur einen Hammer hat, sieht in jedem Problem einen Nagel.

  9. #9
    petzi ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    18.12.2008
    Beiträge
    255
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard

    In dem MW steht online drin: Statuswert = -7

    Anbei noch ein Bildchen mit meinen Einstellungen.
    Angehängte Grafiken Angehängte Grafiken
    Grüße
    petzi

  10. #10
    Registriert seit
    13.10.2007
    Beiträge
    12.038
    Danke
    2.789
    Erhielt 3.273 Danke für 2.159 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    hast du den versucht dieses MW200 als Variabel in Flexibel zu deklarieren
    und dieses dann auf ein neues Ausgabefeld zu bringen?
    - - -
    Wer als Werkzeug nur einen Hammer hat, sieht in jedem Problem einen Nagel.

Ähnliche Themen

  1. OPC Negative Zahlenwerte
    Von Gucky_av im Forum Hochsprachen - OPC
    Antworten: 5
    Letzter Beitrag: 24.06.2008, 19:29
  2. Negative Zahlen abfangen in Step 5
    Von Idlav im Forum Simatic
    Antworten: 16
    Letzter Beitrag: 25.04.2008, 09:51
  3. Negative Erfahrungsberichte
    Von Atommolch im Forum Stammtisch
    Antworten: 17
    Letzter Beitrag: 24.07.2007, 06:25
  4. Negative Zahlen im Hexadezimalen Zahlensystem
    Von Unregistriert1 im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 12.05.2006, 06:32
  5. OP7 negative Zahlen darstellen
    Von Anonymous im Forum HMI
    Antworten: 2
    Letzter Beitrag: 27.09.2005, 09:40

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •