Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 6 von 6

Thema: Variable in Fehlermeldung anzeigen

  1. #1
    Registriert seit
    20.10.2010
    Beiträge
    5
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Böse


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen.

    Ich habe Probleme eine Variable in einer Fehlermeldung anzeigen zu lassen.
    Ich habe eine Variablen Wort deklariert (habe auch schon die Variable im String, Char und DWort deklariert)und rufe Sie in einer Fehlermeldung auf. Sehe aber meine zweistellige Zahl nicht wenn die Fehlermeldung ausgelöst wird.
    Ich habe WinCC 2008 und ein OP170B.

    Weiss einer ob das OP170B Scripte unterstützt?

    Vielen Dank schon mal im vorraus


    P.S. If you build a idiot prove machine they will improve there idiots
    Zitieren Zitieren Variable in Fehlermeldung anzeigen  

  2. #2
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.220
    Danke
    533
    Erhielt 2.696 Danke für 1.948 Beiträge

    Standard

    OP170B kann keine Scripte.

    Hast du die Variable in die Fehlermeldung im Feld "Text" rechts mit dem Button eingefügt? Stimmt die Feldlänge? Hast du die Erfassungsart der Variablen mal auf "Zyklisch fortlaufend gestellt"?
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  3. #3
    Andy AC ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    20.10.2010
    Beiträge
    5
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Vielen Dank Ralle. Habe mich auch schon gewundert warum der Scriptordner nicht zu finden war.

    Die Feldlänge habe ich schon variiert und mit dem Erfassungszeit habe ich auch schon ohne Erfolg experimentiert. Und ja ich habe mit rechtsklick eine Variable im Fehlertext eingefügt. Egal was ich bis jetzt gemacht habe, es werden mir nur "#" als Platzhalter angezeigt. Die Variable wird mir aber korrekt in einem Ausgabefenster angezeigt. Könnte es sein das es an dem alten OP liegt? Ich habe das OP170B von Protool auf WinCC umgewandelt und habe alte Beiträge gefunden in denen man verschiedene kommandos vor der Variablen stehen haben muss damit sie in den "Interne" Ausgabe übernommen werden.
    Habe diese Kommandos auch schon ohne Erfolg ausprobiert.

    Vielen Dank schon mal

  4. #4
    Registriert seit
    11.04.2008
    Ort
    Bayern
    Beiträge
    523
    Danke
    26
    Erhielt 67 Danke für 67 Beiträge

    Standard

    Die # können aber auch bedeutet das dein Wert zu viele Stellen für den Platzhalter hat.

  5. #5
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.220
    Danke
    533
    Erhielt 2.696 Danke für 1.948 Beiträge

    Standard

    Ich meinte nicht den Rechtsclick, sondern den Button ganz rechts im Textfeld. Möglich, dass er erst sichtbar wird, wenn man mit der Maus darübersteht. Ist aber wahrscheinlich das Selbe, wie der Rechtsclick.
    ### sagen tatsächlich i.d.R., daß der Wert nicht paßt. Es ist wichtig, dass die Variable zum Zeitpunkt des kommenden Fehlers den richtigen Wert hat, ich denke, zu diesem Zeitpunkt wird dann ein "Schnappschuß" der Variable gemacht und angezeigt.
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  6. #6
    Andy AC ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    20.10.2010
    Beiträge
    5
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Zusammen.

    Als ich die # gesehen habe dachte ich auch das ich das Anzeigefeld zu klein gemacht habe, aber egal bei welcher groesse der Anzeigelange bekomme ich immer nur # angezeigt.

    Ich habe auch beide Varianten ausprobiert die Variable hinzufügen. Einmal mit rechtsklick und über den EinfügeKnopf am textrand. Lieder ohne Erfolg.

    Ich habe ebenfalls ein Ausgabefeld eingefügt um zu sehen ob die Variable richtig angezeigt wird. Ich will eigentlich nur eine zweistellige Zahl angezeigt bekommen.

    Vielen Dank für eure Tipps schon mal im vorraus. Werde mich mal an Siemens selber wenden.

Ähnliche Themen

  1. S7 Variable in Java Variable umwandeln
    Von maxi81 im Forum HMI
    Antworten: 0
    Letzter Beitrag: 26.11.2010, 17:55
  2. Antworten: 7
    Letzter Beitrag: 05.03.2008, 07:38
  3. Fehlermeldung
    Von Manfred Stangl im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 03.08.2007, 07:02
  4. Bild anzeigen wenn Variable gesetzt ist
    Von MarioS007 im Forum HMI
    Antworten: 3
    Letzter Beitrag: 13.06.2007, 19:50
  5. Antworten: 0
    Letzter Beitrag: 23.03.2007, 08:42

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •