Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 3 123 LetzteLetzte
Ergebnis 1 bis 10 von 21

Thema: Keine Verbindung mit OP170B (zuviel Busteilnehmer?)

  1. #1
    Registriert seit
    14.07.2004
    Beiträge
    76
    Danke
    19
    Erhielt 2 Danke für 2 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ich habe seit heute ein Problem mit einem OP170B.
    Dieses Panel wird seit ca. 2 Jahren problemlos an einem Profibus-Strang mit 20 Busteilnehmer (ET200 & Festo CPV10) betrieben.
    Der Profibusstrang ist über einen CP443-5 an einer CPU417-4 angeschlossen.
    Wie gesagt seit 2 Jahren ohne Probleme.

    Jetzt wurde dieser Profibus-Strang um 3 ET200 & 3 Festo CPV10 erweitert.
    (Jetzt also 26 Slaves & 1 OP170B am Bus)
    Seitdem die neuen Profibus-Teilnehmer am Bus angeschlossen sind,
    kann sich das OP170B nicht mehr mit der Steuerung verbinden.
    Wenn ich jetzt mind. 5 beliebige Busteilnehmer ausschalte verbindet sich das Panel wieder sofort mit der CPU.
    Kommt ein Busteilnehmer hinzu, wird die Verbindung sofort wieder abgebaut.
    Ein Adresskonflikt liegt nicht vor! (mind. 10x überprüft )
    In der Spezialdiagnose des CP´s kann ich sogar die Adresse des Panels sehen!

    Woran könnte das liegen? Zuviel Kommunikation (CPU->Slaves), sodass das Panel keine Zeit mehr findet Daten mit der CPU auszutauschen?
    Oder gibt es eine Beschränkung wieviel Slaves man in Verbindung mit einem Panel an einer CPU betrieben kann?

    Grüße und einen guten Rutsch....
    Zitieren Zitieren Keine Verbindung mit OP170B (zuviel Busteilnehmer?)  

  2. #2
    Registriert seit
    25.06.2007
    Ort
    Dresden
    Beiträge
    3.930
    Danke
    465
    Erhielt 878 Danke für 634 Beiträge

    Standard

    Hallo Wastel,

    auch wenn die maximale Anzahl von Teilnehmern pro Segment noch nicht erreicht ist, rate ich doch mal einen Repeater - so vorhanden - einzuschleifen.
    Da du ja nur ein paar binäre E/A zugefügt hast, ist die Erhöhung der Buszykluszeit in deinen Fall wohl nicht das Problem.
    Hast du die Mindestleitungsleitungslänge zwischen zwei Profibusteilnnehmern beachtet. Das waren wohl 50cm, wenn ich mich
    recht entsinne.

    Gruß

    Frank
    Grüße Frank

  3. Folgender Benutzer sagt Danke zu IBFS für den nützlichen Beitrag:

    Wastel (04.01.2011)

  4. #3
    Registriert seit
    23.04.2009
    Ort
    Allgäu
    Beiträge
    3.042
    Danke
    241
    Erhielt 863 Danke für 617 Beiträge

    Standard

    Zitat Zitat von IBFS Beitrag anzeigen
    Hast du die Mindestleitungsleitungslänge zwischen zwei Profibusteilnnehmern beachtet. Das waren wohl 50cm, wenn ich mich
    recht entsinne.
    Von einer Mindestleitungslänge habe ich noch nie was gehört und darum habe ich mal gesucht:

    http://support.automation.siemens.co...ew/de/28922114

    ANTWORT:
    Es gibt keine definierten Mindestlängen bei elektrischen Profibusleitungen. Diese Eigenschaft ist unabhängig von der verwendeten Übertragungsgeschwindigkeit.
    Hatte aber auch noch nie das Problem.
    Gruß
    Paule
    ----------------------------------------------------------------------------
    > manchmal verliert man und manchmal gewinnen die anderen <

  5. Folgender Benutzer sagt Danke zu Paule für den nützlichen Beitrag:

    Wastel (04.01.2011)

  6. #4
    Registriert seit
    25.06.2007
    Ort
    Dresden
    Beiträge
    3.930
    Danke
    465
    Erhielt 878 Danke für 634 Beiträge

    Standard

    Hier hatte ich darüber eswas gelesen und daher waren
    die 50cm irgendwie so eine Idee.

    http://spsforum.eu/showpost.php?p=263326&postcount=2

    Gruß

    Frank
    Grüße Frank

  7. Folgender Benutzer sagt Danke zu IBFS für den nützlichen Beitrag:

    Wastel (04.01.2011)

  8. #5
    Registriert seit
    22.03.2007
    Ort
    Detmold (im Lipperland)
    Beiträge
    11.716
    Danke
    398
    Erhielt 2.399 Danke für 1.999 Beiträge

    Standard

    Hallo,
    ich würde sagen, das hier die B&B-Dienste (Bedienen & Beobachten) gegenüber den DP-Diensten (dezentrale Perepherie) "einfach" in den Hintergrund geschoben werden. Das ist m.E. nicht wirklich ein Verdrahtungsthema sondern eher ein Auslastungsthema.

    Es ist also so, wie du vermutest :
    Zuviel Kommunikation (CPU->Slaves), sodass das Panel keine Zeit mehr findet Daten mit der CPU auszutauschen
    ggf. kannst du das ändern, wenn du die Aktualisierungsrate der OP-Variablen hochsetzt.

    Gruß
    Larry

  9. Folgender Benutzer sagt Danke zu Larry Laffer für den nützlichen Beitrag:

    Wastel (04.01.2011)

  10. #6
    Registriert seit
    17.07.2009
    Ort
    Am Rande der Ostalb
    Beiträge
    5.480
    Danke
    1.141
    Erhielt 1.240 Danke für 973 Beiträge

    Standard

    Schau mal in den Eigenschaften des Profibus nach dem Busprofil.
    Wenn es auf DP steht, dann es stell es auf Standard. Mit den Einstellungen des Bus-Profils legst du das Verhältnis DP-Kommunikation zu anderen Kommunikationsdiensten (HMI,FDL,PG,...) fest.

    Gruß
    Dieter

  11. Folgende 2 Benutzer sagen Danke zu Blockmove für den nützlichen Beitrag:

    PN/DP (01.01.2011),Wastel (04.01.2011)

  12. #7
    Registriert seit
    27.10.2005
    Ort
    Schwäbisch Gmünd
    Beiträge
    5.224
    Danke
    630
    Erhielt 955 Danke für 769 Beiträge

    Standard

    Ich tippe mal auf Timing. Die Master haben eine bestimmte Zeitscheibe um die Slaves abzufragen. Danach wird der Token weitergegeben. Wenn jetzt ein Master den Token erhält und die TTR (Target Token Rotating Time) abgelaufen ist, dann muss er ihn sofort weitergeben ohne etwas getan zu haben.
    Deshalb einfach mal des Timing des Busses entsprechend großzügiger einstellen, d.h. mehrere Master und Slaves berücksichtigen. Bei Siemens kann man in der Busprofileinstellung schön herumspielen und sieht die Auswirkungen.
    Rainer Hönle
    DELTA LOGIC GmbH

    Ein Computer kann das menschliche Gehirn nicht ersetzen. Engstirnigkeit kann unmöglich simuliert werden. (Gerd W. Heyse)

  13. Folgende 2 Benutzer sagen Danke zu Rainer Hönle für den nützlichen Beitrag:

    PN/DP (01.01.2011),Wastel (04.01.2011)

  14. #8
    Registriert seit
    17.07.2009
    Ort
    Am Rande der Ostalb
    Beiträge
    5.480
    Danke
    1.141
    Erhielt 1.240 Danke für 973 Beiträge

    Standard

    Zitat Zitat von Rainer Hönle Beitrag anzeigen
    Deshalb einfach mal des Timing des Busses entsprechend großzügiger einstellen, d.h. mehrere Master und Slaves berücksichtigen. Bei Siemens kann man in der Busprofileinstellung schön herumspielen und sieht die Auswirkungen.
    Dabei aber Neustart der Slaves (Spannung aus/ein) nicht vergessen

    Gruß
    Dieter

  15. Folgender Benutzer sagt Danke zu Blockmove für den nützlichen Beitrag:

    Wastel (04.01.2011)

  16. #9
    Registriert seit
    27.10.2005
    Ort
    Schwäbisch Gmünd
    Beiträge
    5.224
    Danke
    630
    Erhielt 955 Danke für 769 Beiträge

    Standard

    Zitat Zitat von Blockmove Beitrag anzeigen
    Dabei aber Neustart der Slaves (Spannung aus/ein) nicht vergessen

    Gruß
    Dieter
    Ist das wirklich notwendig? Ich dachte durch die Konfigurationsänderung geht der Master vom Bus und wenn er wiederkommt initialisiert er die Slaves mit den entsprechenden Parametern.
    Rainer Hönle
    DELTA LOGIC GmbH

    Ein Computer kann das menschliche Gehirn nicht ersetzen. Engstirnigkeit kann unmöglich simuliert werden. (Gerd W. Heyse)

  17. Folgender Benutzer sagt Danke zu Rainer Hönle für den nützlichen Beitrag:

    Wastel (04.01.2011)

  18. #10
    Registriert seit
    17.07.2009
    Ort
    Am Rande der Ostalb
    Beiträge
    5.480
    Danke
    1.141
    Erhielt 1.240 Danke für 973 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von Rainer Hönle Beitrag anzeigen
    Ist das wirklich notwendig? Ich dachte durch die Konfigurationsänderung geht der Master vom Bus und wenn er wiederkommt initialisiert er die Slaves mit den entsprechenden Parametern.
    Im Zusammenspiel mit OPs am Bus, hab ich mir das angewöhnt. Meist übersetz ich das OP-Projekt auch neu und übertrage es ins OP.

    Gruß
    Dieter

  19. Folgender Benutzer sagt Danke zu Blockmove für den nützlichen Beitrag:

    Wastel (04.01.2011)

Ähnliche Themen

  1. S7 224 OP170B keine Busverbindung
    Von steven_seagal im Forum HMI
    Antworten: 0
    Letzter Beitrag: 11.06.2009, 00:24
  2. OP170B Verbindung zur CPU
    Von Eliza im Forum HMI
    Antworten: 8
    Letzter Beitrag: 24.10.2008, 10:25
  3. Keine Verbindung zum TP 170 A
    Von extra im Forum HMI
    Antworten: 5
    Letzter Beitrag: 03.09.2008, 20:32
  4. Keine MPI Verbindung...
    Von AndreK im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 02.09.2008, 07:51
  5. keine Verbindung zur S5-95U?
    Von Bitte_ein_Bit im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 14.10.2007, 12:13

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •