Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 3 von 3

Thema: Probleme mit Connectivity Pack

  1. #1
    Registriert seit
    17.02.2011
    Beiträge
    40
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen,

    Ich hoffe hier hat jemand eine Idee, oder einen Ansatz für mich.

    Ich greife mit dem Connectivity Pack und VB Funktionen in Excel auf meine WINCC Taglogging Archive zu. Das klappt auch alles ganz gut, solange es Einträge in dieser Zeit gibt.
    Aus der Doku habe ich folgenden sSQL String:
    Code:
     
    "TAG:R,1,'2004-10-13 17:00:00.000','0000-00-00 00:05:00.000', 'TIMESTEP=1,260"
    wobei ja der erste Zeitstempel den Startzeitpunkt und der zweite den Endzeitpunkt angibt. Wie gesagt, so lange es Daten an der Stelle gibt, funktioniert alles gut.
    Wenn ich jetzt auf Daten zugreife, die es nicht gibt, dann hängt sich Excel bei
    Set AobjRecordset = AobjCommand.Execute() auf.

    Hat jemand einen Ansatz, wie ich das Aufhängen, bzw. Abstüzen von Excel abfangen kann?

    Mit freundlichen Grüßen

    Hando0815
    Zitieren Zitieren Probleme mit Connectivity Pack  

  2. #2
    Registriert seit
    17.02.2011
    Beiträge
    40
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Lächeln

    Ich habe das Problem gelöst.

    Habe beim SQL String einfach ein 'WHERE Not RealValue is NULL' eingefügt und schon geht es.

    Da hätte ich auch eher drauf kommen können.
    Danke allen, die sich Gedanken gemacht haben.

    Gruß
    Hando0815

  3. #3
    Registriert seit
    17.02.2011
    Beiträge
    40
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    wie ich geschrieben habe, stürzt Excel durch das Einfügen des Where nicht mehr ab, allerdings dauert die Abfrage von vorhandenen Daten nun ca. 3 mal so lange wie vorher.
    Hat jemand eine Idee, wie ich das anders lösen kann?
    Oder weis jemand, ob es normal ist, das der Befehl so viel länger dauert?

    Gruß

    Hando0815
    Zitieren Zitieren sehr langsam !  

Ähnliche Themen

  1. Universal Connectivity Server erhält UA-Zertifizierung der OPC Foundation
    Von OPCNews im Forum Werbung und Produktneuheiten
    Antworten: 2
    Letzter Beitrag: 10.08.2011, 08:10
  2. Antworten: 0
    Letzter Beitrag: 21.07.2010, 10:32
  3. Kein Pack & Go für OP270 ?
    Von JesperMP im Forum HMI
    Antworten: 6
    Letzter Beitrag: 16.04.2010, 17:33
  4. Erfahrung mit dem Database-Server-Pack von Beckhoff
    Von drfunfrock im Forum CODESYS und IEC61131
    Antworten: 0
    Letzter Beitrag: 28.03.2008, 12:51
  5. STEP 7-Micro/WIN V4.0 Service Pack (SP6)
    Von hydrosla im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 18.12.2007, 11:52

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •