Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 3 von 3 ErsteErste 123
Ergebnis 21 bis 27 von 27

Thema: WinCCflexible mehrere Touchpanels auf eine Steuerung Probleme Variable setzen/rückse.

  1. #21
    Registriert seit
    25.06.2007
    Ort
    Dresden
    Beiträge
    3.930
    Danke
    465
    Erhielt 878 Danke für 634 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von JesperMP Beitrag anzeigen
    Wenn es um "software-Taster" handelt, mache ich es so weit wie möglich so das der Taster setzt die Variabel auf "1".
    Im SPS Program wird der Variabel verwendet um ein Funktion zu aktivieren, oder eine weitere Variabel zu wechseln.
    Schlussendlich wird der HMI-Variabel im SPS Program explicit auf "0" gesetzt.
    Diese Verfahren finde ich etwas umständlich, aber total robust.
    Das ist eigentlich der sicherste Weg, weil er unabhängig von
    dem Aktualisierungszyklus und anderen Unwägbarkeiten ist.

    Frank
    Grüße Frank

  2. #22
    Registriert seit
    22.03.2007
    Ort
    Detmold (im Lipperland)
    Beiträge
    11.797
    Danke
    398
    Erhielt 2.417 Danke für 2.013 Beiträge

    Standard

    Zitat Zitat von bernd81 Beitrag anzeigen
    ... und an den beiden TP´s anstatt den Schalter mit Text zwei normale Button´s für das Ein bzw. Ausschalten.
    Fazit--> hat nix gebracht am MP377 ging es trotzdem nicht.
    Dazu nochmal :
    Wir wissen (jetzt), was du an den TP's gemacht hast und das es da anscheinend funktioniert - was aber hast du an dem MP nun genau gemacht und ... warum dort nicht das Gleiche wie an den TP's ?

    Gruß
    Larry

  3. #23
    bernd81 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    02.07.2010
    Beiträge
    115
    Danke
    17
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Zitat Zitat von Larry Laffer Beitrag anzeigen
    Dazu nochmal :
    Wir wissen (jetzt), was du an den TP's gemacht hast und das es da anscheinend funktioniert - was aber hast du an dem MP nun genau gemacht und ... warum dort nicht das Gleiche wie an den TP's ?

    Gruß
    Larry
    Also ich habe an dem MP377 aus Platzgründen gedacht dort könnte ich 2 Buttons nehmen um das ganze ein bisschen Übersichtlicher zu gestalten. Mit dem einen Button Setze ich die Variable M60.0 und mit dem anderen Rücksetze ich die Variable M60.0 jeweils durch Drücken.
    Ich habe aber auch am MP versucht das ganze mit "Schalter mit Text" zu machen aber dort hat es auch nicht funktioniert.
    Habe anstatt der Buttons auch schon EA Felder benutzt, hat auch nix gebracht. Der Merker 60.0 lässt sich einfach nicht auf dem Touchpanel beschreiben bzw. auslesen.

    Fazit --> meineserachtens liegt es nicht an der Art des Schalters sondern an irgend etwas anderes.

  4. #24
    bernd81 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    02.07.2010
    Beiträge
    115
    Danke
    17
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Zitat Zitat von IBFS Beitrag anzeigen
    Das ist eigentlich der sicherste Weg, weil er unabhängig von
    dem Aktualisierungszyklus und anderen Unwägbarkeiten ist.

    Frank
    Kann schon sein das das der sichere Weg wäre aber dann müsste ich jetzt das ganze SPS Programm umschreiben und das ist schon ein großer Aufwand da es 8 Stationen an dieser Anlage gibt.

  5. #25
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.641
    Danke
    377
    Erhielt 805 Danke für 645 Beiträge

    Standard

    Zitat Zitat von bernd81 Beitrag anzeigen
    Also ich habe an dem MP377 aus Platzgründen gedacht dort könnte ich 2 Buttons nehmen um das ganze ein bisschen Übersichtlicher zu gestalten. Mit dem einen Button Setze ich die Variable M60.0 und mit dem anderen Rücksetze ich die Variable M60.0 jeweils durch Drücken.
    Ich habe aber auch am MP versucht das ganze mit "Schalter mit Text" zu machen aber dort hat es auch nicht funktioniert.
    Habe anstatt der Buttons auch schon EA Felder benutzt, hat auch nix gebracht. Der Merker 60.0 lässt sich einfach nicht auf dem Touchpanel beschreiben bzw. auslesen.

    Fazit --> meineserachtens liegt es nicht an der Art des Schalters sondern an irgend etwas anderes.
    Ich habe parallel Panele und PC RT mit zugang zu dieselben Variabeln. Und Buttons und Schalter und Symbolische E/A. Alles funzt wie erwartet.
    Ja, etwas anders muss der Grund sein aber ohne das ganze Projekt ist es schwierig zu sagen wo es liegt.

    Hast du PLCSIM ?
    Passiert dies auch beim simulieren ?
    Jesper M. Pedersen

  6. #26
    Registriert seit
    22.03.2007
    Ort
    Detmold (im Lipperland)
    Beiträge
    11.797
    Danke
    398
    Erhielt 2.417 Danke für 2.013 Beiträge

    Standard

    Zitat Zitat von bernd81 Beitrag anzeigen
    Also ich habe an dem MP377 aus Platzgründen gedacht dort könnte ich 2 Buttons nehmen um das ganze ein bisschen Übersichtlicher zu gestalten. Mit dem einen Button Setze ich die Variable M60.0 und mit dem anderen Rücksetze ich die Variable M60.0 jeweils durch Drücken.
    Mit der Variante wie im Zitat beschrieben bist du ja auch im Grunde schon auf dem optimalen Weg - das MUSS funktionieren. Ich (und ich glaube auch Jesper und Frank) hadere ja auch nur mit dem Schalter (in diesem Zusammenhang).
    Ich stimme also mit deinem Fazit überein (hatte ich das nicht auch schon gesagt ?).

    Also ... was passiert noch so mit dem M60.0 oder den Bytes und Worten und Doppelworten etc. wo das Ding sonst noch so drinsteckt. Vielleicht hängt es ja sogar mit etwas in dem MP-Projekt zusammen (sehr wahrscheinlich sogar). Was sagt denn die QV-Ausgabe zu dem Thema ?

    Gruß
    Larry

  7. Folgender Benutzer sagt Danke zu Larry Laffer für den nützlichen Beitrag:

    bernd81 (25.05.2011)

  8. #27
    bernd81 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    02.07.2010
    Beiträge
    115
    Danke
    17
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Jetzt habe ich den Hund gefunden!!

    Und zwar habe ich auf dem MP377 eine Rezepturverwaltung wo der Bediener verschiedene Artikel auswählen kann und je nach dem werden die Stationen ein bzw. ausgeschaltet. Diese Rezeptur greift auch auf den Merker 60.0 zu.

    In den Einstellungen der Rezeptur waren die Hacken Variablen synchronisieren und Variablen offline angekreuzt gewesen. Somit konnte ich die Variable über die Buttons nicht ändern.

Ähnliche Themen

  1. Mehrere Eingänge auf eine Variable
    Von Limette im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 26.01.2011, 22:26
  2. Mehrere Bits gleichzeitig setzen bzw. rücksetzen
    Von funkey im Forum Hochsprachen - OPC
    Antworten: 5
    Letzter Beitrag: 18.01.2011, 16:13
  3. Mehrere Netzteile für eine Steuerung
    Von Toki0604 im Forum Schaltschrankbau
    Antworten: 23
    Letzter Beitrag: 29.12.2010, 17:24
  4. WinCC!! über C++ eine Variable für 8sek auf eins setzen
    Von dellamorte-dellamore im Forum HMI
    Antworten: 5
    Letzter Beitrag: 25.09.2005, 11:28
  5. Antworten: 3
    Letzter Beitrag: 23.05.2005, 11:34

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •