Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 7 von 7

Thema: WinCC flexible 2008 RT: Markierung im E/A Feld

  1. #1
    Registriert seit
    01.01.2008
    Beiträge
    104
    Danke
    43
    Erhielt 21 Danke für 19 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen,

    folgendes "Problem": Eine Anlagenvisualisierung läuft unter Flexible 2008 RT SP2 auf einem Touch Panel PC.

    Wenn der Bediener auf ein E/A Feld tippt klappt logischerweise die Bildschirmtastatur auf, der aktuelle Wert im E/A Feld wird markiert und somit beim eingeben eines neuen Wertes gelöscht. Nach betätigen des Enter Buttons bleibt der Cursor in diesem E/A Feld hinter der letzte Zahl stehen. Soweit so gut.

    Wenn man jetzt gleich wieder auf dasselbe E/A Feld tippt wird der Wert nicht mehr komplett markiert, sodass man gleich einen neuen Wert eingeben kann, sondern man verschiebt jetzt nur den Cursor der ja noch im Feld aktiv war. Jetzt muss ich umständlich den Wert mit Backspace löschen um erst dann einen neuen einzugeben zu können.

    Gibt es eine Möglichkeit dass sobald ich auf ein E/A Feld tippe (auch mehrmals hintereinander), immer der komplette Wert markiert wird?

    Ich hoffe ich hab mich verständlich ausgedrückt.
    Gruß
    Da_Basco


    Ich kann über das Wasser laufen,
    weil ich weiß wo die Steine sind... (Rainald Grebe)
    Zitieren Zitieren WinCC flexible 2008 RT: Markierung im E/A Feld  

  2. #2
    Registriert seit
    23.04.2009
    Ort
    Allgäu
    Beiträge
    3.042
    Danke
    241
    Erhielt 863 Danke für 617 Beiträge

    Standard

    Zitat Zitat von Da_Basco Beitrag anzeigen
    Ich hoffe ich hab mich verständlich ausgedrückt.
    Ja finde ich schon.
    Dieses Verhalten hat mich auch schon gestört.
    Eventuell könnte man bei "Wertänderung" die "Bedienbarkeit" wegnehmen, habe aber keine Ahnung ob das funktionieren würde.
    Gruß
    Paule
    ----------------------------------------------------------------------------
    > manchmal verliert man und manchmal gewinnen die anderen <

  3. #3
    Registriert seit
    13.10.2007
    Beiträge
    12.024
    Danke
    2.784
    Erhielt 3.268 Danke für 2.156 Beiträge

    Standard

    Oder vlt bei Eingabe abgeschlossen, das gleiche Bild noch mal aufrufen mit
    dem Fokus auf da letzte Feld. Habe abe auh keine Ahnung ob da jetzt geht.
    - - -
    Wer als Werkzeug nur einen Hammer hat, sieht in jedem Problem einen Nagel.

  4. #4
    Avatar von Da_Basco
    Da_Basco ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    01.01.2008
    Beiträge
    104
    Danke
    43
    Erhielt 21 Danke für 19 Beiträge

    Standard

    Hallo Paule und Helmut,

    was mich verdutzt: Der Bediener hat mich erst drauf hingewiesen und gemeint dass das nicht immer so gewesen ist.
    Sprich dass auch bei mehrmaligen drauftippen immer alles markiert wurde...

    Jetzt grübel ich was ich seitdem geändert habe.
    Ich denke aber nur die RT von SP1 auf SP2 hochgerüstet und damit verbunden den Panel PC von XP Prof SP2 auf SP3.

    Hmmh, alles sehr seltsam...
    Gruß
    Da_Basco


    Ich kann über das Wasser laufen,
    weil ich weiß wo die Steine sind... (Rainald Grebe)

  5. #5
    Registriert seit
    08.01.2009
    Beiträge
    7
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo

    ich möchte in WinCC ein Datenwort (Temperatur) zyklisch aus einem Datenbaustein anzeigen. Wie funktioniert das ?

    Besten Dank im Voraus

  6. #6
    Registriert seit
    22.03.2007
    Ort
    Detmold (im Lipperland)
    Beiträge
    11.708
    Danke
    398
    Erhielt 2.397 Danke für 1.997 Beiträge

    Standard


    Ein Ausgabefeld auf den Bildschirm legen und dann dieses mit dem Datenbaustein und dem Datenwort verknüpfen ...

  7. #7
    Avatar von Da_Basco
    Da_Basco ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    01.01.2008
    Beiträge
    104
    Danke
    43
    Erhielt 21 Danke für 19 Beiträge

    Ausrufezeichen


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Irgendwie lustig. Ich denke ich hab gerade aus Zufall die Lösung für mein Problem gefunden.
    Seit dem WinCC flexible 2008 SP2 Update 10 ist das Problem behoben worden.

    Zitat Siemens:

    Fehlerhaftes Verhalten von EA-Feldern
    In einem Bild verwenden Sie ein EA-Feld im Modus "Eingabe". In Runtime wählen Sie
    das EA-Feld, das bereits einen Text enthält. Bei einer weiteren Eingabe, wird der neue
    Text an den bestehenden angehängt, anstatt den Text zu ersetzen.
    Quelle: http://cache.automation.siemens.com/..._sp2_upd13.pdf
    Gruß
    Da_Basco


    Ich kann über das Wasser laufen,
    weil ich weiß wo die Steine sind... (Rainald Grebe)
    Zitieren Zitieren Die Lösung  

  8. Folgender Benutzer sagt Danke zu Da_Basco für den nützlichen Beitrag:

    rostiger Nagel (10.08.2011)

Ähnliche Themen

  1. WinCC Flexible EA-Feld zweizeilig?
    Von WendeMarkus im Forum HMI
    Antworten: 0
    Letzter Beitrag: 07.07.2011, 00:45
  2. Antworten: 8
    Letzter Beitrag: 14.02.2011, 16:18
  3. Antworten: 6
    Letzter Beitrag: 07.12.2010, 19:20
  4. Antworten: 0
    Letzter Beitrag: 17.11.2006, 12:16
  5. Antworten: 1
    Letzter Beitrag: 30.10.2006, 15:37

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •