Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 5 von 5

Thema: WinCC flexible 2008: Triggervariable für Störmeldungen nicht zuweisbar

  1. #1
    Registriert seit
    27.10.2006
    Ort
    Plauen
    Beiträge
    374
    Danke
    107
    Erhielt 13 Danke für 11 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen,

    ich bin gerade dabei Störmeldungen zu bearbeiten. Dabei ist mir ein sehr merkwürdiges Verhalten meines WinCC flexible aufgefallen:

    ich wollte für mehre Störmeldungen die Triggervariable ändern. Dazu habe ich alle Meldungen ausgewählt und wollte über das Eigenschaftsmenü die entsprechende Variable angeben. Jedoch wird mir die Variable nicht angezeigt.
    Wenn ich eine einzelne Meldung auswähle, wird mir die Triggervariable im Eigenschaftsmenü ebenfalls nicht angezeigt.
    Klicke ich jedoch direkt auf der Störmeldeanzeige (also im Projektierungsfenster) auf die Spalte Triggervariable, wird mir die Variable korrekt angezeigt.

    Hat jemand von Euch dieses Phänomen schon einmal beobachtet?

    Es wäre jetzt arg müsig über 500 Störmeldung einzeln anzupassen und danach vor allem noch das richtige Triggerbit einzutragen.

    Danke schon einmal!
    Step7 V5.5 SP4 HF11
    TIA Portal V14
    WinCC flexible 2008 SP3
    WinCC 7.2 Update 10
    =======================
    Zitieren Zitieren WinCC flexible 2008: Triggervariable für Störmeldungen nicht zuweisbar  

  2. #2
    Registriert seit
    25.11.2008
    Ort
    Westpfalz
    Beiträge
    1.550
    Danke
    187
    Erhielt 212 Danke für 186 Beiträge

    Standard

    Wenn ich mich recht erinnere kannst du einmal die Triggervariable ändern, dann das Feld mit der Variable anklicken und wie bei Excel am Punkt über die 500 Meldungen ziehen.
    and we all support the team (S.King - Die Arena)

  3. Folgender Benutzer sagt Danke zu Sinix für den nützlichen Beitrag:

    Grimsey (06.07.2011)

  4. #3
    Avatar von Grimsey
    Grimsey ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    27.10.2006
    Ort
    Plauen
    Beiträge
    374
    Danke
    107
    Erhielt 13 Danke für 11 Beiträge

    Standard

    Jup damit gehts schon mal. Aber ist ja trotzdem komisch das mir die Variable nicht immer korrekt angezeigt wird, oder?

    Wer weiß was da wieder faul ist...
    Step7 V5.5 SP4 HF11
    TIA Portal V14
    WinCC flexible 2008 SP3
    WinCC 7.2 Update 10
    =======================

  5. #4
    Registriert seit
    09.02.2010
    Beiträge
    13
    Danke
    1
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Wird die Variable im Eigenschaftsmenü bei Trigger einfach nicht angezeigt oder kannst du da auch keine auswählen ?

    Wenn du mehrere markiert hast und es sind verschiedene Variablen hinterlegt kann das durchaus sein das nichts drinn steht.

    Ich habs grade versucht bei den Bitmeldungen mehrere zu markieren, es steht im Eigenschaftsfenster drinnen und ich kann auch darüber eine zuordnen, egal ob dich die Meldezeile oder nur die Triggervariable markiert habe.

  6. #5
    Avatar von Grimsey
    Grimsey ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    27.10.2006
    Ort
    Plauen
    Beiträge
    374
    Danke
    107
    Erhielt 13 Danke für 11 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Es waren alles Störmeldungen, denen noch keine Variablen zugewiesen war. Demnach wurde auch im Eigenschaftsfeld nichts angezeigt. Soweit ok. Aber wenn man dann auf das Feld klickt, öffnet sich doch ein Fenster wo man entweder auf die bereits angelegten Variablen oder auf die aus den DBs zugreifen kann. Und da werden mögliche Variablen (Datentyp Word) nicht angezeigt. Es spielt dabei auch keine Rolle, ob ich mehrere Meldungen ausgewählt habe oder nur eine.
    Erst wenn ich in die Spalte "Triggervariable" (nicht unter "Eigenschaften" der Meldungen) klicke, öffnet sich wieder das Fenster und diesmal bekomme ich mögliche Variablen angezeigt.

    Eigentlich sollte man die Triggervariable ja an jeder Stelle, an der man Zugriff auf diese hat, ändern können. Dies halt bei mir nicht der Fall.

    Die Variablen habe ich jetzt soweit alle zugewiesen. Ist halt nur ein komisches Phänomen.
    Step7 V5.5 SP4 HF11
    TIA Portal V14
    WinCC flexible 2008 SP3
    WinCC 7.2 Update 10
    =======================

Ähnliche Themen

  1. WinCC flexible 2008 Komuniziert nicht mit PLCSim
    Von robiotor im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 22.09.2011, 21:07
  2. Antworten: 5
    Letzter Beitrag: 10.02.2011, 19:42
  3. WinCC flexible Störmeldungen
    Von Blade81 im Forum HMI
    Antworten: 1
    Letzter Beitrag: 29.09.2010, 18:53
  4. Antworten: 2
    Letzter Beitrag: 15.06.2010, 23:45
  5. Antworten: 6
    Letzter Beitrag: 15.02.2010, 15:08

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •