Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 8 von 8

Thema: Migration TP27 --> MP277 Kakteenbilder

  1. #1
    Registriert seit
    10.02.2009
    Beiträge
    115
    Danke
    15
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo, ich habe folgendes Problem nach der Migration eines TP27 Projektes auf ein MP277. Und zwar wird bei einigen Bildern die in Abhängigkeit einer Variable erscheinen ein hübsches Kakteenbild angezeigt wenn die Variable einen in der Grafikliste nicht definierten Wert animmt . Ich weiß dass das Kakteenbild erscheint wenn eine Grafik nicht vorhanden ist, aber die Grafik ist wie beim TP27 vorhanden und soll auch bei den selben Wertigkeiten erscheinen. Beim TP27 ist der Platz der Grafik bei einem Wert ausserhalb des definierten Bereichs jedoch einfach nur Weiß und beim MP277 erscheint der Kaktus. Hat jemand ne Idee wie ich das umgehen kann? Vielen Dank
    Zitieren Zitieren Migration TP27 --> MP277 Kakteenbilder  

  2. #2
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.197
    Danke
    926
    Erhielt 3.292 Danke für 2.661 Beiträge

    Standard

    Füge bei den Grafiklisten eine weiße Grafik hinzu und aktiviere für den Eintrag die Option "Standard" (oder schreibe bei Wert: "Default").

    Zitat aus der WinCCflexible Hilfe:
    Standardbereichstyp des Eintrags
    Mit dieser Option legen Sie einen Standardwert für eine Textliste oder eine Grafikliste fest.

    Auswahl "Bereich (...-...)": Der Standardwert wird angezeigt, wenn der Wert der verbundenen Variable außerhalb des definierten Bereichs liegt.

    Auswahl "Bitnummer (0-31)": Der Standardwert wird angezeigt, wenn mindestens zwei Bits gesetzt sind, die beide projektiert sind. Wenn "Bitauswahl in Text- und Grafiklisten" aktiviert ist, wird der Standardwert angezeigt, wenn kein Bit ist gesetzt oder beim gesetzten Bit mit der kleinsten Wertigkeit kein Text oder keine Grafik projektiert ist.

    Der Standardwert ist sprachabhängig und muss für jede verwendete Sprache projektiert werden.
    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet
    Zitieren Zitieren Listen-Defaultwert  

  3. #3
    Registriert seit
    13.09.2010
    Beiträge
    2.292
    Danke
    178
    Erhielt 375 Danke für 355 Beiträge

    Standard

    Hallo zusammen,

    hatte bei einer Migration von OP37 (ProTool) auf MP 277 (flex) das gleiche Problem.
    Die Grafiksymbole in ProTool sind bei "1" erschienen und waren bei "0" unsichtbar.
    Bei Flex müssen aber beide Werte ("0" und "1") definiert sein, sonst erschien der Kaktus.

    Es fehlt also an der Definition des 2. Wertes.
    --> Also: grafiklisten um die fehlenden Werte erweitern !

    Grüsse
    kind regards
    SoftMachine

  4. Folgender Benutzer sagt Danke zu SoftMachine für den nützlichen Beitrag:

    MaurerT (19.07.2011)

  5. #4
    MaurerT ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    10.02.2009
    Beiträge
    115
    Danke
    15
    Erhielt 0 Danke für 0 Beiträge

    Standard

    OK, danke für die Tipps. Werde das am Montag gleich mal testen.

  6. #5
    Registriert seit
    13.09.2010
    Beiträge
    2.292
    Danke
    178
    Erhielt 375 Danke für 355 Beiträge

    Standard

    Hallo,

    da gibt es nochwas für Dich:

    http://support.automation.siemens.co...docid=10448126

    denke, das hilft dir weiter !

    Gruss
    kind regards
    SoftMachine
    Zitieren Zitieren Anleitung  

  7. Folgende 2 Benutzer sagen Danke zu SoftMachine für den nützlichen Beitrag:

    MaurerT (19.07.2011),S_Everz (16.07.2011)

  8. #6
    Registriert seit
    13.09.2010
    Beiträge
    2.292
    Danke
    178
    Erhielt 375 Danke für 355 Beiträge

    Standard

    Hier, ehe du suchen musst:

    Kapitel 6.2:

    Tritt ein ungültiger Wert in einer Symbolliste auf, wird bei Grafikgeräten nichts
    in der Symbolliste angezeigt, bei einem Windows-basierten System werden
    ### oder ein Kakteenbild angezeigt

    gruss

    kind regards
    SoftMachine

  9. #7
    Registriert seit
    02.11.2010
    Ort
    Bergisches Land
    Beiträge
    101
    Danke
    40
    Erhielt 24 Danke für 13 Beiträge

    Standard

    Hallo, das ist ein Problem wenn Daten auf dem MP aufgezeichnet werden. Abhilfe hier schafft der Update aufs aktuelle Hotfix und dann das Betriebssystem Update auf dem Panel. Hatte das auch schon gehabt.

  10. #8
    MaurerT ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    10.02.2009
    Beiträge
    115
    Danke
    15
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo, Problem ist gelöst. Die Definition des Default Wertes war die Lösung. Nochmal vielen Dank für die Infos.

Ähnliche Themen

  1. Biete Touch Panel TP27
    Von *chris* im Forum Suche - Biete
    Antworten: 0
    Letzter Beitrag: 21.09.2011, 15:09
  2. Biete Touchpanel Siemens Simatic TP27
    Von HansAmBau im Forum Suche - Biete
    Antworten: 0
    Letzter Beitrag: 15.07.2010, 19:54
  3. Biete Touch Panel TP27 10 Zoll
    Von HansAmBau im Forum Suche - Biete
    Antworten: 0
    Letzter Beitrag: 22.08.2009, 09:57
  4. Biete S5 Komplettsets / TP27
    Von HansAmBau im Forum Suche - Biete
    Antworten: 0
    Letzter Beitrag: 22.03.2009, 17:01
  5. Seitenumschaltung TP27-6C
    Von mzva im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 05.09.2006, 22:58

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •