Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 2 ErsteErste 12
Ergebnis 11 bis 19 von 19

Thema: Smart Access über Telefonleitung

  1. #11
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.207
    Danke
    927
    Erhielt 3.293 Danke für 2.662 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von Cutty Beitrag anzeigen
    Ich habe schon richtig Angst dir nochwas zu schreiben, da ich anscheinend jetzt schon deine Nerven überstrapaziere...aber ich probiere es dennoch .
    Hallo Cutty,
    Du strapazierst meine Nerven nicht - würde ich mir dann die Zeit nehmen, Beiträge zu Deinem Thema zu schreiben? - Du schriebst nur bisher salopp am wesentlichen vorbei, ohne die Nachfragen zu beantworten.
    Doch nun wissen wir ja, was Du willst.

    Für 1. allein bräuchstest Du einfach nur einen TS-Adapter, der an Deiner Anlage die Telefonleitung mit der MPI- oder DP-Schnittstelle verbindet und TeleService auf Deinem PG für die Telefonanwahl. Dann könntest Du das Programm in der CPU beobachten und ändern und auch eine Projektierung auf das Panel transferieren. Am einfachsten wird der Transfer, wenn das TP177 mit der selben Schnittstelle der CPU verbinden ist wie der TS-Adapter. Wenn das Panel über eine andere Schnittstelle mit der CPU verbunden wäre (z.B. Ethernet), dann könntest Du trotzdem eine Projektierung auf das Panel laden, dann müßtest Du einfach nur das S7-Routing durch die CPU nutzen (bin mir aber jetzt nicht sicher, ob Siemens nicht ausgerechnet beim TP177 den S7-Routing-Transfer wieder gestrichen hat - bei irgendeinem Panel war da sowas). Auf dem Panel bräuchtest Du keinerlei zusätzliche Lizenz, Du müßtest lediglich den automatischen Transfer für den MPI/Profibus-Kanal freischalten.
    TS-Adapter auf MPI/Profibus gibt es außer von Siemens auch von einigen anderen Anbietern.
    Für 1. könntest Du auch einen TS-Adapter IE oder einen DFÜ-Einwahlrouter nutzen. Dann ändert sich nur die Einstellung des PG/PC-Zugangspunktes S7ONLINE auf TCP/IP<netzwerkkarte>.

    Wenn Du einen TS-Adapter IE oder eben einem DFÜ-Einwahlrouter (den Du ja erfolgreich hast) auf das Ethernet der Anlage benutzt und die CPU und das Panel mit dem Ethernet verbunden sind, dann kannst Du zusätzlich 2. das TP177B mit einem VPN-Client oder dem Siemens Sm@rtClient fernsteuern und somit Deine Anlage fernbeobachten und fernsteuern. Dazu mußt Du lediglich auf dem Panel den Sm@rtServer starten (Häkchen in den Geräteeinstellungen der WinCCflex-Projektierung) und im Control Panel des TP177B die Zugangspasswörter einrichten. Und Du mußt auf dem Panel eine Lizenz für den Sm@rtServer installieren. Ohne die Lizenz funktioniert das ganze zwar auch, doch dann kommt alle paar Minuten ein Hinweis in der Panel-Runtime, daß die Lizenz nicht vorhanden ist. Was kommt nach dem Häkchen für "Sm@rtServer starten" am Ende des WinCCflex Generierungslauf für eine Meldung?
    Erforderliche Lizenz: Entweder WinCC flexible /Sm@rtAccess for Panel oder WinCC flexible /Sm@rtService for Panel
    Du kannst Dir also aussuchen, ob Du die Lizenz für Sm@rtAccess oder Sm@rtService kaufst und installierst, doch eigentlich ist das eine typische Anwendung für Sm@rtService. Sm@rtAccess ist zwar für andere Sachen gedacht, kostet aber weniger - daher also die Empfehlung Sm@rtAccess.

    Wenn Du selber eine DFÜ-Verbindung auf Deinem PG einrichten kannst, dann brauchst Du kein Teleservice auf dem PG. Teleservice ist allerdings nützlich, wenn Du Dich für die Fernwartungssitzung vom TS-Adapter rückrufen lassen willst.

    Zu 3.
    Um Deine Anlage mit der projektierten Bedien-Oberfläche des Panels fernzusteuern mußt Du nicht unbedingt das reale Panel fernsteuern - brauchst dann also keine Fernsteuer-Lizenz! Du kannst auch eine DFÜ-Einwahlverbindung zum Anlagen-Netzwerk aufbauen und dann die WinCCflex-Runtime-Simulation des Panels auf Deinem PG starten. Da das TP177B keine Scripte kann, kann Deine Projektierung eigentlich nichts enthalten, was bei der Panel-Simulation unter Windows anders oder gar nicht funktioniert. Die Verbindung zur CPU muß aber als IE-Verbindung projektiert sein.
    Die PG/PC-Schnittstelle auf Deinem PG wird auf TCP/IP<netzwerkkarte> eingestellt, die PG-Schnittstelle bzw. Windows versucht dann den Verbindungsaufbau zur CPU der Anlage über alle aktiven LAN-Adapter. Die IP-Adressen der Anlage müßen sich von den lokalen Netzwerken unterscheiden, die Du sonst noch über Dein PG erreichen kannst. Das scheint bei Dir der Fall zu sein, da Du ja Deine CPU und das Panel anpingen kannst.
    Wichtig: auf keinen Fall TCP/IP(Auto) einstellen!

    Vorteil von 3. gegenüber 2.:
    + Du brauchst keine zusätzliche Lizenz auf dem TP177
    + besonders bei Verbindung über Telefonleitung wird die Fernsteuerung flüssiger, weil nicht der Bildschirminhalt des Panels über die Leitung übertragen werden muß, sondern nur die reine Variablen-Kommunikation

    Nachteil:
    - man kann nicht die realen Meldepuffer und Archive und Trendkurven des Panels der Anlage einsehen, da man ja eine eigene "Instanz" des Panels benutzt


    Hab ich noch was vergessen? Oder hast Du Detailfragen? Frag einfach.
    Jetzt wäre eigentlich der Zeitpunkt, wo Du schilderst, was genau "nicht geklappt" hat, obwohl Du die DFÜ-Verbindung zum Einwahlrouter erfolgreich eingerichtet hast.

    Gruß Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  2. Folgender Benutzer sagt Danke zu PN/DP für den nützlichen Beitrag:

    Cutty (04.08.2011)

  3. #12
    Cutty ist offline Benutzer
    Themenstarter
    Registriert seit
    14.04.2011
    Beiträge
    51
    Danke
    13
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Hallo Harald,

    vielen vielen Dank .

    Ich bin heute nicht im Büro, deshalb kann ich keine Tests machen, habe aber trotzdem noch Fragen:

    Nachteil:
    - man kann nicht die realen Meldepuffer und Archive und Trendkurven des Panels der Anlage einsehen, da man ja eine eigene "Instanz" des Panels benutzt
    Kann ich also nicht in Echtzeit Trendkurven betrachten oder wie ist das gemeint? Das Starten der Runtime auf dem PG funktioniert und ich kann auch darüber meine Anlage ansteuern. Dann würde diese Variante ja wirklich ausreichen. Der Unterschied zwischen Steuerung des realen Panels und Steuerung meiner Anlage über das simulierte Panel ist mir zwar irgendwie klar, aber ob ich nun mein Panel ansteuere oder meine Anlage über das Panel ist doch eigentlich egal, oder? Die Funktion und das erreichte Ergebnis ist doch im Endeffekt gleich, oder? Der Sinn des Smart Access hat sich mir auch noch nicht so richtig erschlossen, aber das liegt wohl daran, dass ich noch keine entsprechende Applikation entworfen habe...

    Danke erstmal...ich melde mich dann später wieder.

    Gruß Cutty
    Geändert von Cutty (03.08.2011 um 14:31 Uhr)

  4. #13
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.207
    Danke
    927
    Erhielt 3.293 Danke für 2.662 Beiträge

    Standard

    Zitat Zitat von Cutty Beitrag anzeigen
    Kann ich also nicht in Echtzeit Trendkurven betrachten oder wie ist das gemeint?
    Doch, Du kannst auch Trendkurven (Echtzeit oder aus Archiv) betrachten, aber erst ab dem Zeitpunkt, ab dem Deine Panel-Simulation mit der fernen Anlage verbunden ist (mal von der Variablen-Aktualisierungszeit über Telefonleitung abgesehen). Was vor der Anwahl der Anlage passiert ist, kann die Panel-Simulation natürlich nicht aufzeichnen - aber das real an der Anlage vorhandene Panel weiß es und hat es ggf. aufgezeichnet. Wenn Du also wissen mußt, was während Deiner Abwesenheit von der Anlage passiert ist, dann müsstest Du das reale Panel fernsteuern oder ein Ereignisprotokoll in der SPS programmieren und in einem DB ablegen, welchen Du dann von fern auslesen könntest.

    ob ich nun mein Panel ansteuere oder meine Anlage über das Panel ist doch eigentlich egal, oder? Die Funktion und das erreichte Ergebnis ist doch im Endeffekt gleich, oder?
    Ja, wenn Du auf die angesprochenen älteren Daten verzichten kannst.

    Das Starten der Runtime auf dem PG funktioniert und ich kann auch darüber meine Anlage ansteuern. Dann würde diese Variante ja wirklich ausreichen.
    Herzlichen Glückwunsch! Dann hast Du die schwierigsten Hürden schon gemeistert.
    Wenn Du mit dieser Variante zufrieden bist und die Daten von vor Deiner Anwahl nicht brauchst, dann ist das eine schöne Möglichkeit für gelegentliche Fernwartung. Strenggenommen und besonders bei regelmäßigem Gebrauch will Siemens aber auch für diese Variante Geld sehen - Du bräuchtest eine viel teurere WinCCflex-Runtime Lizenz.

    Diese Panel-Simulation zum Testen der WinCCflex-Projektierung ist übrigens eine feine Sache bei Anlagen-Inbetriebnahmen oder Störungssuchen. Man hat praktisch immer ein tragbares Bedienpanel der Anlage bei sich und kann bei WLAN-Anbindung des PG damit in der Anlage rumlaufen. Und man hat eine Notfall-Lösung zum Bedienen der Anlage, wenn z.B. mal wieder ein Staplerfahrer nicht rechtzeitig vor dem Touchpanel bremsen konnte ...

    Der Sinn des Smart Access hat sich mir auch noch nicht so richtig erschlossen
    Das geht auch anderen Leuten so , weil Siemens unbedingt 2 Zusatzoptionen erfinden mußte, dann den Funktionsumfang der Optionen Sm@rt Access und Sm@rt Service nicht sauber getrennt hat und noch dazu Sm@rt Access billiger anbietet. Schaue Dir mal diesen Thread an, dann wird Dir bestimmt einiges klarer.

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  5. Folgender Benutzer sagt Danke zu PN/DP für den nützlichen Beitrag:

    Cutty (04.08.2011)

  6. #14
    Cutty ist offline Benutzer
    Themenstarter
    Registriert seit
    14.04.2011
    Beiträge
    51
    Danke
    13
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Hallo Harald,

    danke für die Infos...langsam verstehe ich

    Also, ich habe jetzt das Häkchen gesetzt und das Projekt generiert. Ich habe in den WinCC Internet Settings meine Passwörter eingerichtet und Smart Client gestartet. Siehe da, ich kann auf das Panel zugreifen . Was mich wundert: in dem Fenster steht oben "WinVNC". Benötigt Smart Access das VNC-Programm, damit das läuft ?

    Naja, jedenfalls sehe ich zwar das Panel, wenn ich dann aber auf "Start" klicke, um meine Benutzeroberfläche anzuschaun, kommt diese Fehlermeldung (ohne Nummer): Connection failed: Local loop-back connections are disabled. Disconnected.

    Ich kann das Panel anpingen, kann aber keinen Transfer durchführen. Liegt es vielleicht daran? Wegen dem S7-Routing hab ich mal gegoogelt und mit meinem Touch Panel ist es nicht möglich...also hat sich das dann wies scheint schon erledigt. Aber irgendwie muss es doch möglich sein, die Projektierung zu übertragen????? Danke schonmal im Voraus .

    Gruß Cutty
    Geändert von Cutty (04.08.2011 um 10:59 Uhr)

  7. #15
    Cutty ist offline Benutzer
    Themenstarter
    Registriert seit
    14.04.2011
    Beiträge
    51
    Danke
    13
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Hallo Harald,

    gibt es noch andere Möglichkeiten, die Projektierung zu übertragen, außer Smart Access einzurichten? Muss ich für die Übertragung meiner Benutzeroberfläche zwingend eine Smart Client-Anzeige einfügen? Vielen Dank im Voraus.

    Gruß Cutty

  8. #16
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.207
    Danke
    927
    Erhielt 3.293 Danke für 2.662 Beiträge

    Standard

    Hallo Cutty,

    sorry, doch wie oft soll ich noch schreiben, daß man zum Transfer der Projektierung KEINE ZUSÄTZLICHE Software auf dem Panel einrichten muß? Und wann bitte ziehst Du Dir mal rein, was und wofür Smart Access ist?

    Bevor Du hier noch mehr uralte Themen hochziehst wollen wir lieber mal Schritt für Schritt vorgehen.

    Nein, Du mußt keine SmartClient-Anzeige in Deine Benutzeroberfläche einfügen. Die SmartClient-Anzeige ist dafür da, um mit dem Panel andere Panels fernzusteuern und ist im Grunde einfach nur ein VNC-Viewer. Brauchst Du das? wenn nein, dann rausschmeißen. Die SmartClient-Anzeige hat mit dem Transfer NICHTS zu tun und verwirrt Dich nur.

    Mit Smart Access einrichten meinst Du doch sicherlich, den SmartServer zu aktivieren und Zugangspasswörter einzurichten? Das brauchst Du nur dafür, um das Panel übers Netzwerk mit dem SmartClient-Programm oder irgendeinem VNC-Client fernzusteuern. Das hat mit dem Transfer der Projektierung ebenfalls NICHTS zu tun.

    Damit man übers Ethernet-Netzwerk einen Transfer auf das Panel durchführen kann, muß man einfach nur
    - das Panel mit einem LAN verbinden
    - am Panel eine zum LAN passende IP-Adresse + Subnetzmaske und ein Standardgateway/Router einstellen
    - am Panel den Transferkanal "Ethernet" erlauben
    - für den Transferkanal "Ethernet" den automatischen Übergang in den Transfermodus aktivieren
    - eine Runtime auf das Panel transferieren und sie muß gestartet sein

    Hast Du auf dem Panel schon eine Runtime drauf und läuft die?
    Die automatische Umschaltung in den Transfermodus geht nur aus der laufenden Runtime.
    Beim ersten Transfer oder nicht laufender Runtime muß man das Panel manuell in den Transfermodus schalten.

    - dem Projektier-PG eine zum LAN passende IP-Adresse geben
    - auf dem Projektier-PG die PG/PC-Schnittstelle einstellen: S7ONLINE(STEP7) -> TCP/IP -> <name_der_Netzwerkkarte>

    Auf keinen Fall TCP/IP(Auto) einstellen! Wenn das eingestellt war, dann nach dem Umstellen zunächst das PG neu starten (Windows neu booten).

    - in WinCCflex auf Transfer gehen, den Transferkanal "Ethernet" auswählen und die IP-Adresse des Panels eingeben

    Wenn Dein PG vorort am LAN der Anlage steckt, dann muß der Transfer nun funktionieren.
    Wenn nicht, dann ist irgendeine Einstellung am Panel, am PG oder das Netzwerk falsch konfiguriert.
    - passen die IP-Adressen und Subnetzmasken zueinander?
    - kann das Panel vom PG angepingt werden?
    - Ist es wirklich das Panel, was auf den Ping antwortet? Netzwerkkabel vom Panel abziehen - fällt die Ping-Antwort nun aus?
    - Verhindert eine Desktop-Firewall auf dem PG den Transfer?
    - Kann mit ProSave der Gerätestatus des Panel gelesen werden?

    Wenn Du von fern den Transfer durchführen willst, dann unterscheidet sich das Vorgehen nur dadurch, daß der Transfer nun über einen Router läuft. Im Panel muß zwingend die lokale IP-Adresse des Routers (LAN-Seite) als Gateway eingetragen sein. Die IP-Adresse des Gateways muß im selben durch die Subnetzmaske festgelegten Netzwerk wie das Panel liegen.
    Für den Transfer von fern mußt Du Dich zunächst mit dem Netzwerk der Anlage verbinden. Du hast geschrieben, daß Du Dich mit einer DFÜ-Verbindung in die Anlage einwählst und das auch funtioniert. Du hast auch geschrieben, daß Du das Panel anpingen kannst. Nochmal: ist es tatsächlich das Panel, von dem die Ping-Antworten kommen?
    Im Zweifelsfall kann man "tracert" oder "pathping" benutzen, um den Weg des Ping zu kontrollieren.

    Du hast geschrieben
    Das Starten der Runtime auf dem PG funktioniert und ich kann auch darüber meine Anlage ansteuern.
    Hast Du das von fern über die DFÜ-Verbindung gemacht? Dann ist an Deinem PG alles richtig eingestellt.
    Du müßtest auch mit Step7 auf die CPU kommen und das Programm beobachten können.

    Wenn der Transfer immer noch nicht funktioniert, dann nochmals die Einstellungen am Panel kontrollieren.
    Wenn alles richtig ist, dann könnte irgendwas im Übertragungsweg den Port 102 oder den Port 2308 blockieren oder verbiegen. Eine eventuell vorhandene Desktop-Firewall auf dem PG kontrollieren, ob diese den Transfer blockiert. Den Einwahlrouter kontrollieren, ob da womöglich eine störende Portweiterleitung eingerichtet ist.

    So, mehr fällt mir im Moment nicht ein, was noch zu beachten ist.

    Probiere und analysiere nochmals.

    Falls der Transfer immer noch nicht funktioniert:
    Bei welchem Schritt klemmt es? Gibt es Fehlermeldungen? Wie lauten die? Bedenke, wir können nicht sehen was Du siehst und was Du tust. Schreibe auch, was Du erfolgreich oder nicht erfolgreich ausprobiert hast.
    Schreibe auch mal, welche IP-Adressen/Subnetzmasken/Gateways Du für das Panel, die CPU und Dein PG vergeben hast. Die öffentliche IP-Adresse des Einwahlrouters schreibe hier NICHT, sonst bekommst Du ungebetene Hilfe zur Einwahl auf Deine Anlage.

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  9. Folgender Benutzer sagt Danke zu PN/DP für den nützlichen Beitrag:

    Cutty (11.08.2011)

  10. #17
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.207
    Danke
    927
    Erhielt 3.293 Danke für 2.662 Beiträge

    Standard

    Zitat Zitat von Cutty Beitrag anzeigen
    Connection failed: Local loop-back connections are disabled. Disconnected.
    Hattest Du nach dem Häkchen für SmartServer starten die Runtime-Simulation auf Deinem PG gestartet? Dann wird normalerweise auch ein SmartServer auf dem PG gestartet und Du hast vielleicht versucht, SmartClient mit dem SmartServer auf Deinem PG zu verbinden statt mit dem Panel.
    Schau unten rechts in den Systemtray von Windows und beende den SmartServer.

    Wenn es das nicht war, dann weiß Google noch eine Menge über diese Fehlermeldung.

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  11. Folgender Benutzer sagt Danke zu PN/DP für den nützlichen Beitrag:

    Cutty (23.08.2011)

  12. #18
    Cutty ist offline Benutzer
    Themenstarter
    Registriert seit
    14.04.2011
    Beiträge
    51
    Danke
    13
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Ist ja gut, ist ja gut...ich weiß, es ist schwierig mit mir .

    Also ich werde nochmal alles probieren und analysieren . Ich danke dir schon jetzt wie verrückt für deine Hilfe. Es ist das allererste mal, dass ich mich überhaupt mit WinCC und Fernwartung beschäftige und da prasselt ganz schön viel auf einen ein...also bitte nicht böse sein...

    Ich habe nach deinen Ausführungen nun den dringenden Verdacht, dass es am Standardgateway des Panels liegt. Ich werde es bei Gelegenheit ausprobieren und dir sofort berichten. danke danke danke

    Gruß Cutty

  13. #19
    Cutty ist offline Benutzer
    Themenstarter
    Registriert seit
    14.04.2011
    Beiträge
    51
    Danke
    13
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Harald, es funktioniert!!!! *juhu*

    Sorry, dass es erst so spät kommt, aber ich war noch an einem anderen Problem dran.

    Es lag am Eintrag des Standardgateways und daran, dass der Smartserver auf meinem PG gestartet war. Zu meinem Ärgernis startet dieser immer automatisch beim Hochfahren des PG und bis ich das bemerkt habe, war ich schon am Verzweifeln . Außerdem lief die Runtime aus unerfindlichen Gründen auf dem Panel nicht mehr. Also hab ich nochmal alles lokal transferiert, Smart Server auf dem PG beendet, dann wieder umgesteckt und meine DFÜ-Verbindung gestartet und siehe da: es lief!

    Hach was bin ich glücklich und dir Harald danke ich tausendmal für deine Bemühungen .

    Gruß Cutty

Ähnliche Themen

  1. RWE Smart Home
    Von thomass5 im Forum Gebäudeautomatisierung
    Antworten: 76
    Letzter Beitrag: 28.11.2013, 19:51
  2. Panel über Web Access einbinden
    Von Teimo im Forum HMI
    Antworten: 0
    Letzter Beitrag: 14.09.2011, 09:59
  3. Antworten: 6
    Letzter Beitrag: 06.12.2010, 13:22
  4. Smart Service
    Von mitchih im Forum HMI
    Antworten: 1
    Letzter Beitrag: 21.01.2009, 22:22
  5. PC-SPS-Datenverbindung über Telefonleitung???
    Von Anonymous im Forum Elektronik
    Antworten: 6
    Letzter Beitrag: 27.02.2006, 13:04

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •