Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 6 von 6

Thema: WinCC Rezeptur und Variablen Probleme

  1. #1
    Registriert seit
    20.06.2011
    Beiträge
    11
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo!

    Ich habe ein TP177B mit WinCC und arbeite auf eine S7 317 PN/DP mit dem Tp über PN.

    Mein Problem auf WinCC ist, wenn ich eine Rezeptur für eine Anlage habe, in der 11 Werte gespeichert werden sollen und ich diese Werte in meinen Bildern mit schiebereglern einstellen soll, wie übernehme ich diese in die Rezeptur?!

    Die Rezeptur hat schon alle Variablen drin, die ich bearbeiten kann. Sobald diese aber in der Rezeptur sind, werden die Variablen nicht automatisch beim bearbeiten mit dem Schieberegler an die SPS gesendet, das muss ich dann machen mit "RezepturanzeigeSchreibeDatensatzInSteuerung" und es geht auch nur wenn irgendwo aktiv eine Rezepturanzeige ist.

    Das habe ich geschafft mit einer Rezepturanzeige auf dem gleichen Bild, aber das finde ich sinnlos bei mir. Dann habe ich die Rezepturanzeige in die Vorlage gesteckt, hat auch geklappt, war halt nur immer "im weg" das Ganze.

    Wenn ich die RezepturAnzeige unsichtbar mache, werden die Variablen an die SPS geschickt, aber nicht in der Rezepturanzeige gespeichert! Dort steht dann also immernoch der Startwert drin.

    Was ich also brauche:

    Variablen (MW) schicke ich an die SPS und die gleichen MW sind in der Rezepturanzeige. Die Aktuellen MW sollen dann auch dort sichtbar sein und abspeicherbar sein. Habe irgendwie noch nicht die passende Lösung gefunden!

    Danke schonmal für eure Hilfe!


    Gruß
    Zitieren Zitieren WinCC Rezeptur und Variablen Probleme  

  2. #2
    Registriert seit
    28.02.2006
    Ort
    Ostsee 5 min zum Strand
    Beiträge
    780
    Danke
    92
    Erhielt 110 Danke für 98 Beiträge

    Standard

    Ist der Haken "Variablen synchronisieren" raus? Zu finden unter Eigenschaften, Einstellungen bei der Rezeptur
    Gruß von der Ostsee

    Nordischerjung
    _____________________

    Wenn man seinem Paßbild ähnlich zu sehen beginnt, sollte man schleunigst Urlaub machen. (Vico Torriani, schw. Entertainer)

    Ich habe eine Diät gemacht und fettem Essen und Alkohol abgeschworen - in zwei Wochen verlor ich 14 Tage. (Joe E. Lewis)

  3. #3
    advbug ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    20.06.2011
    Beiträge
    11
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo,

    Der Haken ist gesetzt.


    Gruß
    Geändert von advbug (16.09.2011 um 16:46 Uhr)

  4. #4
    advbug ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    20.06.2011
    Beiträge
    11
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Problem besteht weiterhin, jemand noch Ideen?

  5. #5
    Registriert seit
    13.10.2007
    Beiträge
    12.038
    Danke
    2.789
    Erhielt 3.273 Danke für 2.159 Beiträge

    Standard

    Das könnte vlt ein Problemm mit der Rezepturverwaltung im Allgemeinen sein.
    Versuche doch mal bitte die Rezepturverwaltung in ein separaten Bild zu
    projektieren, dann gehe als erstes in dieses Bild und lege am besten einen
    Datensatz an. Jetzt ändere mal in deinen Übersichtsbilder die Werte, nun gehst
    du wieder in die Rezepturverwaltung und speicherst.

    Die Rezepturverwaltung hat die dumme Eigenschaft, das sie beim ersten Aufruf
    die Variabeln mit werten aus der Rezeptur überschreibt. Bereits getätigte
    Eingaben gehen dann verloren.

  6. #6
    advbug ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    20.06.2011
    Beiträge
    11
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    So, Problem nun ist dass die Rezepturanzeige in ihrem eigenen Bild beim aufrufen immer die Variablen setzt!

    Habe einen workaround gemacht:

    In der SPS wird das MOVE der MW in das PAW unterbrochen wenn das Bild mit der Rezepturanzeige geöffnet wird. Gleichzeitig wird ein MOVE der AW'er in die MW zurück gestartet. So werden die MW zwar kurzzeitig auf standardwerte gesetzt von der Rezeptursteuerung, aber sofort wieder die aktuellen AW geladen und werden somit auch in der Rezepturanzeige richtig angezeigt (aktuelle Werte vor dem Aufruf der Rezepturanzeige!)


    Vielleicht hilft das ja jemandem mal weiter...

Ähnliche Themen

  1. WinCC flexible/Rezeptur/Eingabe
    Von c.wehn im Forum HMI
    Antworten: 7
    Letzter Beitrag: 31.03.2013, 16:37
  2. WinCC flexible Rezeptur erstellen
    Von iPDI im Forum HMI
    Antworten: 7
    Letzter Beitrag: 09.04.2010, 14:10
  3. WinCC Flex 2008 Rezeptur Probleme
    Von sps-welt im Forum HMI
    Antworten: 8
    Letzter Beitrag: 02.06.2009, 09:41
  4. Antworten: 4
    Letzter Beitrag: 18.01.2008, 17:29
  5. Antworten: 0
    Letzter Beitrag: 04.07.2007, 15:59

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •