Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 3 ErsteErste 123 LetzteLetzte
Ergebnis 11 bis 20 von 23

Thema: Verändernde Variablen werden als ### angezeigt

  1. #11
    Registriert seit
    22.03.2007
    Ort
    Detmold (im Lipperland)
    Beiträge
    11.726
    Danke
    398
    Erhielt 2.401 Danke für 2.001 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Wenn ich eine "pauschale" Idee hätte (über den Beitrag von RN hinaus) dann hätte ich es geschrieben.
    Wenn der Beitrag von RN für sich allein hier nicht weiterhilft dann hast du nur eine Chance : Gib uns (viel) mehr Informationen ...

  2. #12
    Finn ist offline Benutzer
    Themenstarter
    Registriert seit
    07.10.2011
    Beiträge
    31
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ich habe das Problem gefunden, der Verweis zur Variable passte nicht.
    Jetzt habe ich ein zweites Problem.
    Ich habe eine Variable in der eine zweistelle Zahl gespeichert wird. Also habe ich ein Ausgaba-Feld mit zwei Stellen eingefügt. Jedoch wird auf dem OP nur eine Stelle angezeigt, bis ich mit dem Cursor auf die zweite Stelle wähle.
    Auch wenn ich in der Variable "Grundwert = 00" einstelle, wird am Anfang trotzdem nur eine Null angezeigt.
    Kann man das irgendwie ändern?

    Liebe Grüße,
    Finn

  3. #13
    Registriert seit
    19.06.2008
    Ort
    Ostalbkreis
    Beiträge
    3.140
    Danke
    201
    Erhielt 553 Danke für 498 Beiträge

    Standard

    Du willst eine Zahl 2-stellig anzeigen?

    00 = 0
    01 = 1
    02 = 2

    10 = 10

    und jetzt soll bei Dir

    00 = 00
    02 = 02

    10 = 10

    da stehen ?

  4. #14
    Finn ist offline Benutzer
    Themenstarter
    Registriert seit
    07.10.2011
    Beiträge
    31
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    So, ich habe ein Eingabe-Feld. Hab mich vertippt.

    Eintragen kann man Minuten und Sekunden.

    00:00 soll der Eingangszustand sein.
    Bei mir steht jedoch:
    0_:0_
    _ = Leerzeichen
    Die jeweils Rechte Ziffer erscheint erst, wenn ich mit dem Cursor nach rechts gehe. Möchte aber, dass die Nullen vom Anfang an da stehen.

  5. #15
    Registriert seit
    20.06.2003
    Ort
    Sauerland.NRW.Deutschland
    Beiträge
    4.850
    Danke
    78
    Erhielt 800 Danke für 543 Beiträge

    Standard

    führende nullen werden bei einer zahl nicht angezeigt. daran lässt sich auch nichts ändern. wenn du unbedingt führende nullen haben willst, musst du mit strings arbeiten und dann entsprechen hin und herkonvertieren.
    .
    mfg Volker .......... .. alles wird gut ..

    =>Meine Homepage .. direkt zum Download

    Meine Definition von TIA: Total Inakzeptable Applikation

  6. #16
    Finn ist offline Benutzer
    Themenstarter
    Registriert seit
    07.10.2011
    Beiträge
    31
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Schade, daran kann ich mich ja setzen, wenn der Rest läuft.
    Kann man eigentlich bei dem OP73 Tasten wie 'ENTER', 'DEL' etc belegen? Anwählbar sind sie ja nicht.
    Und wofür steht ACK?

  7. #17
    Registriert seit
    19.06.2008
    Ort
    Ostalbkreis
    Beiträge
    3.140
    Danke
    201
    Erhielt 553 Danke für 498 Beiträge

    Standard

    Zitat Zitat von Finn Beitrag anzeigen
    Schade, daran kann ich mich ja setzen, wenn der Rest läuft.
    Kann man eigentlich bei dem OP73 Tasten wie 'ENTER', 'DEL' etc belegen? Anwählbar sind sie ja nicht.
    Und wofür steht ACK?
    ACK = Acknowledge = Quittieren

    Enter, Del, .... haben ein zugehöriges Bit, das du in der SPS auswerten kannst. Im OP ist das nicht separat anwählbar

  8. #18
    Finn ist offline Benutzer
    Themenstarter
    Registriert seit
    07.10.2011
    Beiträge
    31
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo, ich bin es mal wieder.

    Ich kämpfe (mal wieder) mit dem OP73.
    Es ist immernoch dasselbe Problem, dass ich am Anfang des Threads hatte.
    Ich habe einen Analogeingang mit einem Temperaturfühler.
    Der Wert dümpelt bei Zimmertemperatur bei ca. 350 rumm.
    Kann ich diesen direkt aus dem OP abfragen? In der Variablentabelle in WinCC flex steht: PEW 60 | INT

    Wenn ich diese ausgeben will, kommen wieder nur rauten.
    Muss ich die vllt. erst einmal im SPS-Programm speichern?

    2. Habt ihr einen Link wo steht, wie ich die ESC, Enter-Tasten abfrage?

    Liebe Grüße,
    Finn

  9. #19
    Registriert seit
    30.08.2010
    Ort
    Östereich
    Beiträge
    1.458
    Danke
    503
    Erhielt 217 Danke für 192 Beiträge

    Standard

    Mach dein Anzeigefeld mal um ein paar stellen größer, dann solltest du wenigstens mal die tatsächlich übertragene Zahl sehen.
    Elektrotechnik und Elektronik funktioniert mit Rauch (Beweis: Tritt Rauch aus, funktioniert auch das Bauteil nicht mehr)

  10. #20
    Registriert seit
    21.12.2006
    Ort
    Wiener Neustadt
    Beiträge
    931
    Danke
    154
    Erhielt 169 Danke für 127 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von Finn Beitrag anzeigen
    Hallo, ich bin es mal wieder.

    2. Habt ihr einen Link wo steht, wie ich die ESC, Enter-Tasten abfrage?

    Liebe Grüße,
    Finn
    GM,
    Link hab ich nicht, aber probiers mit der Vorlage, da kannst du die Tasten deines Begehrens bearbeiten.
    viel Erforlg!
    Geändert von Manfred Stangl (17.11.2011 um 06:14 Uhr) Grund: ausprobiert
    Gruß
    M

    Handbook not read error...
    Klare Frage - klare Antwort

Ähnliche Themen

  1. Step7 Bausteine werden nicht angezeigt
    Von Detto im Forum Simatic
    Antworten: 14
    Letzter Beitrag: 22.08.2011, 11:16
  2. Antworten: 3
    Letzter Beitrag: 12.11.2007, 18:32
  3. Name vom DIW soll angezeigt werden.
    Von Tigerkroete im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 12.06.2006, 09:54
  4. Eingänge werden in NW nicht angezeigt
    Von fr4nk im Forum Simatic
    Antworten: 25
    Letzter Beitrag: 05.04.2006, 14:51
  5. Meldungen werden im TP170a nicht angezeigt.
    Von Anonymous im Forum Simatic
    Antworten: 9
    Letzter Beitrag: 28.08.2004, 17:38

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •