Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 5 von 5

Thema: OP177b - Problem beim Transfer mit Profibus

  1. #1
    Registriert seit
    20.10.2011
    Beiträge
    4
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Frage


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo.
    Ich habe hier eine S7 313C 2DP V.2.6.11, an das ein OP177b PN/DP angeschlossen werden soll. Die Verbindung zwischen Panel und CPU soll über eine Profibusleitung realisiert werden und zum Projektieren der Visu wird WinCC Flexible 2008 SP2 genommen. Das Panel ist neu, es ist also die erste Übertragung.

    Das "PG" ist ein einfacher Windows XP Prof. PC mit S7 V5.4 SP5 jedoch ohne Schnittstellenkarten.
    Für die Verbindung zur CPU / Panel habe ich zur Verfügung:
    -PC USB Adapter (6ES7 972 0CB20 0XA0)
    -PC RS232 Adapter (6ES7 972 0CA23 0XA0)
    -Nullmodemkabel
    -RS232 -> RS485 Adapter von W&T
    -einfaches USB-Kabel


    Nach längerem Suchen habe ich gelesen, dass der PC USB Adapter wohl generell nicht unterstützt wird. Zudem soll es wohl auch Probleme bei dem ersten Übertragen auf ein Panel geben, so dass man das ganze direkt und nicht über die CPU/Profibus aufspielen muss.


    Nunja, nun zu meinen bisher gescheiterten Versuchen, mein Projekt auf das Panel zu übertragen:


    Das WinCC flex Projekt ist in das S7 Programm eingebunden. Am Anfang hatte ich das Ganze mit dem USB-Adapter versucht, bis ich gelesen habe, dass das Ganze wohl nicht funktionieren kann.^^


    Meine Vorgehensweise mit dem RS232 Adapter:


    In der HW-Konfig der S7 Station habe ich die Profibus DP Verbindung eingerichtet und die Adresse 1 gegeben.






    In der HW-Konfig des Panels habe ich als Stationsadresse die 2 angegeben.





    Im NetPro sieht das Ganze dann so aus:





    Jetzt habe ich in dem WinCC Flex Projekt die Verbindung eingerichtet:




    Dann die PG/PC-Schnittstelle auf PC Adapter (MPI) eingestellt, die Adresse 0 gegeben PG/PC als einzigen Master eingestellt und als Anschluss COM1 gewählt.






    Beim Touchpanel habe ich Channel 1 deaktiviert und Channel 2 mit Remote aktiviert.
    ("S7 Transfer Settings" und "Transfer" scheinen identisch zu sein) Dort dann Profibus ausgewählt, die Adresse 1 der CPU angegeben und als "Only Master" angekreuzt. Danach habe ich das ganze Panel über "Reboot" neu gestartet.


    Dann habe ich das S7 Programm auf die CPU im RUN übertragen und wollte danach das WinCC flex Projekt übertragen.


    Als Modus habe ich MPI/DP angegeben und als Stationsadresse die 2 vom Panel.








    Jetzt meldet sich WinCC Flex , dass das Betriebssystem nicht aktuell sei, also das Updaten erlaubt allerdings bekommt er jetzt keine Verbindung zum Panel.. als Meldung wird (wenn ich es richtig im Kopf habe) ausgegeben, dass die Verbindung gestört sei und ich die Kabel ect. Kontrollieren soll.


    Danach habe ich es mal ohne die CPU versucht, also den Adapter direkt an die Profibus Buchse des Panels angeschlossen und am Panel den Modus auf MPI umgestellt. Selbes Ergebnis wie oben.


    Zum Schluss wollte ich es mit einem Nullmodemkabel versuchen, habe in WinCC flex allerdings keine Einstellung zur seriellen Übertragung gefunden, über die das dann ja laufen müsste.
    (Also das eine Ende an die COM Buchse vom PC und das Andere ans Panel.)
    Dafür habe ich den Channel 2 am Panel wieder deaktiviert und Channel 1 aktiviert. Wenn ich es richtig lese, funktioniert das serielle Übertragen wohl nur mit einem PC/PPI-Kabel?


    Ich hoffe das mir jemand zeigen kann, wo mein Fehler liegt.

    Schöne Grüße



    Edit: Also, ich habe heute nochmal versucht, das Projekt über eine Direktverbindung mit dem RS232 Adapter zu übertragen und es hat funktioniert. Scheinbar habe ich die Adressangabe in den Einstellungen des Panels falsch verstanden. Ich dachte zuerst, dort müsse man die Adresse der CPU angeben, mit der das Panel kommunizieren soll. Allerdings ist es die Adresse, die das Panel selber bekommt. Der Direkttarnsfer über MPI funktioniert jetzt also. Die Kommunikation über Profibus nach dem direkten Übertragen scheint auch zu funktionieren. Lediglich das Übertragen des Projektes über die CPU funktioniert nicht. (RS232 an MPI der CPU und von da über den Profibus an das Panel)
    Müsste man in der Praxis mit dem PG zu jedem Panel laufen, nur um etwas aufspielen zu können?


    Schöne Grüße
    Geändert von ElektroElch (24.10.2011 um 11:02 Uhr)
    Zitieren Zitieren OP177b - Problem beim Transfer mit Profibus  

  2. #2
    Registriert seit
    07.06.2011
    Beiträge
    117
    Danke
    4
    Erhielt 18 Danke für 18 Beiträge

    Standard

    Hallo,

    Du musst eine PG/PC-Station in Deinem Projekt anlegen, die Deinem PC entspricht. Die bekommt eine MPI-Verbindung und muss ins MPI-Netz der CPU eingebunden werden. Dann aktivierst Du diese Station. Jetzt sollte das Flexible wissen, wo Dein PC im Netz angeschlossen ist und dass die Übertragung zum Panel über die CPU geroutet werden muss. Der Transferdialog im Flexible zeigt dann die entsprechenden Infos an. Damit sollte der Transfer funktionieren.

    Mario

  3. Folgender Benutzer sagt Danke zu MRose für den nützlichen Beitrag:

    ElektroElch (25.10.2011)

  4. #3
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.616
    Danke
    377
    Erhielt 799 Danke für 642 Beiträge

    Standard

    Ich habe nicht dein ganze (und lange !) Beitrag gelesen.
    Aber... warum verwendest du nicht das Ethernet Schnittstelle ! Einfacher und viel viel schneller.
    Jesper M. Pedersen

  5. #4
    ElektroElch ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    20.10.2011
    Beiträge
    4
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Danke MRose, werde das morgen gleich mal ausprobieren!
    Habe dazu nach einigem Suchen auch etwas in dem Handbuch zu WinCC Flex auf S. 460 unter "Integration von WinCC flex in Step7" gefunden.

    Hallo Jesper, leider besitzt die mir zur Verfügung stehende CPU (313C 2DP s.o.) keine IE-Schnittstelle und ein CP-Modul ist platztechnisch nicht mehr unterzubringen. Sonst hätte ich es mit Profinet gemacht.

    Falls noch Fragen auftreten, melde ich mich bestimmt wieder.



    Schöne Grüße
    Geändert von ElektroElch (25.10.2011 um 21:31 Uhr)

  6. #5
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.616
    Danke
    377
    Erhielt 799 Danke für 642 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von ElektroElch Beitrag anzeigen
    Hallo Jesper, leider besitzt die mir zur Verfügung stehende CPU keine IE-Schnittstelle und ein CP-Modul ist platztechnisch nicht mehr unterzubringen. Sonst hätte ich es mit Profinet gemacht.
    Doch.
    OP177b PN/DP
    Jesper M. Pedersen

Ähnliche Themen

  1. Transfer zu OP177B
    Von rkoe1 im Forum HMI
    Antworten: 17
    Letzter Beitrag: 08.08.2012, 16:25
  2. OP177b - Verbindungsproblem via Profibus
    Von ElektroElch im Forum HMI
    Antworten: 0
    Letzter Beitrag: 20.10.2011, 23:40
  3. Antworten: 7
    Letzter Beitrag: 28.08.2011, 15:00
  4. Problem nach Transfer ProTool->TP270
    Von mapavo im Forum HMI
    Antworten: 1
    Letzter Beitrag: 17.09.2007, 23:09
  5. Problem beim Transfer (PG-> TP270)
    Von Roland im Forum HMI
    Antworten: 8
    Letzter Beitrag: 14.06.2004, 13:09

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •