Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 5 von 5

Thema: Werte an Steuerung(S7 1200)schreiben via ktp400

  1. #1
    Registriert seit
    02.11.2011
    Beiträge
    4
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    bin neu hier und ziemlicher Anfänger vielleicht könnt Ihr mir helfen mit dem folgenden Problem. Ich arbeite das erste mal mit der 1200er(TIA V11) und KTP400(Wincc Basic) vorher hab ich nur kleine steuerungen mit der LOGO! kreiert.
    Nun stellt sich folgendes Problem ich muss über das Panel einen Zähler "aufziehen", und den aktuellen Zählerstand anzeigen.
    Was bisher geschehen ist:

    1. PLC und HMI Variablen erstellt: Sollwert MW2 INT und Istwert MW3 INT

    2. Ein E/A Feld erstellt und mit Variable(MW2) verknüpft. Und als Eingabe parametriert.

    3. Ein E/A Feld erstellt und mit Variable(MW3) verknüpft. Und als Ausgabe verknüpft.

    4. Im programm hängt das MW2 am Zähler(PV) und das MW3 an(CV)

    5. Das ganze geladen und das panel über die software simuliert, der zähler funzt ganz normal aber beim Istwert zeigt es auf dem panel das an : #### ,beim eingabe E/A feld kann ich ganz normal eingeben, aber es ändert sich nix weder im programm(beobachtungmodus) noch an der anzeige am panel.


    ---was mache ich falsch muss ich die werte voher noch irgendwie laden und in andere MW´s transferieren?----



    Im voraus schon mal vielen Dank
    Zitieren Zitieren Werte an Steuerung(S7 1200)schreiben via ktp400  

  2. #2
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.726
    Danke
    314
    Erhielt 1.519 Danke für 1.282 Beiträge

    Standard

    Also dein erstes Problem ist, das sich MW2/3 überlappen,
    MW2 = MB2/3 bzw. MW3 = MB3/4

    Vielleicht ist das auch schon dein ganzes Problem.

    Welchen Zähler verwendest du eigentlich?

    Mfg
    Manuel
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  3. #3
    Nobbe73 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    02.11.2011
    Beiträge
    4
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Guten abend,

    und vielen Dank für die schnelle Antwort!!! Ja da hast du wohl recht 2byte sind nun mal ein wort werd morgen gleich mit mit MW10 und MW20 arbeiten.
    Ich benütze den Rückwärtszähler CTD, wenn ich ihn einfüge legt er mir einen datenbaustein an: IEC_COUNTER_0_DB.
    Aber sonst müsste mein beschriebenes prinzip funktionieren?

    Grüße
    Nobbe

  4. #4
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.726
    Danke
    314
    Erhielt 1.519 Danke für 1.282 Beiträge

    Standard

    Also beim CTD könnte es natürlich bzw. wird es so sein,
    das du deinen Sollwert erst mit dem Eingang "LD" des Zählers Laden musst,
    d.h. der Sollwert "PV" wird auf den Istwert "CV" geschrieben.

    Dann wird der Istwert pro Flanke an CD um eins verringert bis CV irgendwann mal null ist.

    Mfg
    Manuel
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  5. #5
    Nobbe73 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    02.11.2011
    Beiträge
    4
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    also du hattest recht muß den zähler am LD aufziehen dann funzts! Das hauptproblem lag aber wohl daran das der RT Simulator nicht mit der steuerung kommunziert hatte, darum die anzeige beim istwert #### und ich hatte es nicht bemerkt, mit dem realen ktp400 ging´s dann gleich.
    Also viiiiiiielen Dank für deine Hilfe nochmal!!!!!
    Wird wohl nicht das letzte mal gewesen sein wo ich hier was fragen muß


    Gruß und danke
    Nobbe

Ähnliche Themen

  1. Antworten: 14
    Letzter Beitrag: 22.10.2011, 07:20
  2. Antworten: 6
    Letzter Beitrag: 23.05.2011, 20:30
  3. S7 1200 + ktp400
    Von Joseppe im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 21.11.2010, 15:28
  4. Bitmeldungen s7-1200/KTP400
    Von McMeta im Forum HMI
    Antworten: 0
    Letzter Beitrag: 18.11.2010, 15:25
  5. Werte in DBD schreiben
    Von nuss im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 19.09.2007, 16:01

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •