Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 12

Thema: WinCC Flexible plötzlich unschön ?

  1. #1
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.622
    Danke
    377
    Erhielt 799 Danke für 642 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ich habe WinCC Flex 2008 SP2 (wartet auf SP3 DVD).

    Dann habe ich eine Projekt von SP1 nach SP2 migriert und bemerke dann, dass alle Polygone usw. mit genau ein Pixel versezt sind.
    Und, wenn ich eine neue normale Linie mit ein Pfeil am Ende plaziere, sieht es auch aus das es mit 1 Pixel verstzt ist.
    Es sieht alles etwas doof aus.
    Als Beispiel habe die Linie mit Pfeil angehängt, bei 400% Vergröserung.
    WinCC_flex_arrow.JPG
    Man sieht das wegen die Versetzung ist der Pfeil nicht symmetrisch.

    Vielleicht nicht von der grösste Bedeutung, aber es stört mein Blick. Und wenn es zu meine HMI Bilder kommt, dann bin ich Perfektionist.

    Habt ihr auch soetwas bemerkt ?
    Jesper M. Pedersen
    Zitieren Zitieren WinCC Flexible plötzlich unschön ?  

  2. #2
    Registriert seit
    06.01.2005
    Ort
    im schönen Lipperland
    Beiträge
    4.472
    Danke
    498
    Erhielt 1.143 Danke für 736 Beiträge

    Standard

    Hallo Jesper.

    Passt die Auflösung des Projektes zu deinem Bildschirm ? Ich habe auch schon Projekte "hochgezogen" und ich hatte dieses Problem nicht
    Früher gab es Peitschen .... heute Terminkalender

  3. #3
    Avatar von JesperMP
    JesperMP ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.622
    Danke
    377
    Erhielt 799 Danke für 642 Beiträge

    Standard

    Die Auflösung auf mein Programmier PC ist 1920x1200.
    Die Auflösung auf der Ziel-PC ist 1920x1080.

    Nun habe ich das Projekt simuliert auf den Programmier-PC, und in Simulations-Modus gibt es die versetzungen NICHT.
    Also, ich weiss das es kann ziemlich grossen Unterschiede sein zwischen was man auf sein Programmier-PC sieht, und was erscheint auf die Windows CE basierte Panele.
    Aber bis jetzt stimmte es 100% überein wenn es um PC RT handelte.

    Stöhn. Jetzt weiss ich erst beim Runtime wie es alles wirklich aussehen wird.
    NERVEND !

    Es ist auch z.B. Recktangeln, wo die Linien mit 1 Pixel versetzt sind. Dann sehen oberste linke Ecke Rund aus.
    Das Problem ist jetzt wie ich genau Objekte an einander anpassen kann.
    Jesper M. Pedersen

  4. #4
    Registriert seit
    16.05.2007
    Ort
    im Stahlwerk...
    Beiträge
    1.178
    Danke
    120
    Erhielt 429 Danke für 236 Beiträge

    Standard

    Ich habe so ein ähnliches Phänomen bei Textfeldern bemerkt. In der Projektierungssicht ist alles i.O. (Text passend dargestellt) - auf dem MP277 8" Key übertragen siehts plötzlich anders aus und ich muss wieder nachkorrigieren (Text passt nicht ganz in das Textfeld). Habe mir nix dabei gedacht, weil es mein erstes Flex-Projekt ist (Flex2008SP2). Geärgert habe ich mich doch etwas darüber. Wenn ich in der Projektierung die Geometrie eines Textfeldes auf "passend" stelle, dann "passt" der Text jedoch auf dem MP nicht so ganz...
    Projekt ist nicht migriert o.Ä.
    Gruß Approx
    Nihil est in cpu, quod non fuerit in intellectu" - Nichts ist in der CPU, was nicht (zuvor) im Verstand war.

  5. #5
    Registriert seit
    22.03.2007
    Ort
    Detmold (im Lipperland)
    Beiträge
    11.712
    Danke
    398
    Erhielt 2.397 Danke für 1.997 Beiträge

    Standard

    @Jesper:
    Das Entwicklungssystem macht das m.E. um Bearbeitungszeit zu sparen. Wenn du in der Ansicht nicht die 100%-Darstellung hast verzerrt Flex sowieso alles "ein bißchen". Das Problem gab es aber auch schon vorher bei Protool.
    Was man nur manchmal nicht beim Entwicklen sieht ist, dass das Objekt nicht immer genau in der Darstellungsbereich passt (das passiert aber nur, wenn man die Größe selber vergibt und nicht automatisch).

    Gruß
    Larry

  6. Folgender Benutzer sagt Danke zu Larry Laffer für den nützlichen Beitrag:

    JesperMP (01.02.2012)

  7. #6
    Avatar von JesperMP
    JesperMP ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.622
    Danke
    377
    Erhielt 799 Danke für 642 Beiträge

    Standard

    Diese Verzerrung gibts es auch beim 100% Zoom Darstellung. Und ich bin sicher das es war nicht so vorher.
    Hmmm... Kann es sein, es hat zu tun mit etwas von Windows oder MS .Net Framework ?
    Jesper M. Pedersen

  8. #7
    Registriert seit
    11.04.2008
    Ort
    Bayern
    Beiträge
    523
    Danke
    26
    Erhielt 67 Danke für 67 Beiträge

    Standard

    Dies wurde beim SP2 geändert, um wie oben von Larry schon geschrieben, Rechenleistung zu sparren.

  9. Folgender Benutzer sagt Danke zu netmaster für den nützlichen Beitrag:

    JesperMP (01.02.2012)

  10. #8
    Registriert seit
    13.10.2007
    Beiträge
    12.031
    Danke
    2.785
    Erhielt 3.268 Danke für 2.156 Beiträge

    Standard

    Das ist ja ein Hammer, Rechnerleistung zu sparen. Was soll so ein Quatsch, die Rechner sind doch
    seit den letzten SP nicht schwächer geworden und an flexibel ist doch nichts hinzu gekommen, das diesen
    Umstand erforderlich macht. Zur Hölle mit den Software-Endwicklern von Siemens

  11. #9
    Avatar von JesperMP
    JesperMP ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.622
    Danke
    377
    Erhielt 799 Danke für 642 Beiträge

    Standard

    Wäre schön wenn man diese Sparfunktion Ein- aund Ausschalten konnte.
    Jesper M. Pedersen

  12. #10
    Avatar von JesperMP
    JesperMP ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.622
    Danke
    377
    Erhielt 799 Danke für 642 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Nur um meine Frustration ausreden zu können.
    Hier ist noch eine kleine Beispiel von das Problem.
    WinCC_flex_plygons.JPG
    Das Rechtangel am oben und das Polygon am unten haben beide den gleiche Breite.
    Und sie sind auf einander genau plaziert um eine einheitliche Anlagenteil zu visualisieren.
    Aber da ist bei den Darstellung eine Fehler bei den Polygon das bedeuet es sieht als sie sind nicht auf einander korrekt plaziert.
    Erst beim Simulation sieht man wo die kleine Feher sind, und wo man was korrigieren muss.
    Angehängte Grafiken Angehängte Grafiken
    Jesper M. Pedersen

Ähnliche Themen

  1. Antworten: 4
    Letzter Beitrag: 26.11.2011, 14:08
  2. Antworten: 3
    Letzter Beitrag: 09.09.2011, 14:16
  3. Antworten: 0
    Letzter Beitrag: 14.05.2010, 08:11
  4. Plötzlich viel Freizeit.
    Von Rafa im Forum Suche - Biete
    Antworten: 0
    Letzter Beitrag: 07.06.2009, 18:27
  5. HW-Update fehlt plötzlich
    Von Kniffo im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 26.04.2007, 08:53

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •