Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 3 von 4 ErsteErste 1234 LetzteLetzte
Ergebnis 21 bis 30 von 37

Thema: TIA: S7-1200 + KTP 600 Meldungen

  1. #21
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.732
    Danke
    314
    Erhielt 1.520 Danke für 1.282 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Bevor jetzt hier ein falscher Eindruck entsteht,
    mit Merkern kannst du jederzeit und problemlos arbeiten, egal in welcher Version.

    Du musst nur ein Merkerwort deklarieren:
    Meldewort1 = MW30
    Meldung_1 = M30.0
    Meldung_2 = M30.1
    Meldung_16 = M31.7

    Meldung1 - x verwendest du im Programm,
    und Meldewort1 als Trigger auf dem Panel.

    Mfg
    Manuel
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  2. #22
    Registriert seit
    08.12.2011
    Beiträge
    18
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hi,

    also ich habe jetzt die Variablen in der Symboltabelle deklariert. Bei mir MW 60 = Meldewort1.
    Dann habe ich im HMI das Meldewort 1 als Triggervariable und Bit 1 als Triggerbit ausgewählt.
    Anschließend habe ich eine FC Meldungen angelegt und mit dem Eingabe Notstop eine Zuweisung angesteuert.
    Die Zuweisung spricht den Merker 60.0 an. Was genau meinst Du den mit Meldung1 - x? Und brauche ich dann überhaupt noch einen DB Meldungen?

    Gruß Sebastian

  3. #23
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.732
    Danke
    314
    Erhielt 1.520 Danke für 1.282 Beiträge

    Standard

    Zitat Zitat von elibastianst Beitrag anzeigen
    also ich habe jetzt die Variablen in der Symboltabelle deklariert. Bei mir MW 60 = Meldewort1.
    Dann habe ich im HMI das Meldewort 1 als Triggervariable und Bit 1 als Triggerbit ausgewählt.
    Anschließend habe ich eine FC Meldungen angelegt und mit dem Eingabe Notstop eine Zuweisung angesteuert.
    Die Zuweisung spricht den Merker 60.0 an. Was genau meinst Du den mit Meldung1 - x? Und brauche ich dann überhaupt noch einen DB Meldungen?
    Du brauchst keinen DB.
    Mit Meldung 1 - x meine ich einfach die Symbole die ich den M30.0 - M31.7 bzw. bei dir halt dann M60.0 - M61.7 gegeben habe.
    Sinnvoller wäre natürlich auch eine "aussagekräftige" Symbolik, z.B. STG_Motor_1 oder so ...

    Mfg
    Manuel
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  4. #24
    Registriert seit
    08.12.2011
    Beiträge
    18
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo Manuel,

    ich habs jetzt doch mit Merkern realisiert.
    Habe das Programm heute auf die Anlage geschoben und alle Meldungen funktionieren bestens.
    Du hast mir echt geholfen. Vielen Dank nochmal dafür!!

    Gruß Sebastian

  5. #25
    Registriert seit
    04.04.2012
    Beiträge
    3
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo!
    ich bin totaler anfänger im bereich Visualisierung und möchte mir das ganze selber etwas beibringen. Ich scheitere auch an dem problem. Ich möchte, daß ein Bild(z.B.Störung) nur erscheint, wenn z.b. ein Eingang oder Merker aktiv ist. hab schon ewig rumprobiert, klappt aber irgendwie nicht.
    Das kann doch nicht so schwer sein, oder? kann mir jemand helfen oder sogar nen screenshot von der lösung schicken?

    Verwende TIA V10.5 SP1

    Danke für euere Tips

  6. #26
    Registriert seit
    08.12.2011
    Beiträge
    18
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo,

    also ich habe ja an gleichem Problem lange rumprobiert.
    Habe es mit Hilfe des Forums wie folgt hinbekommen:

    Zuerst muss in der Variabletabelle ein Merkerwort und die Merker deklariert werden. Das sieht folgendermaßen aus.

    Name Datemtyp Adresse
    Meldewort_1 UInt z.B. MW50
    Meldung_1 Bool M50.0
    -
    -
    -
    -
    Meldung_8 Bool M50.7

    Anschließend kann in einem FC eine Zuweisung angesprochen werden.
    Die Zuweisung bekommt dann die Variable M60.0 (Meldung_1) zugewiesen und wird mit z.B. E0.0 angesteuert.
    Wird der Eingang 1 wird der Merker 60.0 ebenfalls auf 1 gesetzt.
    Der FC muss natürlich im OB ein eingefügt werden.

    Anschließend kann unter HMI Meldungen die Bitmeldung angelegt werden.
    Die ID wird automatisch vergeben. Der Ereignistext ist beliebig.
    Meldeklasse = z.B. Warnung

  7. #27
    Registriert seit
    08.12.2011
    Beiträge
    18
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo,

    also ich habe ja an gleichem Problem lange rumprobiert.
    Habe es mit Hilfe des Forums wie folgt hinbekommen:

    Zuerst muss in der Variabletabelle ein Merkerwort und die Merker deklariert werden. Das sieht folgendermaßen aus.

    Name Datemtyp Adresse
    Meldewort_1 UInt z.B. MW50
    Meldung_1 Bool M50.0
    -
    -
    -
    -
    Meldung_8 Bool M50.7

    Anschließend kann in einem FC eine Zuweisung angesprochen werden.
    Die Zuweisung bekommt dann die Variable M60.0 (Meldung_1) zugewiesen und wird mit z.B. E0.0 angesteuert.
    Wird der Eingang 1 wird der Merker 60.0 ebenfalls auf 1 gesetzt.
    Der FC muss natürlich im OB ein eingefügt werden.

    Anschließend kann unter HMI Meldungen die Bitmeldung angelegt werden.
    Die ID wird automatisch vergeben. Der Ereignistext ist beliebig.
    Meldeklasse = z.B. Warnung
    Triggervariable = MW50
    Triggerbit = 8

    Nun kann über eine Meldeanzeige in einem HMI Bild der Ereignistext beim angesteuertem E0.0 angezeigt werden.

    Hoffe Du kommst so klar.
    Ansonsten einfach nochmal melden.

    Gruß

  8. #28
    Registriert seit
    04.04.2012
    Beiträge
    3
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    servus und danke für die hilfe.

    Habs mal versucht, hat bisher noch nicht geklappt.
    Allerdings möchte ich nicht einen meldetext in einem HMI Bild anzeigen lassen sondern einen Bildwechsel erzeugen.
    D.H. Wenn z.B. ein Eingang oder Merker gesetzt wird soll das Display auf ein anderes Bild springen.

    Brings einfach nicht hin...
    Hilfe!!!!!!

  9. #29
    Registriert seit
    08.12.2011
    Beiträge
    18
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hi,

    also wie man einen Bildwechsel erzeugt ist mir auch nicht klar.
    Das halte ich aber auch nicht für sinnvoll.
    Du kannst aber ein Bild oder einen Button o.ä. als Meldung über Animation oder Sichtbarkeit
    erscheinen lassen wenn eine Zustandsänderung am Eingang eintritt.
    Wo genau liegt denn dein Problem.
    Für eine klassische Meldung könnte ich versuchen Dir ein paar Sreenshots zu machen.

    Gruß

  10. #30
    Registriert seit
    08.12.2011
    Beiträge
    18
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren

Ähnliche Themen

  1. Antworten: 5
    Letzter Beitrag: 28.02.2012, 17:57
  2. S7-1200 Starter-Kit mit KTP-600
    Von Anfänger 2010 im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 26.01.2012, 07:35
  3. Meldungen Mit S7-1200 und KPT 600
    Von Michael J. im Forum HMI
    Antworten: 2
    Letzter Beitrag: 28.12.2011, 10:36
  4. KTP 600 Defekt
    Von bebaste im Forum HMI
    Antworten: 1
    Letzter Beitrag: 11.04.2011, 08:21
  5. Antworten: 5
    Letzter Beitrag: 10.01.2011, 12:54

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •