Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 6 von 6

Thema: In TIA V10.5 keine S_Everz....kein AWL möglich?

  1. #1
    Registriert seit
    11.01.2012
    Beiträge
    46
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen,
    ich sitze immer noch vor meinem Projekt(HMI Panel und S7 1214C). Konfiguration, Visualisierung etc habe ich mit eurer Hilfe ja schon soweit hinbekommen
    So jetzt wollte ich zum Schluss noch eine kleine Ampelschaltung programmieren. Ich habe einen Fußgängerüberweg und bei Grünanforderung soll nach ein paar sek. die Ampel von Grün auf Gelb und dann auf Rot springen, eigentlich keine große Sache da ich soetwas schoneimal mit einer S300 programmiert habe, dachte ich...... Jetzt bemerke ich aber das es ja gar keine Zeitbausteine wie S_Everz und S_Averz etc gibt? Gut dann mach ich es eben in AWL...aber AWL kann ich ja gar nicht als Programmiersprache auswählen...Und nun? Hoffe ihr könnt mir sagen wie ich das mit den Zeitgliedern realsieren kann...Danke schonmal!
    Gruß Armin
    Zitieren Zitieren In TIA V10.5 keine S_Everz....kein AWL möglich?  

  2. #2
    Registriert seit
    11.12.2009
    Beiträge
    2.115
    Danke
    388
    Erhielt 390 Danke für 271 Beiträge

    Standard

    Die Zeiten heißen TON und TOF.
    AWL gibt es für die 1200er nicht!

    Grüße

    Marcel

  3. #3
    Registriert seit
    11.01.2012
    Beiträge
    46
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hm..kein AWL warum fehlt ausgerechnet das? Wird da nicht der Nutzen einer 1200 extrem eingeschränkt?
    Ja diese "anderen" Zeiten sind das nicht die NormZeiten? Ist S_Everez etc nicht eine eigene Siemensart gewesen?
    Ist das mit den Zeite nun einfacher oder was ändert sich da? Ich brauche für meine Schaltung 3 von diesen Zeitgliedern denke ich? Wie muss ich das den nun programmieren? Steigende und fallende Flanke bringt mir ja nichts für die Ampeln?

  4. #4
    Registriert seit
    11.12.2009
    Beiträge
    2.115
    Danke
    388
    Erhielt 390 Danke für 271 Beiträge

    Standard

    Warum es kein AWL gibt? Frag Siemens!

    Es gibt

    KOP
    FUP
    ST

    muss wohl reichen.

    Die "anderen" Zeiten sind die IEC-Timer, das ist richtig.
    Wesentlich änderst ist, dass du statt z.B. s5t#1s nur noch t#1s schreibst.

    Wie du es programmieren musst, ist dein Part!

    Grüße

    Marcel

  5. #5
    Registriert seit
    11.01.2012
    Beiträge
    46
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hm kein AWL ist echt seltsam..naja Siemens hat sich bestimmt was dabei gedacht
    gut danke dir schonmal werde mal versuchen mit den neuen Zeiten ein Programm zu erstellen....
    Gruß Armin

  6. #6
    Registriert seit
    11.01.2012
    Beiträge
    46
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hi
    so hab mich heute mal ausgiebig mit dem Thema beschäftigt. 1. Benötige ich eine einfach Fußgängerampel. Also ich habe ein nur eine Ampel und über ein Touchpanel verlange ich eine Grünphase für die Fußgänger. So ich habe es mit TON versucht (die Einschaltverzögerung richtig?). Durch Drücken von Start und der Gründforderung läuft die zeit 5s dann wechselt die Ampel auf gelb, dann startet ebenfalls wieder ein Zähler der auch 5s läuft und dann am schluss ist dann der letzte Zähler, ebenfalls 5s mit der Rotphase (Die Zeiten werden noch angepasst ). So ich denke das habe ich richtig gemacht? Ich habe aber nun Fragen zum rücksetzten des vorherigen Lichts also wenn die Gelbphase kommt will ich ja das grün kommt, ich hab das jetzt so gelöst:
    U A...."Gelb"
    = UN A...."Grün"
    so mache ich das in jedem Teil...gibts da nicht eine bessere Lösung dafür? die hier kommt mir ein wenig "seltsam" vor....
    Eine weitere Frage ist wenn die Ampel für die Autos rot ist will ich ja auch irgendwann (nach 5s) das die Ampel wieder auf grün zurück springt...wie mache ich das ? Ich kann ja schlecht mit Rot den TON Eingang beschalten und dann als Q ebenfalls die rot...? Gibts da nicht soeine Art "Richtimpuls" ? Oder muss ich es doch mit Takten machen? (Ich benötige nur eine simple einfach Lösung als Demonstration) Danke schonmal für eure Hilfe!
    Gruß Armin
    Geändert von Firefly87 (12.03.2012 um 17:56 Uhr)

Ähnliche Themen

  1. TIA-Portal V10.5 Hardwarekatalog Update
    Von 4nD1 im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 28.02.2012, 13:24
  2. Referenzdaten bei Know-How Schutz TIA V10.5
    Von Toki0604 im Forum Simatic
    Antworten: 12
    Letzter Beitrag: 12.01.2012, 20:49
  3. TIA Portal V10.5 Basic S7-1200
    Von softy im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 02.11.2011, 09:42
  4. Step7 TIA V10.5 oder V11.0 Basic
    Von Nost im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 20.05.2011, 22:21
  5. TIA v10.5 ServicePack 2
    Von Sinix im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 21.12.2010, 08:17

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •