Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 6 von 6

Thema: Variablen in Meldungen? Im Simulator funktioniert es nicht...

  1. #1
    Registriert seit
    24.11.2008
    Beiträge
    42
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hi,

    ich bräuchte Variablen in (Stör-)Meldungen. Eigentlich kein Problem dachte ich. Meldung sieht z.B. so aus:

    Zylinder <tag MW2> nicht ausgefahren

    Im Simulator wird immer nur

    Zylinder #### nicht ausgefahren angezeigt.

    MW2 ist ein Int, Anzeige soll decimal sein mit 4 Feldern. Die Variable ist nicht zu gross. Selbst wenn in MW2 eine 0 drin steht gehts nicht...
    Liegt das am Simulator, oder mache ich was falsch?

    SPSSchlumpf
    Zitieren Zitieren Variablen in Meldungen? Im Simulator funktioniert es nicht...  

  2. #2
    Registriert seit
    19.06.2008
    Ort
    Ostalbkreis
    Beiträge
    3.140
    Danke
    201
    Erhielt 553 Danke für 498 Beiträge

    Standard

    Hallo,

    zu 99% ist das Feld zu klein. Erweitere es zum Test auf 6-7 Stellen. Danach immer um eins zurück, bis #### erscheint. Jetzt wieder eins dazu

  3. #3
    Registriert seit
    24.11.2008
    Beiträge
    42
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hi,

    daran liegts nicht. Habe mal ein Feld auf 20 Stellen erhöht. Soviel geht mit einem Int natürlich nicht. Ergebnis ist immer noch ############...
    Eigentlich reicht es auch die Anzahl der Stellen +1 (Vorzeichen) zu benutzen. Das Problem bleibt...

  4. #4
    Registriert seit
    19.06.2008
    Ort
    Ostalbkreis
    Beiträge
    3.140
    Danke
    201
    Erhielt 553 Danke für 498 Beiträge

    Standard

    Ahh Simulator

    Steht die Verbindung zum HMI? Wenn keine Verbindung steht, dann haben Var's #####

  5. #5
    Registriert seit
    24.11.2008
    Beiträge
    42
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ja. Hätte ja sonst auch ein Problem die Meldung überhaupt anzeigen zu lassen

    Edit: Kann man eigentlich irgendwie die Darstellung beeinflussen? Bei Variablen in einer Textliste geht das. In Meldungen nicht?
    Geändert von SPSSchlumpf (11.04.2012 um 11:20 Uhr)

  6. #6
    Registriert seit
    24.11.2008
    Beiträge
    42
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Kommando zurück...mit PLCSim gehts, nur mit dem Winccflex Simulator nicht.

    SPSSchlumpf

Ähnliche Themen

  1. Antworten: 1
    Letzter Beitrag: 19.09.2011, 23:33
  2. Update für WinCC flexible Variablen Simulator
    Von rostiger Nagel im Forum HMI
    Antworten: 1
    Letzter Beitrag: 25.05.2011, 08:55
  3. Antworten: 20
    Letzter Beitrag: 23.02.2011, 15:41
  4. Antworten: 2
    Letzter Beitrag: 26.11.2010, 06:14
  5. ALARM_S-Meldungen kommen nicht durch
    Von RAN im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 16.10.2007, 10:17

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •