Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 8 von 8

Thema: WinCC - Bedienung friert ein

  1. #1
    Registriert seit
    11.10.2007
    Ort
    Niedersachsen
    Beiträge
    7
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    ich habe ein großes Problem mit meinem WinCC Projekt. (V7 SP2)
    In unregelmäßigen Abständen friert die Bedienung in meinem WinCC Projekt ein. Ich kann zwar Seitenaufrufe, bzw. Bildaufrufe im Hauptfenster anwählen, es passiert aber erstmal nichts.
    Variablen, Trends usw. werden trotzdem weiter angezeigt und aktualisiert.
    Nach einiger Zeit (ca2-3min) werden dann alle Aktionen die ich vorher angeklickt habe durchgeführt.
    Wäre schön, wenn ich da von jemandem Rat bekommen würde, da es sehr nervig für die Bediener der Anlage ist.
    Zitieren Zitieren WinCC - Bedienung friert ein  

  2. #2
    Registriert seit
    16.05.2007
    Ort
    im Stahlwerk...
    Beiträge
    1.178
    Danke
    120
    Erhielt 429 Danke für 236 Beiträge

    Standard

    Kann es sein, daß Du mehrere Scripte laufen hast und auch der Bildwechsel über Scriptfunktion realisiert ist?
    WinCC arbeitet Scripte meines Wissens nacheinander und nicht parallel ab.
    Also wenn da irgend ein Script hakelt, dann werden auch die Bildanwahlscripte entsprechend verzögert abgearbeitet.

    Approx

    edit: Zur Kontrolle der in der Runtime angemeldeten Scripte kannst Du dir ein GSC-Diagnosefenster in der Runtime aufrufen. Dazu besagtes Fenster im Grafikdesigner in einem Bild einfügen und per Button in der Runtime aufrufen.
    Geändert von Approx (10.07.2012 um 17:08 Uhr) Grund: edit
    Nihil est in cpu, quod non fuerit in intellectu" - Nichts ist in der CPU, was nicht (zuvor) im Verstand war.

  3. #3
    Avatar von Tommes
    Tommes ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    11.10.2007
    Ort
    Niedersachsen
    Beiträge
    7
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Ja, ich habe im sekundentakt ein skript laufen, das mir aus der Störmeldetabelle die anzahl der anstehenden und der unquittierten Meldungen ausliest. Dieses Skript benötige ich aber auch, da ich für die Beckhoff Steuerung eine Fehlerauswertung damit machen muss. Mein nächster Versuch ist es dieses Skript zu deaktivieren und zu schauen was passiert. Im Diagnosetool "APDiag" werden im Sekundentakt die Ausgangsvariablen des Skripts angezeigt.
    Die Bildaufrufe mache ich auch über skripte, weil ich die Anforderung von 2 Monitoren auf denen ich gegebenfalls das gleiche Bild zu sehen ist ( mit einigen Dynamiken beinhaltet) sonst nicht hinbekommen habe.

  4. #4
    Registriert seit
    22.03.2007
    Ort
    Detmold (im Lipperland)
    Beiträge
    11.797
    Danke
    398
    Erhielt 2.417 Danke für 2.013 Beiträge

    Standard

    WinCC ist absolut nicht meine Baustelle ... aber etwas anzumerken habe ich dennoch :
    Die 2 - 3 Minuten erklären sich m.E. nicht durch die relativ hohe Frequenz, mit der du das Störmeldescipt aufrufst. Es sei denn, es würde hier noch Datei-Zugriffe und die vor Allem im Netzwerk stattfinden ... Trotzdem vielleicht mal über die Takt-Rate nachdenken ...
    Kann es sein, dass dein Visu-Rechner Mitglied einer Domäne ist ? Wenn ja und du aber das Netzwerk im Hintergrund nicht zwingend brauchst - passiert es dann auch, wenn das Netzwerk abgeklemmt ist ?

    Gruß
    Larry

  5. #5
    Avatar von Tommes
    Tommes ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    11.10.2007
    Ort
    Niedersachsen
    Beiträge
    7
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Hallo,
    habe die Aufrufzeit des Skriptes erstmal von 1Sek. auf 10Sek. hochgesetzt. Mir ist seit dem noch nichts bekannt geworden das das System wieder eingefrohren ist.
    Mitglied einer Domäne ist der Rechner bewust nicht, ist aber am Netzwerk angeschlossen, da ich das Datamonitoring für Fernzugriffe benötige, bzw. unsere Produktionsleitung.
    Komisch ist halt, das z.B die Temperaturabfragen u.ä im System weiter aktualisiert wurden, nur alles was Skripte betrifft gestockt haben.
    Aus der "Flexible" Welt weiss ich auch, was Approx schon geschrieben hat, das Skripte immer nur nacheinander abgearbeitet werden und nie Parallel. Denn wenn z.B. ein Skript permanent in einer Do..Loop- Schleife läuft, sind andere Skripte Wirkungslos, bzw. wird ein scolches Skript dann noch mehrfach aufgerufen wird ein Panel Arsch-Langsam.
    Werde mich hierzu aber nochmal melden, ob das jetzt gefunzt hat oder nicht. Stehe auch noich mit der Siemens-Hotline in Verbindung. Vielleicht haben die aber auch noch einen Tipp.
    Erste Aussage von denen war, das es Probleme mit "Zustandsanzeigen" im Bild haben könnte. Dieses Problem soll aber mit WinCC V7SP2 behoben sein.
    Bis denne

    Tommes

  6. #6
    Registriert seit
    15.12.2007
    Beiträge
    721
    Danke
    84
    Erhielt 106 Danke für 95 Beiträge

    Standard

    Zwar ein bißchen Offtopic, aber mich würde das Script interessieren mit der du die Anzahl der anstehenden und unquittierten Meldungen ausliest.
    Hatte letzt einen Fall bei dem ich sowas gebraucht hätte.

  7. #7
    Avatar von Tommes
    Tommes ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    11.10.2007
    Ort
    Niedersachsen
    Beiträge
    7
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Hallo,

    es ist ein Skript aus dem Hause Siemens, was ich einem Verteter auf der Hannover Messe entlocken konnte.
    Hab kein Problem damit es weiterzugeben, benötige aber Deine E-Mail Adresse zum Versenden mit Anhang.

    Gruß

    Tommes

  8. #8
    Registriert seit
    15.12.2007
    Beiträge
    721
    Danke
    84
    Erhielt 106 Danke für 95 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hast PN!
    Danke schonmal

Ähnliche Themen

  1. WINCC friert ein
    Von schlecht02 im Forum HMI
    Antworten: 2
    Letzter Beitrag: 26.06.2012, 09:59
  2. TP177B - RT friert ein
    Von jack911 im Forum HMI
    Antworten: 2
    Letzter Beitrag: 16.05.2010, 10:11
  3. MP370 friert ein
    Von derwestermann im Forum HMI
    Antworten: 3
    Letzter Beitrag: 17.04.2008, 13:36
  4. OP 270 Friert ein
    Von Hitschkock im Forum HMI
    Antworten: 9
    Letzter Beitrag: 07.09.2007, 19:53
  5. Prodave friert Rechner ein
    Von Andreas78 im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 29.06.2006, 18:50

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •