Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 6 von 6

Thema: Grafik als Schaltfläche mit grünem Farbumschlag bei WinCC Flex

  1. #1
    Registriert seit
    08.08.2008
    Ort
    Köln
    Beiträge
    357
    Danke
    57
    Erhielt 88 Danke für 69 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,


    ich möchte in WinCC Flexible 2008 SP3 eine Schaltfläche als Grafik darstellen-
    Genauer gesagt Off = Long flip switch down und On = Long flip switch up.
    Unter Ereignisse habe ich das Bit für mein XOR in Simatic eingetragen, funktioniert
    auch einwandfrei.
    JETZT möchte ich aber das wenn mein XOR Bit high ist der Long flip switch Up aktiviert ist
    und dieser einen grünen Farbumschlag macht.
    Habe also unter Animationen mein XOR Bit als Trigger eingetragen und dann auf 1 im Simulator gesetzt,
    leider bleibt der Long flip immer unten. Bei einer normalen Schaltfläche, also dieses Standard Rechteck ist
    das alles kein Problem, nur sobald ich eine Grafik als Schaltfläche erzeuge kann ich diese nicht animieren.
    Bräuchte nur nen kleinen Tip, gerne auch Link auf Howto.


    Danke
    Zitieren Zitieren Grafik als Schaltfläche mit grünem Farbumschlag bei WinCC Flex  

  2. #2
    Registriert seit
    23.04.2009
    Ort
    Allgäu
    Beiträge
    3.042
    Danke
    241
    Erhielt 863 Danke für 617 Beiträge

    Standard

    Hallo Lebenslang,

    wenn du eine Grafik farblich animieren willst, musst du sie aus dem Symbolordner und nicht aus dem Grafikordner holen.
    Gruß
    Paule
    ----------------------------------------------------------------------------
    > manchmal verliert man und manchmal gewinnen die anderen <

  3. #3
    Avatar von Lebenslang
    Lebenslang ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    08.08.2008
    Ort
    Köln
    Beiträge
    357
    Danke
    57
    Erhielt 88 Danke für 69 Beiträge

    Standard

    Hallo Paule,

    vielen Dank erstmal für den Tip.
    Also Symbole (wenn die so genannt werden) finde ich nur 4 Stück unter Erweiterte Objekte, dort gibts eine Benutzeranzeige, Kurvenanzeige, Rezepturanzeige und Meldeanzeige.
    Eine Symbolbibliothek oder ähnlich finde ich nirgendwo. Muss ich da erst noch etwas downloaden und dann importieren?

    Hab mir jetzt erstmal selbst gezeichnet was ich brauche, funktioniert auch alles soweit, ABER: nachdem ich soeben eine weitere Schaltfläche editiert habe und dann das Projekt übertragen habe - blieb mein Bildschirm weiss!!
    Nach Google Recherche soll dieser Fehler mit dem SP2 Update 12 behoben sein, ich hab aber bereits SP2 mit Update 13 drauf und der Fehler tritt immer noch auf. (Panel ist KTP1000PN)
    Habe dann im Projekt meine Änderungen Stück für Stück rückgängig gemacht, hat nichts genutzt, musste ein neues Projekt anlegen in das ich die alten Bilder reinkopiert habe und jetzt läufts wieder. Da wird mir jetzt aber ziemlich unwohl.

    Vielleicht hat jemand die Geduld hier und kann mir das mit den Symbolen und wo ich die finde nochmal erklären.


    Vielen Dank ins Forum

  4. #4
    Registriert seit
    06.10.2009
    Ort
    NRW
    Beiträge
    1.572
    Danke
    63
    Erhielt 259 Danke für 219 Beiträge

    Standard

    Was Du vorhast, geht mit einen "grafischen EA Feld". Das findest Du unter den Basisiobjekten. In den Grafiklisten legst Du außerdem eine Grafikliste an. Auswahl mit "Bit(0,1)". In der Grafikliste hinterlegst Du bei Eintrag die entsprechende Grafik. (Schalter oben / Schalter unten). Diese Grafikliste weist Du dann dem grafischen EA Feld zu und gibst bei "Variable" das Triggerbit an.

    Das Problem mit dem weißen Bildschirm wird nicht automatisch durch das Übertragen des Projekts behoben. Entscheidend ist die Version des Betriebssystems. Ich glaube je nachdem welches Betriebssystem auf dem Panel läuft, wird das OS-update nicht zwingend gefordert, wenn ein Projekt übertragen wird. Auch wenn das neueste Hotfix auf dem Projektierungsrechner installiert ist.

    Die Version des Betriebssystems kannst Du bei Neustart des Panels einsehen, wenn Du die Einstellungen aufrufst. Ggf. das OS-update manuell durchführen.
    Meine Motivation läuft nackig mit einem Cocktail über eine Wiese.

  5. Folgender Benutzer sagt Danke zu Tigerente1974 für den nützlichen Beitrag:

    Lebenslang (02.11.2012)

  6. #5
    Avatar von Lebenslang
    Lebenslang ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    08.08.2008
    Ort
    Köln
    Beiträge
    357
    Danke
    57
    Erhielt 88 Danke für 69 Beiträge

    Standard

    Danke erstmal für die Infos.<br><br>Okay, der weiße Bildschirm nach dem Hochladen auf das KTP1000 ist ein Bug der mit einem OS Update behoben sein soll,<br>also schleunigst SP3 Update2 auf das Programmiergerät und Neustart: Zakkkk - da ist der Bluescreen.<br>Schnell gegoogelt und den Grund auf der Siemens Homepage gefunden, Inkompatibilität des WinCC flex SP3 Tastaturtreibers&nbsp;<br>mit HP Laptops,&nbsp;Stunden mit der Instandsetzung des PGs verbracht.<br><br>Fazit:<u> Touchpanel KTP1000 mit weißem Bildschirm und ohne Funktion und ein PG mit Bluescreen nach der Installation von SP3 für Flex.</u><br><br>DAS KANN DOCH NICHT ERNST GEMEINT SEIN WAS Big S DA ABLIEFERT.<br><br>Dann heute als Absacker noch Update 5 für TIA SP2 installiert, nun ist die Arbeitsgeschwindigkeit von TIA endgültig für den Ar.....<br>Ich bin nun nach vielen Jahren mit Update und Installationsorgien von Siemens Software wirklich sowas genervt, unendliche Stunden<br>auch zuhause damit verbracht, dass ich mich jetzt&nbsp;wirklich mal auf die Suche nach Alternativen mache.<br><br><br><br>

  7. #6
    Avatar von Lebenslang
    Lebenslang ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    08.08.2008
    Ort
    Köln
    Beiträge
    357
    Danke
    57
    Erhielt 88 Danke für 69 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,
    ich bräuchte bitte nochmal Hilfe bei Flex 2008 SP3.
    Habe eine Kurvenanzeige editiert mit 3 Variablen (Typ:Int und Real)
    Funktioniert auch einwandfrei, war überrascht wie einfach das ging.
    Allerdings: Datum und Uhrzeit der Wertetabelle und der X-Achse beginnen immer beim 01.01.2004
    bzw. 12:00:00 Uhr.

    Über einen Bereichszeiger habe ich mir laut Anleitung von PN/DP die Systemzeit meiner CPU aufs Panel
    geholt und zeige diese dort auch mit einem Datum-Uhrzeit-Feld an, alles okay soweit, nur bei den Kurvenanzeigen und Wertetabellen wird diese richtige Zeit nicht angezeigt.
    Hab mich schon schwindelig gegoogelt und hoffe das hier jemand evtl. einen Rat hat.

    Danke

Ähnliche Themen

  1. Antworten: 4
    Letzter Beitrag: 03.05.2012, 15:19
  2. Grafik in Schaltfläche einfügen
    Von KB78 im Forum HMI
    Antworten: 8
    Letzter Beitrag: 20.01.2011, 17:18
  3. Grafik in WINCC flex importieren - MP270
    Von sirbarny im Forum HMI
    Antworten: 9
    Letzter Beitrag: 14.05.2010, 23:37
  4. Antworten: 6
    Letzter Beitrag: 23.07.2008, 11:45
  5. WinCC flex unsichtbare Schaltfläche
    Von Lipperlandstern im Forum HMI
    Antworten: 2
    Letzter Beitrag: 31.05.2006, 12:39

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •