Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 9 von 9

Thema: Bitmeldungen / TP 177 B

  1. #1
    Registriert seit
    20.07.2012
    Beiträge
    108
    Danke
    9
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Bild 1.png
    Hallo zusammen,

    Steuerung : ET 200 s, S7 v5.5 SP 2
    TP : TP 177 B , WInCC flexible 2008 SP 2

    Ich benutze auf dem TP 177 B :

    - eine Meldeanzeige für Meldungen, hier werden anstehende Warnungen od. Störungen angezeigt
    - eine Meldeanzeige für Meldeereignisse, hier werden die Warnungen und Störungen abgespeichert

    Es funktioniert beides soweit, ich habe aber leider noch ein Problem

    Problem :

    ( Bitwechsel von 0 auf 1 )
    Mein Problem betrift die Meldeanzeige für Meldeereignisse. Sobald in meinem Programm z.b eine

    Grenzwertüberschreitung ( Bitwechsel von 0 auf 1 ) für pH stattfindet ( siehe Bild 1 ) dann wird auch in der

    Meldeanzeige für Meldungen die Meldung angezeigt und auch in der Meldeanzeige für Meldeereignisse

    abgespeichert.

    ( Bitwechsel von 1 auf 0 )
    ABER sobald nun der pH Wert wieder einen normalen Wert erreicht, speichert die Meldeanzeige für

    Meldeereignisse trotzdem diese Meldung als Überschreitung des pH Wertes ab. Also die Meldung erscheint quasi

    zwei mal. Iwie wird diese Meldung bei einem Wechsel von 0 auf 1 und 1 auf 0 gespeichert. Kann man dies Iwie ändern.

    Positive flanke kann ich nicht verwenden da sonst die Meldeanzeige für Meldungen nicht richtig funktioniert

    Freundliche Grüße

    Jeremy
    Zitieren Zitieren Bitmeldungen / TP 177 B  

  2. #2
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.622
    Danke
    377
    Erhielt 799 Danke für 642 Beiträge

    Standard

    Es gibt 3 Ereignisse pro Alarmmeldung die in eine normale Meldeanzeige angezeigt werden: "Gekommen", "quittiert" und "gegangen".
    Es sieht aus wie du hast keine Speicherung + Quittierung von dein Alarm, also hast du für jede alarm "gekommen" und "gegangen".
    Wenn du Speicherung und Quittierung programmierst, kannst du eine Meldeanzeige konfigurieren der nur die nicht-quittierte Alarmmeldungen anzeigt.
    Geändert von JesperMP (09.01.2013 um 12:59 Uhr)
    Jesper M. Pedersen

  3. #3
    Jeremy3 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    20.07.2012
    Beiträge
    108
    Danke
    9
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ok, also gibt es zwischen den beiden Meldungen die gleich aussehen doch einen Unterschied wie du es sagst.
    Es wird ausgegeben wenn die Meldung gekommen ist und es wird ausgegeben wenn die Meldung gegangen ist , Bitwechsel von 0 auf. 1 und Bitwechsel von 1 auf 0.

    Frage :
    1. Kannst du mir auch sagen ob das in der Meldeanzeige irgendwo vermerkt ist ob die Meldung Gekommen od. Gegangen ist und wie man das gegebenfalls umstellen kann ?

    Freundliche Grüße

    Jeremy

  4. #4
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.622
    Danke
    377
    Erhielt 799 Danke für 642 Beiträge

    Standard

    In den Meldefenster gibts es eine Kolonne "Status".
    Wenn ein Alarm kommt steht da "1".
    Wenn ein Alarm gekommen und danach gegangen ist steht da "10".
    Wenn ein Alarm gekommen, gegangen, und quittiert ist, steht da "10x".

    edit: "1", "10", "10x" oder "K", "G", "Q" häng vermutlicht von den projektierte Sprache ab.
    Geändert von JesperMP (10.01.2013 um 13:25 Uhr)
    Jesper M. Pedersen

  5. #5
    Registriert seit
    29.09.2005
    Beiträge
    124
    Danke
    6
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Hallo Jeremy,

    das hatte ich absichtlich so projektiert. Daher gibt es ja die Meldeereignisanzeige separat. Die Ereigniscodes werden immer mitgeloggt K,G und Q für Kommen, Gehen und Quittieren.

    Gruß

    Jochen

    P.S.: Wenn Du sowas hast, schau doch in meiner Bachelorthesis nach, die bei Euch im Regal steht, da habe ich die komplette Anlage wirklich bis ins kleinste dokumentiert. Kapitel 5.2, "Störmeldesystem" ab Seite 34.
    Geändert von Jochen (10.01.2013 um 13:20 Uhr)

  6. #6
    Jeremy3 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    20.07.2012
    Beiträge
    108
    Danke
    9
    Erhielt 0 Danke für 0 Beiträge

    Standard

    @ JesperMP

    ja stimmt, Wenn man an der Meldeanzeige unter Eigenschaften Spalten Sichtbare SPalten ein Häckchen bei Zustand anklickt, dann ergibt das ganze auch Sinn. Es steht einmal G für gegangen und einmal K für Kommen sobald ich den pH Wert über Pufferlösungen ändere.

    @ Jochen
    Hallo Jochen,

    Ich habe das Meldesystem über FUP und nicht SCL programmiert da ich zum ersten mal damit arbeite und das lieber so mache das ichs erstmal verstehe bevor ich auf SCL sofort umsteige. Noch habe ich mir dein SCL Programm für das Störmeldesystem nicht angeschaut, und würde wahrscheinlich auch nicht so schnell in dein Program durchblicken, deswegen habe ich das einfach so gemacht wie ich es am einfachsten gefunden habe. Aber herzlichen Dank für den Tipp mit deiner Bachelor - Thesis !
    _ _ _ _ _ _ _
    Da nutze ich doch aber gerne die Gelegenheit dich etwas zu fragen da mir eine Sache auf die Nerven geht. Ich habe für die Et 200 s und das Panel im Großes Gewächshaus eine Netzwerkdose an meinem Schreibtisch installiert über die ich auf die Anlage zugreife. Mir gehts aber auf die Nerven nach einer Programmänderung ins Gewächshaus zu rennen und verschiedene Inputs am Touchpanel vorzunehmen. Da habe ich etwas von Sm@rt Service hier im Forum gelesen. Kennst du dich da zufällig aus ? Ich würde nämlich gerne vom PC aus das Touchpanel als Fernbedienung nutzen ( Beobachten u. Steuern ). Ansonsten würde ich mich im Internet noch informieren

    P.S Alles ok soweit am ZEMA ?
    Freundliche Grüße

    Jeremy

  7. #7
    Registriert seit
    20.06.2003
    Ort
    Sauerland.NRW.Deutschland
    Beiträge
    4.850
    Danke
    78
    Erhielt 800 Danke für 543 Beiträge

    Standard

    das ist denkbar einfach. panal muss natürlich auch am ethernet hängen.
    im flexible unter geräteeinstellungen einfach einen haken bei 'sm@rtaccess oder service: sm@rt server starten'
    mit dem smartclient (findest du im startmenü bei ...flex runtime...) (oder auch mit einem anderen vnc-client) kannst du dann darauf zugreifen. standartpasswort ist 100.
    wenn du keine lizenz dafür hast erscheint alle 10min eine hässliche meldung auf dem panel die du wegklicken musst.
    .
    mfg Volker .......... .. alles wird gut ..

    =>Meine Homepage .. direkt zum Download

    Meine Definition von TIA: Total Inakzeptable Applikation

  8. #8
    Jeremy3 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    20.07.2012
    Beiträge
    108
    Danke
    9
    Erhielt 0 Danke für 0 Beiträge

    Standard

    @volker

    wie lässig ist das denn , hat auf anhieb funktioniert total coole Sache ! Hab ja heute nen guten Tag erwischt

    herzlichen Dank

    In der Tat kommt eine hässlige Meldung. Ist das quasi nur ein Lizenzcode den man noch übertragen müsste oder wie kriegt man die genau weg ? Kommt die hässlige meldung nur aufm pc eigentlich oder wird diese auch auf dem Panel angezeigt ?

    freundliche Grüße

    Jeremy

  9. #9
    Registriert seit
    29.09.2005
    Beiträge
    124
    Danke
    6
    Erhielt 2 Danke für 2 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Jeremy, Du kannst direkt auf das Panel auch per Webbrowser drauf zugreifen, hab ich auch immer gemacht. Einfach die IP im Browser angeben und dann kommt ein Screen, wo Du Remotecontrol auswählen kannst. Dann mit dem Standardpasswort 100 einloggen und fertig. Die Lizenz muss natürlich transferiert werden. Wir haben aber noch Lizenzen, kontaktier mich am besten mal dazu.

    Jochen

Ähnliche Themen

  1. TP 177 A an Profibus?
    Von dpd80 im Forum HMI
    Antworten: 15
    Letzter Beitrag: 10.01.2013, 10:26
  2. TP 177 B Rezeptverwaltung
    Von Spsneuling im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 08.05.2009, 17:47
  3. Kurvenanzeige TP 177 B
    Von mitchih im Forum HMI
    Antworten: 3
    Letzter Beitrag: 03.06.2008, 08:31
  4. Op 177
    Von viperlk6 im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 17.02.2007, 06:32
  5. Op 177
    Von viperlk6 im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 16.02.2007, 17:12

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •