Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 16

Thema: Visualisierung mit S5 135 U?

  1. #1
    Registriert seit
    09.11.2003
    Beiträge
    50
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    wir haben ein kleines Problem.

    Wir haben eine Anlage die über 2 CPUs 1*CPU 921 und CPU 922 und einen Koordinator betrieben wird. Außerdem haben wir noch einen CP 1412 oder so ähnlich, weiß ich jetzt nicht mehr genau. Diese CP-Schnittstelle hat einen Ethernetanschluß die wir auch über einen Ping erreichen können. Dann ist noch so ein schwarzer Kasten, ich weiß nicht, ist das sowas wie ein Repeater, da ist das Kabel von der CPU 1 und von der CPU 2 angeschlossen. Weiter gehts von diesem "schwarzem" Kasten über BNC Anschluß auf eine andere Steuerung und auch in unseren Leitstand. Arcnet oder so ähnlich müßte dieser Aufbau heißen. Auf diesem schwarzen Kasten ist auch eine TTY Schnittstelle, mit der ich von jedem "schwarzen" Kasten die CPU1 und CPU 2 über Step5 erreichen kann. Aber jeweils immer nur für das geladene Projekt. Also wenn ich Projekt CPU 1 öffne, erreiche ich CPU 1 und das gleiche nochmals für die CPU 2.

    Das Problem ist jetzt aber, wenn ich das ProToolProjekt über Runtime laufen lassen, und das TTY Kabel an die TTY Schnittstelle anstecke, kann ich immer nur auf eine CPU zugreifen, nicht aber auf beide. Wir haben heute festgestellt, wenn ich vorher in Step 5 das Projekt der CPU 1 lade, das TTY-Kabel abstecke und an den Labtop mit dem ProToolprojekt anstecke, können wir auf die Variablen der CPU 1 zugreifen, nicht aber auf die CPU 2. Irgendwie ist das komisch, weil ja nicht eingestellt werden kann, mit wem sich ProTool verbinden soll.

    Meine Frage kommt eigentlich erst jetzt, gibts denn e Möglichkeit in ProTool oder auch WinCC beide CPUs über den CP 1412 (glaub ich, das er so heißt) über Ethernet zu erreichen? In ProTool haben wir heute keine Möglichkeit gefunden eine Ethernetadresse einzustellen. In WinCC gibts ja verschiedene Kommunikationstreiber, aber wir wußten nicht, welchen wir jetzt dafür einsetzen müssen! Hat jemand von euch vielleicht einen Tipp für uns. Am besten wärs natürlich wenns über Ethernet ne Möglichkeit geben würde!

    Vielen Dank für eure Antworten und natürlich dafür das ihr diesen Roman gelesen habt

    Viele Grüße
    Michael

    Nachtrag:

    Ich habe in WinCC einen Kommunikationstreiber installiert der nennt sich "Simatic S5 Ethernet Layer 4" und dann den Kanal Unit S5 Transport TCP/IP" installiert. Er fragt nach der IP-Adresse. Die kann ich ihm noch nennen aber was oder woher bekomme ich diese TSAP? Wir haben für diesen CP noch ne Software INAT, kann es sein, da in diesem Programm alle relefanten TSAPs stehen? Also Eigener und Fremder TSAP für Read und Eigener und Fremder TSAP für Write? So viele neue Sachen ist ganz schon hart!!

    Wäre echt super von euch, wenn mir jemand weiterhelfen könnte!!
    Zitieren Zitieren Visualisierung mit S5 135 U?  

  2. #2
    Registriert seit
    18.07.2003
    Beiträge
    228
    Danke
    4
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Hallo Michael,

    am besten setzt du dich mit Inat www.inat.de in Verbindung, die können dir sicher weiterhelfen.
    Die sitzen in Nürnberg und sind sehr kompetent und hilfsbereit.

    Wenn nicht sag bescheid dann such ich in meinen Unterlagen.

  3. #3
    Anonymous Gast

    Standard

    Mahlzeit,

    'Schwarze Kiste mit Arcnet', da fallen mir zwei Hersteller ein K+W und Deltalogic, von beiden gab es da mal Lösungen, vielleicht gibt es di auch noch. Wenn ich mich richtig erinnere kann man die Ziel-CPU per Busanwahl adressieren.

    Guckst Du hier:

    http://home.t-online.de/home/k_w.gmbh/
    http://www.deltalogic.de
    Zitieren Zitieren Schwarze Kiste mit Arcnet  

  4. #4
    Registriert seit
    09.11.2003
    Beiträge
    50
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo,

    also INAT hat mir geantwortet, nur leider sehr dürftig. Auf jedenfall soll es funktionieren mit einer RFC1006 Verbindung. Habe mir von INAT ne Anleitung runtergeladen, wie man eine S5 mit S5 TCP/IP an den OPC Server von INAT bindet. Ungefähr sind wir jetzt nach dieser Anleitung gegangen, nur mit dem Unterschied, das wir eben noch das Häckchen RFC1006 Verbindung gesetzt haben. Leider gings nicht. WinCC kann keine Verbindung aufbauen.

    Vielleicht weiß hierzu jemand was grundlegendes.

    Also in unserer Steuerung 135 u ist der Synchronbaustein FB 125. Er sollte nur nach einem Wiederanlauf bzw. nach einem Neustart einmal ausgeführt werden. Er synchronisiert die Daten der CPU und dem CP, sowie ich es verstanden habe.

    Receive-All Baustein ist bei uns der FB 127 und der FB 126 der Send-ALL Baustein. Sowie ich es verstanden habe, werden die zwei FBs unbedingt aufgerufen, sodaß sie immer bearbeitet werden.

    Diese FBs brauchen anscheinend keine Auftragsnummer bzw. 0 und sie beziehen sich nicht auf die Auftragsnummer der Verbindung die ich INAT Parametriersoftware anlegen.

    Man muß dazusagen, das wir in CPU 2 arbeiten und wir in der Parametriersoftware den Kachelwert auf 1 setzen. Da ja 0 = CPU 1 und 1 = Cpu2 usw.

    Vielleicht probieren wir mal es mit OPC Server von INAt, der ist 72 Stunden lauffähig und ne Anleitung haben wir auch dazu. Dan muß es klappen und wir schliessen andere Fehler aus. Gibts denn ne Möglichkeit, vorrausgesetzt die Verbindung über den OPC Server hat geklappt, das ich die Variablen dann mit WinCC sichtbar machen kann (über den OPC server?)

    Vielleicht hat hier jemand noch einen Tipp an uns. Wäre echt toll. So ne bebilderte Anleitung werde ich mal erstellen, wenn es geklappt hat, das sich der nächste nicht wieder so ärgern muß!!!

    Gruß
    Michael

  5. #5
    Registriert seit
    18.07.2003
    Beiträge
    228
    Danke
    4
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Hallo Michael,

    das Inat dürftig antwortet wundert mich....
    Naja.
    Mit dem OPC-Server von Inat solltest du keine großen Probs haben ist leicht bedienbar.
    Ich habe da noch ne Frage, wie sind die CPU's mit der CP (Ethernet) verbunden?

    Ciao

  6. #6
    Registriert seit
    09.11.2003
    Beiträge
    50
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo AndyPed,

    vielleicht versteh ich die Antwort auch nicht.

    Die CPUs sind einfach nur gesteckt und wahrscheinilch über den Bus auf der Rückwandplatine verbunden. Am linken Steckplatz steckt der Koordinator, dann CPU 1 und CPU 2.

    Also wir haben das heute mal probiert mit dem OPC Server von INAT.

    Leider sind wir nicht zu einem Ergebnis gekommen.

    Im OPC Server wird eine Verbindung angezeigt, sie wird auch grün. In der Parametriersoftware von INAT tut sich auch was, es werden Daten übertragen. Der OPC Server meldet jedoch noch, er empfängt Daten obwohl kein FetchonEvent anliegt! Wenn man jetzt im INAT OPC Client irgendeine Variable angibt, kommt unter Sub Value Invalid und unter Sub Quality Uncertain. Also kein Wert und/oder keine Verbindung zur SPS.

    Eigentlich haben wir das mit dem Receive/Send all noch nicht ganz verstanden. In der CPU befindet sich bereits ein Send All, jedoch ist der nicht so wie in der Anleitung von INAT beschrieben parametriert.

    Es wird bei der SSNR: 0,210 angegeben und nach Anleitung wäre es 0,0. Es darf der SendAllBaustein ja nur einmal aufgerufen werden oder?

    Hastu du für mich vielleicht ein kleine Hilfestellung wie die Synchron und Receive/Send All Bausteine in AWL aussehen müßten, damits funktioniert.

    Ich nehme mal an die Receive/Send All Bausteine werden immer aufgerufen, kann ich also auch im OB 1 aufrufen, einfach
    SPA FB126
    SPA FB125

    Der Synchronbaustein ist auch schon vorhanden, der wird immer nach einem Neustart und nach Wiederanlauf aufgerufen, somit muß ich mit diesem Baustein nichts mehr machen oder?

    Vielleicht machen wir einfach im diesem OPC Client noch was falsch, ich weißt es auch nicht mehr. Ganz schön kompliziert, wenn man sowas noch nie gemacht hat.

    Angenommen es besteht schon eine Verbindung zu einem OPC Server und wir machen jetzt noch einen dazu. Dann ist ja bereits ein Receive/Send All im Programm und auch der Synchronbaustein und für meinen OPC Server brauch ich die Hantierungsbausteine dann nicht mehr?

    Viele Grüße
    Michael

  7. #7
    Registriert seit
    18.07.2003
    Beiträge
    228
    Danke
    4
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Hallo Michael,

    nur mal kurz ein parr Tipps. Um ne ausfühliche Anleitung zu erstellen werde ich wohl 1-2 Mittagspausen brauchen.

    Der Synchronbaustein solltest du in den Anlauf OBs OB20 und OB21 aufrufen.

    Wie sind die Einstellungen in den FB 125 - 127 ?

    zeig mal

    Generell kann ich dir wirklich mal empfehlen nen Kurs bei INAT mitzumachen.
    "Ethernet TCP/IP in der Automatiserung" ist da für dich genau das richtige.
    Hinzu kommt noch das Nürnberg ne richtig geile Stadt ist.
    Der Preis ist zwar nicht ohne (ca. 1200 ¤ für 3 Tage) aber die Infos die du da kriegts sind Klasse

    Ciao

  8. #8
    Registriert seit
    09.11.2003
    Beiträge
    50
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Guten Morgen AndyPed,

    ja du hast recht . Mit Kopplung S7 über Ethernet das klappt schon ziemlich aber mit S5 habe ich nie was gemacht.

    Also in der CPU 2 haben wir folgende Bausteine.

    Wie du schon gesagt hast, ist der Synchronbaustein in Ob20 und Ob21 aufgerufen.

    Was komisch ist, laut der INAT-Anleitung müßte der ReceiveAll Baustein so aussehen.

    SPA FB 245 (Das ist bei der 135U der FB126 oder FB125, weiß ich nicht mehr genau)
    NAME: RECEIVE
    SSNR: KY 0,0
    A-NR: KY 0,0
    ANZW: MW192
    ZTYP: KC NN
    DBNR: KY 0,0
    ZANF: +0
    ZLAE: +0
    PAFE: MB 164

    Meiner Meinung nach ist INAT hier ein Fehler unterlaufen, da das für mich ein normaler Receive Baustein ist. Wird in der Beschreibung ausdrücklich darauf hingewiesen, das man die Receive/Send ALL Hantierungsbausteine braucht.

    Wenn wir den FB 126 aufrufen sieht das so aus.

    SPA FB 126 (Baustein wurde von uns eingefügt, da er im Programm noch nicht vorhanden war)
    NAME: RECEIVE-A
    SSNR: KY 0,0
    A-NR: KY 0,0
    ANZW: MW192
    PAFE: MB 164

    Ebenso mit dem SEND Baustein

    Laut INAt:
    SPA FB 244

    NAME: SEND
    SSNR: KY 0,0
    A-NR: KY 0,0
    ANZW: MW188
    ZTYP: KC NN
    DBNR: KY 0,0
    ZANF: +0
    ZLAE: +0
    PAFE: MB 161

    Bei uns: (Der Baustein ist bereits im Programm vorhanden.)
    SPA FB 126
    NAME: SEND-A
    SSNR: KY 0,201 <---- Laut INAT müßte hier 0 stehen
    A-NR: KY 0,0 <---- Hier gehört normal die Auftragsnummer rein
    ANZW: MW192
    PAFE: MB 164
    SPA FB125

    Ansonsten haben wir es GENAU so gemacht, wie es in der Anleitung von INAT steht. Mit dem einzigen Unterschied, das wir den Auftragsoffset in der Parametriersoftware von INAT für den CP S5 TCP/IP auf 1 gesetzt haben, da wir ja die Baustein in der CPU 2 haben. Habe gelesen, Auftragsoffset 0 = CPU 1 und Auftragsoffset 1 = CPU 2. Die Auftragsnummer ist anscheinend egal, wir ja nicht zwei Verbindungen parametrieren können mit der selben Auftragsnummer, also haben wir die Auftragsnummer, die uns INAT Parametriersoftware vorgeschlagen hat, übernommen. So stehts auch in der Anleitung. "Sie können die vorgeschlagene Auftragsnummer übernehmen"

    Deine Mittagspausen brauchst du nicht für mich opfern!!! Wenns nicht geht, dann hilfts eh nicht!

    Viele Grüße
    Michael

  9. #9
    Registriert seit
    18.07.2003
    Beiträge
    228
    Danke
    4
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Hallo Michael

    ich bin leider auch nicht der S5 freak.

    ich denke aber das Problem ist eher an der OPC-Server Seite.

    Da ih ja immerhin ein "uncertain" kriegt

    beschreib mal die Server-einstellungen.
    Arbeit ihr mit Fetch & Write passiv oder aktiv ?

    Cruß Andy

  10. #10
    Registriert seit
    09.11.2003
    Beiträge
    50
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ich glaubs auch schon fast,

    also die Servereinstellungen in OPC - Server ist das Häckchen bei Verbindungsaufbau auf Aktiv.

    In der Parametriersoftware vom CP ist Fetch passiv und Write passiv und Verbindungsaufbau passiv ein Häckchen.

    Eben genauso wie von INAT beschrieben.

    Gruß
    Michael

Ähnliche Themen

  1. Visualisierung am PC
    Von ellawo im Forum HMI
    Antworten: 11
    Letzter Beitrag: 07.10.2009, 16:26
  2. Web-Visualisierung
    Von winniepuh im Forum HMI
    Antworten: 1
    Letzter Beitrag: 22.02.2006, 17:13
  3. Visualisierung in VB
    Von Jochen Kühner im Forum HMI
    Antworten: 9
    Letzter Beitrag: 14.10.2005, 14:17
  4. Visualisierung mit VB
    Von Jochen Kühner im Forum HMI
    Antworten: 1
    Letzter Beitrag: 21.09.2005, 16:35
  5. Visualisierung von ASI Bus
    Von Daniel B im Forum Feldbusse
    Antworten: 3
    Letzter Beitrag: 04.09.2003, 00:16

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •