Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 10 von 10

Thema: Keine Verbindung zum Mobile Panel

  1. #1
    Registriert seit
    26.11.2010
    Beiträge
    181
    Danke
    9
    Erhielt 13 Danke für 13 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo

    Ich habe ein Simatic Mobile Panel 277 und dazu zwei Docking Stationen
    die über Profibus mit der Steuerung verbunden sind.
    Wenn ich die Batterie herausnehme und das Panel "durchstartet"
    kommt eine Verbindung zustande und alles läuft ohne Probleme.
    Wenn ich aber einmal abgesteckt habe und nach ca. 1 Minute
    an der selben oder an der anderen Station wieder anstecke
    kommt keine Verbindung mehr zustande.

    Gibt es für das Mobile Panel irgendwelche besonderen Einstellungen
    für den Verbindungsaufbau entweder im Panel in der Systemsteuerung
    oder im WinCC Flex Projekt?
    Oder sind in den Dockingstationen Einstellungen zu machen?

    Wie ist dabei mit der Profibus Adresse der Dockingstation?
    Muss man beide Stationen mit der selben Adresse einstellen,
    das passt aber nicht zum Profibus, meiner Meinung nach.

    Gruß
    Bernhard
    Zitieren Zitieren Keine Verbindung zum Mobile Panel  

  2. #2
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.624
    Danke
    377
    Erhielt 801 Danke für 642 Beiträge

    Standard

    Zitat Zitat von IPC Bernhard Beitrag anzeigen
    Gibt es für das Mobile Panel irgendwelche besonderen Einstellungen
    für den Verbindungsaufbau entweder im Panel in der Systemsteuerung
    oder im WinCC Flex Projekt?
    Ich habe keine Erfahrung mit Mobile Panels, aber ich konnte mir vorstellen das man den Busprofil auf "Standard" setzen muss (nicht auf "DP").

    Zitat Zitat von IPC Bernhard Beitrag anzeigen
    Wie ist dabei mit der Profibus Adresse der Dockingstation?
    Muss man beide Stationen mit der selben Adresse einstellen,
    das passt aber nicht zum Profibus, meiner Meinung nach.
    Wenn beide Mobile Panels gleichzeitig verbunden werden können, dann müssen sie individuelle Adressen haben.

    Sind beide Mobile Panels in den STEP7 Projekt integriert ?
    Es ist wichtig das beide Panels für den Berechnung von den Profibus TTR "bekannt" sind. Wenn ein falsche TTR berechnet wäre konnte es Probleme geben, obwohl ich nicht weiss ob es die Auswirkung hat wie du es gesehen hast.
    Jesper M. Pedersen

  3. #3
    Registriert seit
    25.06.2007
    Ort
    Dresden
    Beiträge
    3.930
    Danke
    465
    Erhielt 878 Danke für 634 Beiträge

    Standard

    @Jesper

    Zitat Zitat von IPC Bernhard Beitrag anzeigen
    Ich habe ein Simatic Mobile Panel 277 und dazu zwei Docking Stationen
    die über Profibus mit der Steuerung verbunden sind.
    @IPC Bernhard

    Ein Dockingstation hat KEINE eigene Adresse. Es ist die Adresse maßgeblich, die im Mobile Panel eingesellt ist.
    Die Schalter in der Dockingstation sind zum Einstellen der Box ID!
    Grüße Frank

  4. #4
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.624
    Danke
    377
    Erhielt 801 Danke für 642 Beiträge

    Standard

    Argh!

    Aber nichtdestotrotz ist es ein Versuch wert den Hinweis über Projektintegration und TTR zu probieren.
    Jesper M. Pedersen

  5. #5
    Registriert seit
    25.06.2007
    Ort
    Dresden
    Beiträge
    3.930
    Danke
    465
    Erhielt 878 Danke für 634 Beiträge

    Standard

    Zitat Zitat von JesperMP Beitrag anzeigen
    Aber nichtdestotrotz ist es ein Versuch wert den Hinweis über Projektintegration und TTR zu probieren.
    Wenn das Moblie Panel nicht integriert ist - oder werden soll - dann muss der Zähler bei Verbindungsresourcen in der Maske CPU - HWKonfig - um eins erhöht werden.
    Sonst wird zur Laufzeit nicht genug Pollingreserve für das Panel freigelassen und der Token ist beim nächsten Busteilnehmer bevor das Panel reden kann.
    Grüße Frank

  6. #6
    IPC Bernhard ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    26.11.2010
    Beiträge
    181
    Danke
    9
    Erhielt 13 Danke für 13 Beiträge

    Standard

    Hallo

    Das Ganze ist bei mir in ein PCS7 Projekt integriert.
    Das Panel hängt an einem CP 443 (Profibus).

    Es ist gut zu wissen dass die Adresse der Anschlussbox nicht die Profibusadresse ist.

    Muss man die Verbindungsresource dann im CP einstellen oder ist diese auch in
    der CPU zum Einstellen?

    Muss man dann die Verbindung über den NETPRO laden?

    In der Diagnoes vom CP 443 ist auch der Teilnehmer nicht zu sehen.
    Aber ich denke mal da er in der HW Konfig auch nicht drin ist,
    dann ist er in der Diagnose auch nicht vorhanden.

    Gruß
    Bernhard

  7. #7
    Registriert seit
    25.06.2007
    Ort
    Dresden
    Beiträge
    3.930
    Danke
    465
    Erhielt 878 Danke für 634 Beiträge

    Standard

    Zitat Zitat von IPC Bernhard Beitrag anzeigen
    Das Ganze ist bei mir in ein PCS7 Projekt integriert.
    Das Panel hängt an einem CP 443 (Profibus).
    .....
    Muss man die Verbindungsresource dann im CP einstellen oder ist diese auch in
    der CPU zum Einstellen?

    sieh Eigenschaften der CPU:

    Jede Kommunikationsverbindung benötigt auf der S7-CPU eine Verbindungs-Ressource als Verwaltungselement für die Dauer des Bestehens der Kommunikationsverbindung. Entsprechend den technischen Daten stehen jeder S7-CPU eine bestimmte Anzahl von Verbindungs-Ressourcen zur Verfügung, welche von verschiedenen Kommunikationsdiensten (PG/OP-Kommunikation, S7-Kommunikation oder S7-Basis-Kommunikation) belegt werden.
    Wenn sich Kommunikationsdienste anmelden, werden die Verbindungs-Ressourcen nach der zeitlichen Reihenfolge der Anmeldung belegt.

    Um die Belegung der Verbindungs-Ressourcen nicht nur von der zeitlichen Reihenfolge der Anmeldung verschiedener Kommunikationsdiensten abhängen zu lassen, besteht für folgende Dienste die Möglichkeit, Verbindungs-Ressourcen zu reservieren:

    · PG-Kommunikation und OP-Kommunikation

    · S7-Basis-Kommunikation

    Für die PG/OP-Kommunikation wird jeweils mindesten eine Verbindungs-Ressource als Vorbelegung reserviert. Kleinere Werte sind nicht möglich.


    --->Für die PG/OP-Kommunikation wird jeweils mindesten eine Verbindungs-Ressource als Vorbelegung reserviert <-- sobald ein PG UND ein PANEL am Strang hängt ist Feierabend. Daher manuell auf zwei setzen



    Zitat Zitat von IPC Bernhard Beitrag anzeigen
    Muss man dann die Verbindung über den NETPRO laden?

    Ein Panel kommuniziert auf BASIS der OP-Kommunikation.

    Der Weg, d.h. MPI/DP/PN wird dabei nur im Panel eingestellt. Eine NETPRO Anbindung ist nicht nötig.

    Es ist daher bei einem Panel-Standalone-Projekt nur der Adresse/Rackbezug der CPU anzugeben NICHT des CP. Dieser Fehler wird gern genommen.
    Grüße Frank

  8. #8
    IPC Bernhard ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    26.11.2010
    Beiträge
    181
    Danke
    9
    Erhielt 13 Danke für 13 Beiträge

    Standard

    Hallo

    Desweiteren habe ich noch ein zusätzliches Problem, ich kann das Panel nicht mehr laden.
    Das Ganze ist wie gesagt in ein PCS7 intergriert.
    Es ist in der Komponenten Sicht genau wie eine CPU nur eben ein WINCC Flexible Projekt.
    Die Verbindung der Variablen ist eingerichtet und die beiden Stellen kennen sich.

    Normalerweise bin ich mit der Schnittstelle PCInternal/local Online zum CFC Projektieren usw..

    Dann stelle ich unter PG/PC Einstellungen den PG Betrieb ein,
    wechsle im Simatic Manager die PG/PC Schnittstelle auf CP 1623
    und in dem PG/PC ordne ich die Schnittstelle CP 1623 (RFC 1006) zu.

    So hat es schon eine ganze Weile funktioniert, aber jetzt nicht mehr.

    Im WINCC Flexible habe ich dann beim Transfer eine weitere Zeile
    gesehen worüber das Laden ausgeführt wird. Diese Zeile ist
    nun auch nicht mehr sichtbar.

    ES komplett durchstarten hat auch nichts gebracht.

    Gibt es da irgendeinen Haken den ich eventuell nicht richtig
    gesetzt habe?

    Gruß
    Bernhard

  9. #9
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.624
    Danke
    377
    Erhielt 801 Danke für 642 Beiträge

    Standard

    Keine Ahnung wo es liegt.
    In WinCC Flexible Transferdialog, hast du "Ethernet" oder "S7Ethernet" gewählt ?
    Probier "Ethernet". Es funktioniert unabhängig von die Einstellungen in PG/PC Schnittstelle.
    Und den Verbindung zum Panel mittels PING testen. Wenn PING klappt, klappt den Transfer auch.

    Im WINCC Flexible habe ich dann beim Transfer eine weitere Zeile
    gesehen worüber das Laden ausgeführt wird. Diese Zeile ist
    nun auch nicht mehr sichtbar.
    Screenshot bitte.
    Jesper M. Pedersen

  10. #10
    IPC Bernhard ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    26.11.2010
    Beiträge
    181
    Danke
    9
    Erhielt 13 Danke für 13 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo

    Am Ende geht doch alles wieder, meistens.

    Es ist zwar fast unglaublich aber es hat sich das Betriebssytem selbst aufgehängt.
    Ich habe z.B. die DP Geschwindigkeit auf 500KBit heruntergesetzt und mit OK bestätigt.
    Beim nächsten öffen des Dialogs war wieder 1,5 MBit drin !?!
    Das Panel über Routing (Profibus) laden ging auch nicht mehr aber über Ethernet,
    aber auch dann gab es keine Kommunikation über Profibus!!?!

    Ich habe das Betriebssystem einmal neu übertragen und im Anschluss das Projekt
    und es läuft alles wieder.

    Naja wieder was dazugelernt.

    Danke nochmal an alle

    Gruß
    Bernhard

Ähnliche Themen

  1. Antworten: 3
    Letzter Beitrag: 02.12.2011, 16:30
  2. Mobile Panel 170 v.s. Mobile Panel 177DP
    Von CZach001 im Forum HMI
    Antworten: 5
    Letzter Beitrag: 03.09.2009, 08:47
  3. Keine Verbindung zum TP 177A
    Von Valmont87 im Forum HMI
    Antworten: 12
    Letzter Beitrag: 06.02.2009, 19:10
  4. Keine Verbindung zum CP143
    Von S5-Bastler im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 16.01.2009, 14:28
  5. Antworten: 4
    Letzter Beitrag: 23.10.2008, 22:51

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •