Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 8 von 8

Thema: Ausgabe von analogen Messwerten

  1. #1
    Registriert seit
    14.03.2013
    Beiträge
    3
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo alle zusammen

    ich bearbeite gerade eine Aufgabe bei der ich nicht weiter weiß...

    Eine Temperatur (160- 270Grad Celsius) soll erfasst werden. Der gemessene Wert soll dann an einem Siemens Touch Panel ausgegeben werden.

    Die Umrechnung von den Digits im PEW zu einem MD klappt bereits.

    Mein Problem ist dass ich in Win CC flexible zwar die Schaltfläche E/A gefunden hab, auch das MD als Ausgang einstellen kann, jedoch zeigt das Touch Panel das Komplette EA feld nicht an und folglich ist kein wert ablesbar.

    Ich hoffe ihr wisst um Rat

    Danke schon mal im vorraus

    David
    Zitieren Zitieren Ausgabe von analogen Messwerten  

  2. #2
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.184
    Danke
    923
    Erhielt 3.290 Danke für 2.659 Beiträge

    Standard

    Ich meine mich zu erinnern, daß man Variablen einfach per Drag/Drop in ein Bild ziehen kann, dann erstellt WinCC flexible automatisch ein rudimentäres EA-Feld. Mache das mal und schau ob dieses dann sichtbar ist. Dann vergleiche die Einstellungen diese EA-Feldes mit Deinem EA-Feld.

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  3. #3
    Registriert seit
    20.06.2003
    Ort
    Sauerland.NRW.Deutschland
    Beiträge
    4.850
    Danke
    78
    Erhielt 800 Danke für 543 Beiträge

    Standard

    prüf mal ob das ea feld im komplett sichtbaren bereich liegt. es ist möglich das feld zu verschieben, das ein teil ausserhalb des bildschirms liegt. dann wird das feld nicht angezeigt.
    .
    mfg Volker .......... .. alles wird gut ..

    =>Meine Homepage .. direkt zum Download

    Meine Definition von TIA: Total Inakzeptable Applikation

  4. #4
    DavidS ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    14.03.2013
    Beiträge
    3
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    hallo
    danke schon mal für die schnellen antworten, allerdings besteht das Problem weiterhin.
    die Variablen reinziehn hab ich getestet, funktioniert nicht und das Feld liegt auch sicher im sichtbaren Bereich, jedoch bekomme ich beim Generieren des Bildes einen generator Fehler:

    Fataler Fehler [Position Exception occured in: ProTool1. ViewTool1. ViewIOField, Grund: Ein Aufrufziehl hat einen Ausnahmefehler verursacht]
    kann mir denn wer " Ein Aufrufziehl hat einen Ausnahmefehler verursacht" erklären?

    ...eine Warnung bekomme ich auch:
    Interne Warnung (Detail: screen elemnt EA-Feld.1 (3fde 3fe6 b3c4 4daf aded c406 40a5 1892) of type IO Field was created by Generator HMI Screen (ScreenBild_1) - Pbjekttyp: Screen. ITEM)

    Ich kanns allerdings hochladen also kann der Fehler ja nicht am Bild liegen oder??

    Könnte es am Datentyp liegen, der durch das EA Feld angezeigt werden soll?
    Den MD20 hab ich beim Panel schon alle möglcihen Datentypen annehmen lassen, sogar Zeit ohne Erfolg :P

    Mein Programm sieht so aus:
    L PEW752
    ITD
    DTR
    L 7,987e+3
    -R
    L 1,536e+2
    /R
    L 1,1e+2
    +R
    T MD20

    Meine Formel sieht dazu so aus:

    Grad in Prozent= (Wert aus PEW752 - Offset)/(Digits pro Grad Celsius) + Nullpunktverschiebung

    mit Werten: 218°C=(24575-7987)/153,6+110°C

    Dann ist doch MD20 eine Gleitpunktzahl, welche ich mir durch Beobachten "Brille" anzeigen lassen könnte, allerdings wenn ich die "Brille" aufsetze, sehe ich eine nur eine Hexadezimale Zahl (0 bis 9 und a bis f).
    Und wenn ich beim ersten /R gucke dann ist der Wert nicht kleiner sondern größer

    Ich benutze:
    SPS 314C- 2DP
    Touch Panel OP177B color
    mittels MPI verbunden um Netzwerkfehler auszuschließen

  5. #5
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.184
    Danke
    923
    Erhielt 3.290 Danke für 2.659 Beiträge

    Idee

    Welche Version von WinCC flexible benutzt Du? Welche Windows-Version hat Dein Programmier-PC?
    Ist das WinCCflexible-Projekt integriert in das Step7-Projekt? Wenn ja, welche Step7-Version?

    Das WinCCflexible-Projekt muß mit 0 Fehler übersetzt werden! Vorher macht ein Laden ins Panel gar keinen Sinn. Ich wußte gar nicht, daß das überhaupt geht - vielleicht wird aber auch das letzte fehlerfreie Compilat ins Panel transferiert? Da gab es Dein neues EA-Feld noch gar nicht und deshalb ist es auch nicht sichtbar?

    Ein Doppelklick auf die Fehlerzeile (in der Ausgabe) springt normalerweise zum fehlerverursachenden Objekt. Dort Fehler beseitigen oder das Objekt löschen.

    Lösche mal alle temporären Dateien: Extras > Temporäre Dateien löschen
    Projekt komplett neu compilieren: Projekt > Generator > Alles neu generieren...
    Gelingt das Generieren nun ohne Fehlermeldung?
    Wenn nicht, dann das Projekt nochmal komplett neu anlegen.

    Ein EA-Feld per Drag/Drop erzeugen:
    - ein Bild öffnen (in den Editorbereich)
    - im Projektbaum den Variablen-Ordner markieren
    - links unten das Fenster "Objekte" öffnen
    - die gewünschte Variable markieren und in das Bild-Editorfenster ziehen

    Ist Dein EA-Feld sichtbar, wenn Du statt auf das OB177B zu transferieren gleich die Simulation startest?
    Projekt > Generator > Runtime starten

    Tip: Wenn in dem WinCCflex-Projekt die Verbindung zur CPU per Ethernet angelegt ist, dann kann sich die Runtime/Simulation mit der echten CPU verbinden und echte Werte beobachten/steuern.

    AWL-Programm als Gleitpunktzahl beobachten:
    - nach dem Einschalten der Brille rechts-Mausklick in die Statusspalte "STANDARD" > Darstellung > Gleitpunkt
    oder über "Zielsystem > Variable beobachten/steuern" Deine Variable in einer Variablentabelle beobachten

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet
    Zitieren Zitieren Wo anfangen?  

  6. #6
    DavidS ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    14.03.2013
    Beiträge
    3
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    also das WinCC flex is mit Step7 integriert.
    der PC läuft mit XP und Step7 advanced is drauf

    Ja stimmt dass des WinCCflex Projekt null Fehler haben muss aber in der letzten Zeile nach dem Generator wird doch nochmals zusammengefasst wie viele Warnungen und Fehler es gibt. Da stehen auch keine Fehler nur die eine Warnung.

    Das Projekt hab ich neu angelegt, gleicher Effekt...
    Doppelklick auf den Fehler bzw Warnung funktioniert nicht.

  7. #7
    Registriert seit
    09.08.2006
    Beiträge
    3.627
    Danke
    912
    Erhielt 656 Danke für 542 Beiträge

    Standard

    Zitat Zitat von PN/DP Beitrag anzeigen
    Welche Version von WinCC flexible benutzt Du? Welche Windows-Version hat Dein Programmier-PC?
    Ist das WinCCflexible-Projekt integriert in das Step7-Projekt? Wenn ja, welche Step7-Version?
    Zitat Zitat von DavidS Beitrag anzeigen
    also das WinCC flex is mit Step7 integriert.
    der PC läuft mit XP und Step7 advanced is drauf
    Ich glaube nicht, dass Deine Antwort PN/DP befriedigen wird...

    Geh noch mal in Dich, und versuch's nochmal...

  8. #8
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.184
    Danke
    923
    Erhielt 3.290 Danke für 2.659 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hmm, "Step7 advanced" - da kann ich Dir wohl nicht helfen, das kenn' ich nicht.
    Und ich hoffe, Du hast nicht WinCC flexible 2004 ...

    Ich habe aber mal fix ein neues Projekt mit Step7 V5.4 SP5 und WinCC flexible 2008 SP2 Upd1 nach Deinen spärlichen Angaben für OP177B 6" color PN/DP zusammengeklickt. Funktioniert dieses Projekt bei Dir ohne Fehler?

    Harald
    Angehängte Dateien Angehängte Dateien
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

Ähnliche Themen

  1. Kontinuierliche Speicherung von Messwerten
    Von ronin2503 im Forum CODESYS und IEC61131
    Antworten: 4
    Letzter Beitrag: 24.09.2008, 22:02
  2. Mehrfachnutzung von analogen Signalen
    Von Johannes F im Forum Elektronik
    Antworten: 16
    Letzter Beitrag: 03.02.2008, 09:11
  3. Messbereich von analogen eingängen
    Von SPS beginner im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 04.01.2008, 11:13
  4. Selektion von Messwerten
    Von dimo_77 im Forum Programmierstrategien
    Antworten: 3
    Letzter Beitrag: 15.11.2006, 07:33
  5. Invertieren von Analogen Eingängen
    Von bayernskipper im Forum PC- und Netzwerktechnik
    Antworten: 3
    Letzter Beitrag: 05.11.2006, 18:00

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •