Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 3 ErsteErste 123 LetzteLetzte
Ergebnis 11 bis 20 von 21

Thema: [WinCC flexbile] Meldearchive - Zeit

  1. #11
    Registriert seit
    27.03.2012
    Beiträge
    56
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo faust,

    viele Fragezeichen helfen mir leider auch nicht, deine Frage zu verstehen.

    Meine "Umrechnung" ist schon richtig. Die Vorschläge aus dem Tia Portal kann man sich getrost sparen.
    Wenn Du den Zeitstempel den Du aus dem Archiv enthältst in Excel kopierst und diese Zelle wie folgt formatierst (oben war ein Fehler):
    Code:
    TT.MM.JJJJ hh:mm:ss,000
    zeigt mir Excel z.B. für den Wert aus der Anleitung
    Code:
    37986,476928
    folgendes an:

    Code:
    31.12.2003 11:26:46,579
    Das entspricht ziemlich genau dem, was im TIA Portal gezeigt wird. In den Meldearchiven wird wohl generell keine Information über die Millisekunden eingetragen.

  2. #12
    Registriert seit
    17.10.2007
    Beiträge
    263
    Danke
    5
    Erhielt 52 Danke für 48 Beiträge

    Standard

    Und was beinhaltet deiner Meinung nach der Teil ',579' in dem Zeitstempel '31.12.2003 11:26:46,579>' ?

    Gruß, Fred

  3. #13
    Registriert seit
    27.03.2012
    Beiträge
    56
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Ich bin mir ziemlich sicher, dass wir aneinander vorbeischreiben. Die Umrechnung habe ich zu keinem Zeitpunkt bemängelt!

    Es wird in den Meldearchiven (bei mir im RDB-Format) keine Information über die Millisekunden eingetragen. Das heißt bei mir ist der Part mit ',XXX' immer ',000'.

  4. #14
    Registriert seit
    17.10.2007
    Beiträge
    263
    Danke
    5
    Erhielt 52 Danke für 48 Beiträge

    Standard

    Kannst du zur Verdeutlichung mal einen kompletten Datensatz einer Meldung posten?

    Ich kann mir nämlich nicht wirklich vorstellen, dass WinCC einen anderen Zeitstempel erzeugt nur weil sich das Dateiformat unterscheidet.


    Gruß, Fred

  5. #15
    Registriert seit
    27.03.2012
    Beiträge
    56
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Code:
    41408,7153935185	↗, ↘	Fault	2600
    41408,7131481482	↗	Fault	2600
    41408,7122800926	↗, ↘	Fault	2600
    41408,7122106482	↗	Fault	2600
    41408,7120833333	↗, ↘	Fault	2600
    41408,7120601852	↗	Fault	2600
    41408,7120138889	↗, ↘	Fault	2600
    41408,7119907407	↗	Fault	2600
    41408,7115509259	↗, ↘	Op	4104
    41408,7115509259	↗, ↘	Op	4105
    41408,7109375000	↗	Op	4201
    41408,7109375000	↗	Op	4221
    41408,7058912037	↗	ATO	5011
    41408,7058912037	↗	ATO	5012
    41408,7058912037	↗	ATO	5000
    41408,7058912037	↗	ATO	5003
    41408,7058912037	↗	ATO	5006
    41408,7058912037	↗	ATO	5017
    41408,7058912037	↗	ATO	5125
    41408,7058912037	↗	ATO	5116
    41408,7058912037	↗	System	140000
    41408,7058912037	↗	Fault	1200
    41408,7058912037	↗	Fault	1201
    41408,7058912037	↗	Fault	1206
    41408,7058912037	↗	Fault	1300
    41408,7058912037	↗	Fault	1301
    41408,7058912037	↗	Fault	1507
    41408,7058912037	↗	Fault	2601
    Klar, kein Problem!

  6. #16
    Registriert seit
    17.10.2007
    Beiträge
    263
    Danke
    5
    Erhielt 52 Danke für 48 Beiträge

    Standard

    Also....

    Ich bekomme für die Datensätze folgende (per Hand) umgerechnete Zeitstempel heraus:

    '14.05.2013 17:10:9,999'
    '14.05.2013 17:06:56,000'
    '14.05.3013 17:05:41,000'
    '14.05.3013 17:05:35,000'
    .
    .
    '14.05.3013 16:56:28,999'

    Wobei die Umrechnung niemals ganz glatt auf ',000' aufgeht, siehe auch den ersten und letzten Datensatz.


    Mein Fazit:
    Mit der Info von Harald einige Posts zuvor sieht es bei dir danach aus, als wenn die Meldungen von WinCC im Sekundenabstand 'detektiert' (also erhalten) werden.


    Gruß, Fred

  7. #17
    Registriert seit
    27.03.2012
    Beiträge
    56
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Danke, dass bestätigt dann nochmal meine Annahme aus dem ersten Post.

    Ich habe gerade versucht, in den Meldetext direkt die Zeit zu schreiben. Das klappt natürlich auch, allerdings ist der niedrigst mögliche Erfassungzyklus bei mir 100ms. Und das entspricht dann mehr als 10 Zyklen der SPS - von daher sind weitere Versuch überflüssig...

  8. #18
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.316
    Danke
    932
    Erhielt 3.331 Danke für 2.689 Beiträge

    Standard

    Hast Du das mit dem Erfassungszyklus auf 100ms auch mal ausprobiert? Sind dann die ms im Archiv-Zeitstempel ungleich 0?

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  9. #19
    Registriert seit
    27.03.2012
    Beiträge
    56
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Ich habe es probiert, der Zeitstempel bleibt leider = 0. Es wäre interessant, wenn das jemand bestätigen bzw. widerlegen könnte.

  10. #20
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.316
    Danke
    932
    Erhielt 3.331 Danke für 2.689 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ich habe einige Meldearchive von einem MP370 im CSV-Format von WinCC flexible 2008 SP2.
    Die ms sind definitiv krumme Werte ungleich ,000

    Mit RDB-Format kann ich im Moment leider nicht dienen.

    Wie kommst Du überhaupt zu den Datensätzen in #15? Warum sind die in absteigender Reihenfolge (sollten eigentlich aufsteigende Reihenfolge sein)? Warum sind die Werte so klein - also schon durch 1.000.000 dividiert? Kann es sein, daß Du womöglich bei irgendeinem Umrechnen oder Kopieren die Millisekunden abschneidest (vielleicht wird ein Dezimalkomma als Separator interpretiert oder auf eine bestimmte Anzahl Nachkommastellen gerundet)?

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

Ähnliche Themen

  1. Antworten: 0
    Letzter Beitrag: 19.12.2011, 17:42
  2. WinCC flex Zeit in DB
    Von torstenh im Forum Simatic
    Antworten: 9
    Letzter Beitrag: 18.02.2009, 15:05
  3. Meldearchive MP270 / MP277
    Von Astralavista im Forum HMI
    Antworten: 3
    Letzter Beitrag: 18.12.2008, 09:49
  4. Antworten: 11
    Letzter Beitrag: 16.09.2008, 09:02
  5. Antworten: 3
    Letzter Beitrag: 08.10.2007, 09:35

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •