Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 2 ErsteErste 12
Ergebnis 11 bis 15 von 15

Thema: WinCCflex 2008 SP3 ######################## in E/A_Felder

  1. #11
    Registriert seit
    04.03.2010
    Beiträge
    44
    Danke
    7
    Erhielt 5 Danke für 5 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Mach doch mal bitte folgendes lade dein Programm in PLCSIM, CPU aber nicht starten, aktuelle Werte werden ja trotzdem angezeigt Verbindung zur SPS haste dann ja auch. CPU ist aber gestoppt.
    Danach machste den Test mit dem Generieren nochmal wenn dann Dein Fehler immer noch auftritt scheints wirklich eher an Flexible zu liegen.
    Gruß Didaddy

    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    > Erlaubt ist was funktioniert, wenn man alles perfekt machen will wird man nie fertig. <

  2. #12
    Avatar von Sinix
    Sinix ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    25.11.2008
    Ort
    Westpfalz
    Beiträge
    1.550
    Danke
    187
    Erhielt 212 Danke für 186 Beiträge

    Standard

    Zitat Zitat von ducati Beitrag anzeigen
    vielleicht spasseshalber mal ne PC-Runtime projektieren, und schaun obs damit geht, bzw. nen anderes Panel...
    das habe ich probiert und siehe da:
    Simulation mit KTP1000 alternativ TP1500 Fehler
    Simulation mit MP277 / MP377 / Mobile Panel kein Fehler

    und nun muss ich wohl doch mit der richtigen Hardware testen
    and we all support the team (S.King - Die Arena)

  3. #13
    Avatar von Sinix
    Sinix ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    25.11.2008
    Ort
    Westpfalz
    Beiträge
    1.550
    Danke
    187
    Erhielt 212 Danke für 186 Beiträge

    Standard

    Um hier nun ein Feedback zu geben:

    Das KTP1000 kann ich überhaupt nicht empfehlen.
    Hatte schon öfter KTP400 / 600 und dabei viel weniger Stress.

    Zur Problematik dieses Threads: Big S konnte mir nicht weiterhelfen, nachdem ich widerwillig auch das letzte Hotfix installiert habe war
    deren letzte Aussage, dass es an der Verwendung des udt im S7-Prog liegt und ich mein Programm ändern müsste.
    Der sonst so gewissenhafte Support hat scheinbar was zu sich genommen, wenn ich doch ganz klar mit nem MP277 das Ganze gebacken bekomme, kann es unmöglich am S7-Projekt liegen.
    Ich machte mir die Mühe S7 und Panel jungfräulich zu projektieren, den Antivir auszuschalten und nach jeden neuen Schritt beides zu speichern, übersetzen und testen. Dieser Fehler trat bis dato nie wieder auf.
    Mit dem KTP hatte ich in der Folge das Problem das die 22 Stringvariablen a 40 Zeichen, trotz Einhaltung der max. erlaubten Tags und Bitmeldungen bei zyklisch fortlaufender Erfassung zu Fehler "50000 Überlast: Datentausch mit Steuerung unterbrochen" führten. Abhilfe konnte ich durch Erfassung bei Verwendung schaffen, allerdings wurden die E/A-Felder dann nicht immer (scheinbar nach belieben) bei Wertänderung aktualisiert. Wiederum Abhilfe: bei Wertänderung, die nur auf dieser Bildschirmseite stattfindet (Tasten löschen/einfügen), das Bild selbst nochmal aufrufen.
    Abgesehen davon wurden Animationen Gestaltung/Sichtbarkeit trotz löschen Temporärer Dateien und ordnungsgemäßer Projektierung nicht immer richtig ausgeführt. Bin mir nicht sicher ob es durch kopieren von Bildobjekten auftritt. Abhilfe war nur durch löschen und neu projektieren der Bildobjekte möglich.

    Alles in allem war meine Arbeitszeit teurer, als die Mehrkosten für ein MP und
    ich kann von dem KTP1000 nur abraten.

    VG Mäuseklavier
    and we all support the team (S.King - Die Arena)

  4. #14
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.166
    Danke
    921
    Erhielt 3.286 Danke für 2.655 Beiträge

    Standard

    Zitat Zitat von Mäuseklavier Beitrag anzeigen
    Fehler "50000 Überlast: Datentausch mit Steuerung unterbrochen"
    Kann es sein, daß Deine Strings in der CPU in einem ARRAY OF STRING oder gar ARRAY OF STRUCT liegen und Du im HMI Tag-sparend das ganze Array als eine einzige Variable angelegt hast?
    In dem Falle wäre das Verhalten des KTP zwar nicht schön, aber normal.

    Dann erzeugt jeder Zugriff auf ein Array-Element ein Lesen bzw. Schreiben des kompletten Arrays und in Folge die Kommunikations-Überlast. Die Überlast-Meldung siehst Du aber nur, wenn Du ein Meldefenster oder eine Meldeanzeige für die Meldeklasse System projektiert hast. Die wegen dem Überlast-Kommunikationsabbruch nicht mehr aktualisierten Array-Member werden dann natürlich mit ############ angezeigt.

    Lösung: jeden String als separate Variable (Tag) im HMI anlegen.

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  5. #15
    Avatar von Sinix
    Sinix ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    25.11.2008
    Ort
    Westpfalz
    Beiträge
    1.550
    Danke
    187
    Erhielt 212 Danke für 186 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Harald,

    danke für deinen Hinweis

    Zitat Zitat von PN/DP Beitrag anzeigen
    Kann es sein, daß Deine Strings in der CPU in einem ARRAY OF STRING oder gar ARRAY OF STRUCT liegen und Du im HMI Tag-sparend das ganze Array als eine einzige Variable angelegt hast?
    In dem Falle wäre das Verhalten des KTP zwar nicht schön, aber normal.
    Ist nicht der Fall.
    Auf S7-Seite gibt es ein udt, der an Adresse 400 einen String[40] hat, kein array oder struct.
    Der udt wird in 20 verschiedenen DB verwendet.
    Somit habe ich 20 String[40] in 20 verschiedenen DB.

    Zitat Zitat von PN/DP Beitrag anzeigen
    Lösung: jeden String als separate Variable (Tag) im HMI anlegen.
    Genau so habe ich es gemacht:
    Diese 20 String[40] sind im HMI einzeln projektiert mit Array Element 1 / Zeichenlänge 40.

    Die System-Meldung mit Überlast bin ich eher froh, damit ich hier einen Anhaltspunkt habe warum etwas nicht oder falsch angezeigt wird.
    Deshalb projektiere ich die in mindestens einem Meldefenster mit.

    Gruß MK
    and we all support the team (S.King - Die Arena)

Ähnliche Themen

  1. Antworten: 0
    Letzter Beitrag: 23.05.2013, 08:26
  2. Antworten: 4
    Letzter Beitrag: 21.05.2013, 16:04
  3. WinCCflex 2008 SP3 "Drücken" auswerten
    Von Matze001 im Forum HMI
    Antworten: 5
    Letzter Beitrag: 29.08.2012, 12:29
  4. Antworten: 9
    Letzter Beitrag: 03.07.2012, 17:23
  5. WinCCflex 2008 auf WinServer 2008 R2
    Von steinche im Forum HMI
    Antworten: 0
    Letzter Beitrag: 17.02.2010, 09:06

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •