Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 4 von 4

Thema: Umrichter Konfiguration von Touchpanel via Modbus-RTU

  1. #1
    Registriert seit
    20.02.2005
    Beiträge
    246
    Danke
    3
    Erhielt 3 Danke für 3 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen,

    ich versuche gerade einen Controltechniques Comander SK und später einen Unidrive SP über RS485 mit Modbus-RTU Protokoll von einem Touch-Panel zu parametrieren.
    Bei dem Panel handelt es sich um ein Wachendorff (Weintek) WBGSE070.
    Leider habe ich absolut keine Ahnung bei Modbus.
    Ich habe bisher nur was von Registern usw. gehört.

    Als Ziel ist es die wichtigen Motorparameter ähnlich einem Typenschild über das HMI einzustellen und dann einige Messwerte wie Motorstrom und Spannung, Leistung Drehzahl und den Wert eines anlogen Umrichtereingang auf dem HMI anzuzeigen (Prüfstand).

    Hat von euch schon mal einer so etwas gemacht?

    Ich bekommen immer nur ein "PLC no response" auf dem Panel angezeigt.
    Zitieren Zitieren Umrichter Konfiguration von Touchpanel via Modbus-RTU  

  2. #2
    Registriert seit
    03.01.2013
    Beiträge
    96
    Danke
    4
    Erhielt 4 Danke für 4 Beiträge

    Standard

    Hi !

    Als erstes musst Du eine Doku von Deinem Umrichter haben, da jeder Hersteller die Belegung der Modbus-Register selbst festlegt. In dieser Doku findest Du die Modbus-Adresse und die unterstützen Modbus Funktionscodes. Damit weisst Du, wie Du an Deine benötigten Daten heran kommst.

    Dann kannst Du das Panel parametrieren. Modbus RTU-Treiber in der Geräteliste der Systemparameter einfügen und Schnittstellenparameter richtig angeben. Bei RS485 2-Draht musst Du einfach die Leitungen mal umdrehen wenn es nicht funktioniert. Das macht jeder Hersteller anders.
    Dann am Besten erst mal nur eine Variable in das Projekt rein nehmen. Am einfachsten mit Funktionscode 3x die Adresse 1 auslesen (z.B. 30001) und schauen, ob ein Datum zurück kommt? Wenn das funktioniert ist die Kommunikation O.K. und kann "aufgebohrt" werden.

    Gruß
    HMIman

  3. #3
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.166
    Danke
    921
    Erhielt 3.286 Danke für 2.655 Beiträge

    Standard

    Zitat Zitat von buffi4711 Beitrag anzeigen
    Ich bekommen immer nur ein "PLC no response" auf dem Panel angezeigt.
    Das hat erstmal nichts mit dem Umrichter zu tun, sondern Dein HMI-Panel kann nicht mit der SPS kommunizieren.
    Überprüfe, ob Du die Verbindung des Panel zur SPS richtig projektiert hast und die Kabel und ggf. Netzwerk/Routing richtig funktionieren.
    Vielleicht verrätst Du uns auch mal, mit welcher Software Du die Bilder für das Panel erstellst.

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  4. #4
    buffi4711 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    20.02.2005
    Beiträge
    246
    Danke
    3
    Erhielt 3 Danke für 3 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Also,

    es geht recht einfach, wenn mann erst mal Verstanden hatt, wie die Parmeteradresse auf de Modbus Register umzusetzen sind.
    Wenn dann auch noch das Verbindungskabel richtig ist geht alles fast von Geisterhand.
    Hardware:
    Controltechniques Commander SK und Unidrive SP
    Wachendorf Dispaly Bediengerät WBGSE070
    Software:
    EasyBuilder

Ähnliche Themen

  1. Antworten: 2
    Letzter Beitrag: 21.10.2012, 09:52
  2. Modbus RTU
    Von Rauchegger im Forum Feldbusse
    Antworten: 15
    Letzter Beitrag: 23.11.2010, 21:11
  3. modbus rtu
    Von di_sch im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 25.05.2010, 17:30
  4. Modbus RTU Seriell
    Von emsbootsmann im Forum Hochsprachen - OPC
    Antworten: 2
    Letzter Beitrag: 06.03.2010, 11:59
  5. Wandeln von IEEE 754 Zahlen bei der Modbus-RTU Biliothek
    Von WaEv im Forum CODESYS und IEC61131
    Antworten: 0
    Letzter Beitrag: 14.01.2010, 19:26

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •