Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 6 von 6

Thema: MP177B WinCC flex, Wertübernahme in Steuerung nicht möglich

  1. #1
    Registriert seit
    18.03.2013
    Beiträge
    43
    Danke
    2
    Erhielt 3 Danke für 3 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    folgende Konfiguration:
    -1xCPU317-2PN/DP
    -2xMP177B am Profibus, Akkugepuffert, mit 4 Anschlussboxen
    -28 weitere Slaves am Profibus
    -Profibuslänge <60m
    -Projektiert und Programmiert mit Step7 5.4+SP5
    -1 Panel-PC mit WinCC flex 2008 SP3 Runtime über Ethernet angebunden

    in der CPU eingestellt:
    -Profibusprofil: DP, 1,5MBit/s, höchste Adresse 126
    -Zyklusbelastung durch Kommunikation: 20% (voreingestellt)
    -bei Busparameter steht: Ttr:64,3ms Ttr typisch: 17,7ms
    -Zykluszeit der CPU: 14ms im Schnitt

    folgendes Problem:
    am Anfang der Inbetriebnahme funktionierten die Panel einwandfrei.
    Nachdem noch einige DP-Slaves dazukamen, gibt es ab und zu ein Problem beim anstecken der Panel.
    Es erscheint die Meldung: "TasteXX: Wertübernahme in Steuerung nicht möglich". Meistens gibt sich das Problem nach einigen Sekunden, manchmal muss man das Panel aber neu sterten (Akku raus und neu anstecken)
    Kann mir jemand sagen, woran das liegt und ob es einen Parameter im HW-Konfig gibt, mit dem man optimieren könte.

    Danke im voraus, urlaub
    Zitieren Zitieren MP177B WinCC flex, Wertübernahme in Steuerung nicht möglich  

  2. #2
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.192
    Danke
    925
    Erhielt 3.292 Danke für 2.661 Beiträge

    Standard

    Sind alle Panels in NetPro mit dem Profibus vernetzt?
    Wenn die Panels in einem anderen Projekt projektiert werden dann Dummy/Stellvertreter-Panels in NetPro vernetzen oder in den Profibus-Netzeinstellungen die Anzahl aktiver Teilnehmer um 2 erhöhen.
    Das Profibus-Profil muß "Standard" oder "Benutzerdefiniert" sein.

    Sind RS485-Repeater am Bus vorhanden?
    28 Slave + 1 CPU + 2 Panels + ggf. ein PG ist zu viel für ein Profibus-Segment

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  3. #3
    Registriert seit
    25.11.2008
    Ort
    Westpfalz
    Beiträge
    1.550
    Danke
    187
    Erhielt 212 Danke für 186 Beiträge

    Standard

    Zitat Zitat von urlaub Beitrag anzeigen
    Nachdem noch einige DP-Slaves dazukamen, gibt es ab und zu ein Problem beim anstecken der Panel.
    Haben die Panel unterschiedliche DP-Adressen und die Anschlussboxen unterschiedliche ID's?
    Kann an beiden Panel eine gleiche Funktion gleichzeitig ausgeöst werden?

    MfG Sinix
    and we all support the team (S.King - Die Arena)

  4. #4
    urlaub ist offline Benutzer
    Themenstarter
    Registriert seit
    18.03.2013
    Beiträge
    43
    Danke
    2
    Erhielt 3 Danke für 3 Beiträge

    Standard

    Danke für die schnelle Reaktion
    -hab nochmal nachgezählt, es sind 26 Slaves inklusive Panels, Entschuldigung
    -die Panel sind im NetPro projektiert und im HW-Konfig wegen Direkttasten
    -keine Repeater im Profibus. Könnte das was bringen
    -Profibusadressen sind unterschiedlich, Box-IDs sind unterschiedlich
    -Eingabewerte an den Panels sind über Multiplexvariablen realisiert, beide Panel nutzen unterschiedliche Multiplex-DB, also nicht dieselben Funktionen

    @Harald: Dass das Profil Standard oder Benutzerdefiniert sein muss, wusste ich nicht. Warum ist das so. Wir haben bis jetzt immer "DP" genommen, weils voreingestellt ist und es hat funktioniert. Ich würde gern mehr darüber erfahren, was es mit dem Profil auf sich hat.

    Kann es ein Problem sein, wenn die Buszykluszeit grösser als die Zykluszeit im OB1 ist?

  5. #5
    urlaub ist offline Benutzer
    Themenstarter
    Registriert seit
    18.03.2013
    Beiträge
    43
    Danke
    2
    Erhielt 3 Danke für 3 Beiträge

    Standard

    Danke für die schnelle Reaktion
    -hab nochmal nachgezählt, es sind 26 Slaves inklusive Panels, Entschuldigung
    -die Panel sind im NetPro projektiert und im HW-Konfig wegen Direkttasten
    -keine Repeater im Profibus. Könnte das was bringen
    -Profibusadressen sind unterschiedlich, Box-IDs sind unterschiedlich
    -Eingabewerte an den Panels sind über Multiplexvariablen realisiert, beide Panel nutzen unterschiedliche Multiplex-DB, also nicht dieselben Funktion
    @Harald: Dass das Profil Standard oder Benutzerdefiniert sein muss, wusste ich nicht. warum ist das so. Wir haben bis jetzt immer "DP" genommen, weils voreingestellt ist und es hat funktioniert. Kann mir jemand sagen, was es mit dem Profil auf sich hat.

  6. #6
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.192
    Danke
    925
    Erhielt 3.292 Danke für 2.661 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Wenn wirklich alle Panels in NetPro vernetzt sind, dann berechnet NetPro die Netztimings richtig. Auch im Profil "DP". Wenn real mehr Panels vorhanden sind als NetPro bekannt sind, dann wird eine zu geringe Target-Rotation-Time (Ttr) festgelegt und dadurch bekommen die Panels nicht genug Kommunikationszeit. Dann muß man in NetPro die Anzahl aktiver Teilnehmer am Profibus manuell einstellen - und das geht nur bei den Profils "Standard" und "Benutzerdefiniert" (und bei "universell").

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

Ähnliche Themen

  1. Antworten: 1
    Letzter Beitrag: 03.12.2010, 09:53
  2. Antworten: 5
    Letzter Beitrag: 10.12.2009, 18:09
  3. Öffnen aus Steuerung bei Lenovo R61 Laptop nicht möglich
    Von karlheinzsps im Forum CODESYS und IEC61131
    Antworten: 1
    Letzter Beitrag: 30.03.2009, 10:41
  4. ProTool-Simatic-Wertübernahme in Steuerung
    Von googy im Forum Simatic
    Antworten: 41
    Letzter Beitrag: 01.11.2008, 18:00
  5. keine Scripterstellung in WinCC flex. möglich
    Von electroniconepack im Forum HMI
    Antworten: 2
    Letzter Beitrag: 23.01.2008, 14:30

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •