Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 9 von 9

Thema: Migration von Protool nach WinCC Flex - Variablen werden zerschossen - FM-Baugruppe

  1. #1
    Registriert seit
    11.02.2007
    Beiträge
    90
    Danke
    32
    Erhielt 7 Danke für 7 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,
    nach langer Zeit hab ich mal wieder ne Frage.

    Bei uns dauert es ja meist etwas länger aber jetzt ist es doch soweit - unsere Protoll-Panels werden auf WinCC flexible 2008 - SP 3 umgestellt (Step7 hat die Version V5.5).
    Bei den meisten Projekten gab es auch keine Probleme - WinCC Flex aufgemacht, das entsprechende Protool-Projekt damit geöffnet und auf "migrieren" gegangen und alles war schön und gut.

    Bei einer Steuerung klappt das aber nicht so

    Bei einer Steuerung befindet sich in der Anlage eine FM-Baugruppe mit entsprechenden Servo´s.

    Für diese Baugruppe sind diverse Variablen in dem Panel hinterlegt und bei Protool sind die alle als "String" oder "Double" deklariert mit Adresszuweisung
    (siehe Bild/ Anhang: Protool.jpg)

    Nach der Migration in WinCC Flex sind daraus alles "Int" geworden und die Adresszuweisung ist auch weg.
    (siehe Bild/ Anhang: WinCCFlex.jpg)

    So und da bin ich mit meiner "Weisheit" am Ende. Was muss ich denn machen damit das mit den migrieren richtig klappt.

    Der eine oder andere wird doch sicher schon mal vor demselben Problem gestanden haben
    und ich würde mich über Tips und Hilfe freuen...


    Mfg
    elektromensch
    Angehängte Grafiken Angehängte Grafiken
    Zitieren Zitieren Migration von Protool nach WinCC Flex - Variablen werden zerschossen - FM-Baugruppe  

  2. Folgender Benutzer sagt Danke zu elektro_mensch für den nützlichen Beitrag:

    yremyremy (22.04.2014)

  3. #2
    Registriert seit
    03.04.2008
    Beiträge
    6.200
    Danke
    237
    Erhielt 815 Danke für 689 Beiträge

    Standard

    War es nicht so, dass nur bis SP2 ein Portieren richtig funktioniert?
    Wenn möglich versuche es mit WinCC flex 2008 SP2.
    Wenn das dann fertig ist, kannst du es nach SP3 übernehmen.


    bike
    "Any fool can write code that a computer can understand.
    Good programmers write code that humans can understand."
    --Martin Fowler

  4. Folgender Benutzer sagt Danke zu bike für den nützlichen Beitrag:

    yremyremy (22.04.2014)

  5. #3
    Registriert seit
    11.02.2007
    Beiträge
    90
    Danke
    32
    Erhielt 7 Danke für 7 Beiträge

    Standard

    Hallo - ich hab heute nochmal geschaut.
    Das was ich gestern geschrieben habe war falsch.
    Das kommt davon wenn mal schnell was machen möchte.

    Wir haben aktuell die Software Step7 V5.4 + SP5 + HF8 und WinCC flex 2008 SP2
    Damit hab ich auch die Migration gemacht.

    Danach (!) soll das Projekt dann unter Step7 V5.5 und Flex2008 SP3 laufen.

    Also bei der Migration unter Flexible 2008 SP2 kommt das Ergebnis mit den zerschossene Variablen (siehe Anhang - 1 Beitrag)
    Ich schicke heute noch mal ne PDF mit - mit dem Fehlerprotokol beim Migrationsprozeß
    Mfg
    elekrtromensch
    Angehängte Dateien Angehängte Dateien
    Zitieren Zitieren Step7 V5.4 und Wincc flex 2008 Sp2  

  6. Folgender Benutzer sagt Danke zu elektro_mensch für den nützlichen Beitrag:

    yremyremy (22.04.2014)

  7. #4
    Registriert seit
    29.03.2004
    Beiträge
    5.735
    Danke
    143
    Erhielt 1.685 Danke für 1.225 Beiträge

    Standard

    Also wenn ich mir diesen FAQ so durchlese:
    http://support.automation.siemens.co...ew/de/61527641

    brauchst du für die FM-Baugruppen unter WinCC flexible das Optionspaket "SINUMERIK HMI Projektierpaket WinCC flexible".
    Wenn du als Kommunikationstreiber S7300/400 einstellst, gibt es nämlich keine Möglichkeit den Datentyp Double (doppelte Genauigkeit) anzugeben. Der Datentyp Real ist bei einer S7 immer nur 4 Bytes groß, was dem Datentyp float (einfache Genauigkeit) entspricht.

  8. Folgender Benutzer sagt Danke zu Thomas_v2.1 für den nützlichen Beitrag:

    yremyremy (22.04.2014)

  9. #5
    Registriert seit
    10.07.2013
    Beiträge
    215
    Danke
    6
    Erhielt 46 Danke für 34 Beiträge

    Standard

    Thomas_v2.1 hat vollkomme recht das läuft so nicht mehr du brauchst auf jeden fall die Sinumerik Erweiterung.
    Geht nicht gibt's nicht

  10. Folgender Benutzer sagt Danke zu Wetzelaer für den nützlichen Beitrag:

    yremyremy (22.04.2014)

  11. #6
    Registriert seit
    11.02.2007
    Beiträge
    90
    Danke
    32
    Erhielt 7 Danke für 7 Beiträge

    Standard

    Hallo, vielen Dank für die Antworten....

    Ich hab heute mal geschaut und das kann gut sein. Jetzt hab ich versucht die Software bei Siemens runterzuladen aber ich finde da keinen Downloadlink.
    Bin ich zu dumm den zu finden oder muss ich das für Geld bstellen ?

    oder ist das evtl. in irgendwelchen anderen Paketen mit integriert ?

    Vielen Dank
    mfg
    elektromensch
    Zitieren Zitieren ich finde das Paket nicht  

  12. #7
    Registriert seit
    29.03.2004
    Beiträge
    5.735
    Danke
    143
    Erhielt 1.685 Danke für 1.225 Beiträge

    Standard

    Guck mal in der Siemens Mall, das Paket wirst du kaufen müssen.

  13. #8
    Registriert seit
    11.02.2007
    Beiträge
    90
    Danke
    32
    Erhielt 7 Danke für 7 Beiträge

    Standard

    Okay - ich hab es befürchtet.

    Dann werd ich das mal freundlich bei meinen Chef anfragen

    Kann ein bischen dauern. Wenn das Paket da ist versuche ich es nochmal und werde berichten -

    Bis hierher erstmal vielen Dank für eure Hilfe.

    mfg
    elektromensch

  14. #9
    Registriert seit
    11.02.2007
    Beiträge
    90
    Danke
    32
    Erhielt 7 Danke für 7 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo…
    So nur ein knappes Jahr später und schon geht esweiter
    Die "Sinumerik Erweiterung" wurde nun gekauft und ist installiert.Ich hab die Migration nochmal durchgeführt und siehe da die meisten Variablenwurden ohne zu meckern angelegt. Aber leider nicht alle. Da ich von denFM-Baugruppe keine Ahnung habe würd ich mich freuen wenn mir hier jemand helfenkönnte.

    Ich hab drei Maschine bei den ich das machen muss. Ich fang mal mit der erstenan.

    Nach der Migration hab ich in WinCC-Flex eine Generierung durchgeführt die miteinem Fehler abgebrochen wurde (Bild1)
    In der Variablenliste ist keine Adresse zugewiesen worden (Bild2)
    In der Protoolversion sah das so aus (Bild 3)

    So das hab ich jetzt über das Auswahlmenü angepasst da sieht das fast genausoaus - es steht nur eine zusätzliche 1 dabei für einen"Bereichszeiger" - (Bild4)
    Ich glaube das das richtig ist - aber glauben heißt nicht wissen und wenn mirdas jemand bestätigen könnte wäre mir wohler.
    Danach hab ich die Generierung noch mal durchgeführt und der Fehler war weg(heisst ja auch nicht unbedingt das die Adresse so richtig ist).


    Die Generierung wurde wieder abgebrochen - mit dem Fehler "Interner Fehler- Detail LinkerNCKHandler: missing NCKmessage classes". (Bild 5)

    Ich könnte jetzt anfangen mir irgendwas zusammen zu dichten - aber wenn ichehrlich bin hab ich überhaupt keine Ahnung.
    Wenn mir irgendwer auf die Sprünge helfen könnte, würde ich mich sehr freuen.

    Mfg
    Elektromensch
    Angehängte Grafiken Angehängte Grafiken
    Zitieren Zitieren Migrtion mit Probleme  

Ähnliche Themen

  1. Antworten: 17
    Letzter Beitrag: 27.01.2014, 12:38
  2. Migration von ProTool in WinCC SP3
    Von kliebisch.m im Forum HMI
    Antworten: 8
    Letzter Beitrag: 09.08.2012, 17:09
  3. Antworten: 2
    Letzter Beitrag: 15.03.2012, 14:07
  4. Antworten: 0
    Letzter Beitrag: 05.10.2011, 08:12
  5. Dringend:Backup von Protool nach WINCC-Flex
    Von Outrider im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 04.10.2011, 23:26

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •