Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 3 von 3

Thema: Problem zwischen HMI-Visualisierung und Beckhoff Steuerungen

  1. #1
    Registriert seit
    31.07.2014
    Ort
    Niedersachsen
    Beiträge
    61
    Danke
    7
    Erhielt 2 Danke für 2 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo liebe Forenmitglieder,

    zurzeit habe ich drei verschiedene Rechner, in dem ersten Rechner ein Applikation für HMI-Visualisierung unter LabVIEW gelaufen wird. Die zwei anderen Rechner sind Beckhoff-Steuerung.

    Daten:

    HMI-Rechner mit Windows 7 Pro.
    1. Beckhoff-Steuerung mit Windows Embedded Standard XP (SP3)
    2. Beckhoff-Steuerung mit Windows Embebbed Standard 7


    Situationspunkt:

    wie normal bietet Beckhoff die Möglichkeit, den OPC-Server in der Steuerung zu laufen. Jetzt befinden sich OPC-Client und OPC-Server auf den verschiedenen Rechner. DCOM-Konfiguration für Server auf Steuerung und Client für HMI-Applikation wurden durchgeführt. Firewall sind abgeschaltet. Die drei Rechner liegen jetzt in einer Workgroup und Daten können von drei Rechnern freigegeben werden.

    Zusatz: TwinCat OPC Server wurden auf der beiden Steuerung installiert. Unter "DCOMcnfg" wurde OPC-Eigenschaften eingestellt. Ein kleines Steuerungprogramm für Tests wurde in der Steuerung angelegt.

    LabVIEW biete eine spezifische Möglichkeit, Daten über DataSocket zu kommunizieren. Ich kann jetzt vom HMI-Client die OPC-Server von beiden Steuerungen sehen. Quasi kann ich die Item-Liste in beiden OPC-Servern sehen und ein Item mit einem Bedien- oder Anzeigeelement anbinden.

    Das Problem ist es, dass ich nur Daten in OPC-Server von der Steuerung mit Win XP zugreifen konnte. Die Wertenänderungen wurden in der HMI-Visualisierung angezeigt.
    Die Anzeige, die mit einem Item in der OPC-Server von der Steuerung mit WES 7 angebunden wurde, wird nicht angezeigt. Ich weiß nicht warum es so nicht funktioniert.

    Frage:

    - Kann jemand von Euch abschätzen, wo das Problem liegt. (DCOM Konfiguration, Firewall oder OPC-Server). Was soll ich nochmals überprüfen, da ich hier komisch finde. Item-Liste in OPC Server sind sichtbar aber kann nicht zugregiffen werden.

    Vielen Dank

    Phuong
    Zitieren Zitieren Problem zwischen HMI-Visualisierung und Beckhoff Steuerungen  

  2. #2
    Registriert seit
    29.03.2004
    Beiträge
    5.741
    Danke
    143
    Erhielt 1.687 Danke für 1.226 Beiträge

    Standard

    Wenn das Browsen des OPC-Servers funktioniert, der Zugriff aber nicht, liegt es meiner Erfahrung nach an fehlenden Berechtigungen in der DCOM-Konfiguration. Firewall sollte passen, sonst würde das Browsen auch nicht funktionieren.
    Hast du von Beckhoff eine Anleitung wie die Zugriffsrechte einzustellen sind? Ansonsten kannst du auch entsprechende Anleitungen von anderen Anbietern (z.B. Siemens) zur Einrichtung von DCOM über Netzwerk verwenden, denn die Einstellungen sind bei allen OPC-DA-Servern identisch zu machen.

  3. #3
    Registriert seit
    31.07.2014
    Ort
    Niedersachsen
    Beiträge
    61
    Danke
    7
    Erhielt 2 Danke für 2 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Thomas,

    Danke Dir für deine Hinweise.

    Ich habe vielleicht 5 verschiedene Anleitungen von verschiedenen Anbietern gelesen. Was fand ich kommisch, dass die Einstellung für DCOM und OPC-Server von diesen Anbietern unterschiedlich sind.
    Außerdem fand ich die Anleitung von Beckhoff sehr unübersichtlich. Ich hatte keine Unterstützung von Support, da mein Problem bei Microsoft geklärt werden soll. Das finde ich wieder kommisch.

    Aber gestern Abend habe ich zum Glück durch einige Foren mein Problem entdeckt. Das Problem lag daran an, dass ein Dienst "Remote Registry" bei "Services.msc" in der Steuerung ausgeschaltet wurde.

    Soweit habe ich die Lösung hingekriegt. Es kommt ein kleines Problem, wenn ich die Remote Verbindung zur der Steuerung abgeschaltet habe, kann ich die Variablen von OPC-Server in der HMI-Visualisierung nicht mehr zugreifen. Ich muss die Steuerung neustarten und funktioniert wieder.

    Ich versuche heute das Problem weiter zu lösen.


    Viele Grüße,
    Phuong

Ähnliche Themen

  1. Antworten: 29
    Letzter Beitrag: 29.04.2015, 17:08
  2. Fragen zu atvise Web HMI und OPC Server an Beckhoff Steuerungen
    Von SteffenD im Forum CODESYS und IEC61131
    Antworten: 2
    Letzter Beitrag: 19.09.2013, 23:06
  3. Twincat 3.1 - Kommunikation zwischen einem C++ Modul und HMI (C#)
    Von adrian_weber im Forum CODESYS und IEC61131
    Antworten: 3
    Letzter Beitrag: 13.08.2013, 07:30
  4. ADS Kommunikation zwischen Beckhoff Steuerungen
    Von peraho im Forum CODESYS und IEC61131
    Antworten: 4
    Letzter Beitrag: 09.09.2009, 08:00
  5. Antworten: 6
    Letzter Beitrag: 29.01.2008, 13:34

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •