Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 8 von 8

Thema: Animation von Objekten in einem Bildbaustein

  1. #1
    Registriert seit
    05.11.2014
    Beiträge
    9
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo sps´ler

    ich bin gerade dabei einen Bildbaustein für Motoren zu erstellen, in dem ich die Zustände die ich vom FU bekomme (Bremse offen, Betriebsbereit, Reglerfreigabe,...) jeweils mit einem kleinen Rechteck (grün = 1, grau = 0) darstellen möchte. Nun finde ich aber keine Schnittstelle um die Rechtecke mit einer Animation/Gestaltung zu verbinden.
    Ich glaube momentan sehe ich einfach den Wald vor lauter Bäumen nicht und wäre deshalb über eine kurze Hilfe dankbar.


    Edit________________________
    Noch zu meiner Ausrüstung: TIA V13 SP1 Panel: TP 1500 Comfort

    Gruß
    Pi
    Zitieren Zitieren Animation von Objekten in einem Bildbaustein  

  2. #2
    Registriert seit
    17.09.2014
    Ort
    BW
    Beiträge
    217
    Danke
    18
    Erhielt 28 Danke für 26 Beiträge

    Standard

    Bei TIA bin ich mir nicht ganz sicher, ob es da auch so geht. Hab sowas mal mit WinCC (nicht Flexible) gemacht.
    Dort musste man ein neues Symbol daraus erstellen und dann konnte man eine Variable als Symbol Parameter erstellen ( z.B. Word).
    Und die einzelnen Bits wurden dann mit den zu Dynamisierenden Elementen Verknüpft.
    So musste man dann nur noch die Variable aus tauschen.
    Und Fertig war der Bildbaustein.
    Wenn ich es schaffe kann ich evtl. morgen mal schauen ob ich es im TIA nachbilden kann.

  3. #3
    Registriert seit
    05.11.2014
    Beiträge
    9
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Danke für die Antwort ich werde es heute auch noch einmal probieren weil irgendwie muss das ja gehen.

  4. #4
    Registriert seit
    17.09.2014
    Ort
    BW
    Beiträge
    217
    Danke
    18
    Erhielt 28 Danke für 26 Beiträge

    Standard

    Habs heute Leider nicht geschafft zu schauen. Wenn Fu noch bedarf hast kann ich das gerne noch vor dem WE machen.

  5. #5
    Registriert seit
    19.06.2008
    Ort
    Ostalbkreis
    Beiträge
    3.140
    Danke
    201
    Erhielt 553 Danke für 498 Beiträge

    Standard

    Zitat Zitat von böhlerprogramer Beitrag anzeigen
    Nun finde ich aber keine Schnittstelle um die Rechtecke mit einer Animation/Gestaltung zu verbinden.
    Über Eigenschaften -- Sichtbarkeit kann man die Rechtecke (grün, grau...) ein-ausblenden.
    Bei Eigenschaften -- Gestaltung der Rechtecke kann eine variable angelegt werden, über deren Wert die Farbe eingestellt werden kann

  6. #6
    Registriert seit
    05.11.2014
    Beiträge
    9
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo Verpolt,

    danke für deine Antwort. Leider habe ich bei der Definition der Schnittstelle unter Eigenschaften gar keine Sichtbarkeit zur Auswahl und im Menüpunkt Gestaltung kann ich zwar die Farbe anpassen aber eine Prozessvariable kann ich dort auch nicht definieren. Nun habe ich versucht die Gestaltung direkt am Rechteck unter Animationen zu definieren. Jetzt zeigt er mir auch in der Konfiguration der Schnittstelle an dass Blinken, Gestaltung Farbe Rahmen und Farbe Hintergrund verknüpft worden sind, jedoch nicht wohin, und wenn ich den Baustein verwenden will sehe ich unter Schnittstellen rein gar nichts.
    Reckteck_farbe_wechseln.jpg Rot umrandet die Bausteininterne Variable die ich für einen Versuch vergeben habe und in blauer Schrift die Parameter die dadurch anscheinend ins Nirvana verlinkt worde sind.

    So langsam glaube ich ich lass das mit diesem Baustein und verwende für neue Projekte einfach STRG+C und +V um ihn aus einem alten Projekt anzupassen.

  7. #7
    Registriert seit
    12.12.2013
    Ort
    Kaiserslautern
    Beiträge
    1.339
    Danke
    388
    Erhielt 219 Danke für 173 Beiträge

    Standard

    Moint Pi,

    Alles in der ruhe

    Schau du auch mal hier TIA V13 und CPU-1513 mit TP1200 Bildbausteine mit UDT verbinden

    Bram
    Wenn es nicht auf STRAVA ist, ist es nicht passiert !!

  8. Folgender Benutzer sagt Danke zu de vliegende hollander für den nützlichen Beitrag:

    böhlerprogramer (11.03.2015)

  9. #8
    Registriert seit
    05.11.2014
    Beiträge
    9
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Yess geschafft
    Aber nicht mittels UDT, nach langem einlesen habe ich eingesehen dass ich das hier nicht brauche, sonder ein bisschen einfacher. Bei der Definition der Eigenschaften im Bildbaustein wird immer eine Eigenschaft_1 erstellt. Dieser habe ich den gleichen Namen wie in der Animation des Rechteckes, im Bildbaustein, gegeben. Dann noch eine Variable in den HMI-Variablen definiert die ich mit einem Button invertiere und in der Schnittstelle der Bildbausteininternen Variable zuordne und siehe da: Mein kleiner Testaufbau hat funktioniert!

Ähnliche Themen

  1. Antworten: 1
    Letzter Beitrag: 06.03.2015, 09:55
  2. Textfeld in einem Bildbaustein Beschreiben
    Von Bensen83 im Forum HMI
    Antworten: 2
    Letzter Beitrag: 22.03.2011, 12:58
  3. Antworten: 2
    Letzter Beitrag: 29.09.2010, 00:53
  4. Antworten: 2
    Letzter Beitrag: 15.11.2008, 09:40
  5. Script zum Ausblenden von Objekten
    Von mercury_26 im Forum HMI
    Antworten: 8
    Letzter Beitrag: 25.04.2008, 09:11

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •