Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 4 von 4

Thema: WinCC v7.0 SP3 upd3 AutoStart

  1. #1
    Registriert seit
    09.07.2015
    Beiträge
    2
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen

    Projektaufstellung:

    Server:
    Windows Server 2008 R2 Standard 64bit - An der Maschine wird nicht bedient. Es ist normalerweise keiner eingeloggt und WinCC läuft als Dienst
    Clients:
    Windows 7 Enterprise SP1 bzw. Windows 7 Professional SP1 32bit - Geräte sollen nach einem Neustart selbstständig in die WinCC Runtime laufen ohne das ein Handeingriff notwendig ist.
    Version:
    Wie im Titel bereits geschrieben. WinCC v7.0 SP3 update3 - Auf allen Geräten gleich Server und Clients.

    Problem:
    Der Autostart von WinCC raubt mir den letzten Nerv. Schönstes Blinkverhalten. Tut mal und tut mal nicht.
    Erwünschte Einrichtung: Über Autostartfunktion von Simatic Net startet eine Routine die den Netzwerkshare zum Projekt öffnet (ist auch dann fehlerfrei vorhanden) Über die Runtime Start Optionen soll das WinCC Projekt gestartet und die Graphics Runtime aktiviert werden.
    Notfalleinrichtung: Über Autostartfunktion von Simatic Net startet eine Routine die den Netzwerkshare zum Projekt öffnet (ist auch dann fehlerfrei vorhanden) Über die gleiche Autostartfunktion startet das Programm AutoStartRT.exe aus dem Ordner bin von WinCC mit den nötigen Parametern.
    Testeinrichtung: Routine zur Verbindung des Netzwerkshares wird händisch gestartet. Nach Prüfung der Verbindung wird ein Batchfile ausgeführt der das Programm AutoStartRT.exe aus dem Ordner bin von WinCC mit den nötigen Parametern startet.

    Alle drei Varianten tun oder tun auch nicht und ich komm nicht dahinter was der Grund für ein Versagen ist. Die Varianten 1 und 2 sind auch bei mehreren Clients fehlerfrei im Einsatz. Es gibt mehrere Projekte mit der gleichen Konfiguration was Server und Clients betrifft und das Versagen des Autostarts kommt gelegentlich vor (nicht bei allen Clients obwohl alle mit dem gleichen Image).

    Wenn mir jemand sagen kann wie ich das Versagen des Autostarts ausschliessen kann oder zumindest nach einem Versagen wieder garantieren kann dass es nicht sofort wieder passiert dann wär das super. Ebenso wär mir auch schon erheblich geholfen wenn einer die Stelle weiß an der ich in den LogFiles von WinCC (Ordner Diagnose) nachlesen kann warum es gerade nicht geklappt hat.
    Zitieren Zitieren WinCC v7.0 SP3 upd3 AutoStart  

  2. #2
    Registriert seit
    29.03.2004
    Beiträge
    5.793
    Danke
    144
    Erhielt 1.706 Danke für 1.238 Beiträge

    Standard

    Wie hast du den Pfad zum WinCC Projekt im AutoStart denn eingetragen? Anstelle eines Netzlaufwerks würde ich einen UNC-Pfad verwenden. Auf jeden Fall statische IP-Adressen benutzen, und ggf. die Rechnernamen und zugehörige IP-Adresse in der host/lmhosts von Windows eintragen.

    Bis auf das dieses AutoStart-Programm extrem langsam in der Reaktion ist, hatte ich damit noch keine Probleme.

  3. #3
    Dhalben ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    09.07.2015
    Beiträge
    2
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Erstmal Merci für die Antwort

    Der Pfad wird mit einem Net Use Aufruf eingebunden.
    UNC Pfad haben wir früher verwendet. Aufgrund von IT-Richtlinien mussten wird das ändern. Das Problem bestand aber schon damals.
    IP-Adressen sind zwar gemischt dynamisch und statisch. Es gibt Projekte mit rein statisch, rein dynamisch (ausser Server) und auch gemischt. Lässt sich aber kein Unterschied ausmachen. Tritt in allen Fällen gleich verteilt auf.

    lmhosts werd ich testen. Darauf kam ich noch nicht.

  4. #4
    Registriert seit
    09.08.2006
    Beiträge
    3.638
    Danke
    912
    Erhielt 661 Danke für 543 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Es gab auch mal nen Beitrag von Siemens auf den Supportseiten... Hab grad keinen Link. U.U. hilft Dir der...
    Gruß

    https://support.industry.siemens.com/cs/document/19249315
    Geändert von ducati (11.07.2015 um 06:49 Uhr)

Ähnliche Themen

  1. WinCC flexible 2008 SP3 Upd3 - Skripte
    Von neo2003i im Forum HMI
    Antworten: 2
    Letzter Beitrag: 25.06.2015, 14:54
  2. Antworten: 2
    Letzter Beitrag: 06.02.2014, 15:09
  3. WinCC 7 SP3 Autostart Problem
    Von Pikador im Forum HMI
    Antworten: 5
    Letzter Beitrag: 24.08.2012, 15:11
  4. Antworten: 0
    Letzter Beitrag: 02.06.2009, 08:11
  5. WinCC flex 2007 RT autostart
    Von Manfred Stangl im Forum HMI
    Antworten: 4
    Letzter Beitrag: 10.05.2008, 20:41

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •