Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 3 von 3

Thema: AktiviereBild --> Fehlerhaftes Verhalten

  1. #1
    Registriert seit
    07.09.2015
    Ort
    Thüringen
    Beiträge
    8
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Community,
    anbei Stand meines Projekts und darunter die Problemstellung

    Stand(13.10.15), verwendet wird:
    -WINCC Professional
    -TIA V13
    -HMI KTP 700 Basic
    - Programm hat bis vor 5min geklappt!


    Problem in Kurzfassung:

    Habe einen Schalter eingebaut der beim Eindrücken "Start" und beim rausdrücken "Stop" setzt.
    Bei Animation ist ausgewählt:
    Variablenanbindung --> Prozesswert --> PLC-Variable YY
    Bei Ereignisse ist ausgewählt:
    Umschalten EIN --> AktiviereBild XX
    Umschalten AUS --> Rücksetze Bit YY

    Dieser Schalter soll wenn man auf Start drückt per -AktiviereBild auf Seite XX springen
    Wenn man auf Stop drückt wird der Befehl RücksetzBit XY durchgeführt jedoch kommt man nicht auf die nächste Seite.

    Beim Testen auf dem HMI passiert nun jedoch folgendes:
    Drücke Schalter --> 1ms wird die neue Seite angezeigt und sofort danach springt das Programm auf die Ausgansseite zurück.
    Der Schalter ist eingedrückt...

    Einmalig kam die Nachricht ProjectCharacteristics.rdf nicht gefunden.

    Was denkt ihr wo der Fehler liegt??

    Gruß
    Retler91
    Zitieren Zitieren AktiviereBild --> Fehlerhaftes Verhalten  

  2. #2
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.191
    Danke
    923
    Erhielt 3.292 Danke für 2.661 Beiträge

    Standard

    Zitat Zitat von Retler91 Beitrag anzeigen
    Programm hat bis vor 5min geklappt!
    Was heißt "hat bis vor 5min geklappt!"?
    Was hast Du seitdem gemacht?


    Habe einen Schalter eingebaut der beim Eindrücken "Start" und beim rausdrücken "Stop" setzt.
    Meinst Du "Start" bzw. "Stop" bei Eingeschaltet bzw. Ausgeschaltet auf der Schaltfläche anzeigt?


    Variablenanbindung --> Prozesswert --> PLC-Variable YY
    Bei Ereignisse ist ausgewählt:
    Umschalten EIN --> AktiviereBild XX
    Umschalten AUS --> Rücksetze Bit YY
    Wozu soll beim Ausschalten des Schalters der PLC-Variable YY dieses sowieso ausgeschaltete Bit zusätzlich nochmal rückgesetzt werden?
    Soll der Bildwechsel auch automatisch ausgeführt werden, wenn sich die PLC-Variable YY in der PLC ändert, ohne daß jemand den Schalter drückt?


    Drücke Schalter --> 1ms wird die neue Seite angezeigt und sofort danach springt das Programm auf die Ausgansseite zurück.
    Der Schalter ist eingedrückt...
    Hast Du an irgendwelche Ereignisse weitere Bildwechsel projektiert (z.B. bei Wertänderung der PLC-Variable YY oder anderen Variablen)?
    Was ist in dem neuen Bild an der Stelle, wo im Ausgangsbild der Schalter ist?

    Ich kann nicht ganz folgen: wofür braucht man einen Bildwechsel beim Einschalten von irgendwas?

    Gibt es bei dem TIA ein "Alles übersetzen"?

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  3. #3
    Retler91 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    07.09.2015
    Ort
    Thüringen
    Beiträge
    8
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Harald danke für die schnelle Antwort!

    Räume das Feld mal von hinten auf:

    Gibt es bei dem TIA ein "Alles übersetzen"?


    Ja gibt es und habe ich auch durchgeführt dabei kommen keine Warnungen oder Fehlermeldungen auf.

    wofür braucht man einen Bildwechsel beim Einschalten von irgendwas?
    Das Programm hat einen Auto- und einen Hand-Betrieb. Das ist sozusagen die erste Seite des Programmes. Der Benutzer entscheidet und wird dann direkt beim Klicken auf die jeweils folgende Seite gebracht.
    Will man nun jedoch aus Auto raus in Hand, muss man erst auf die Startseite --> Den Autoschalter auf Stop drücken und dann kann man den Handbetriebs-Schalter drücken.
    Hoffe man versteht was ich meine :P

    Hast Du an irgendwelche Ereignisse weitere Bildwechsel projektiert (z.B. bei Wertänderung der PLC-Variable YY oder anderen Variablen)?


    Muss ich morgen nochmal genauer unter die Lupe nehmen bzw. werde ich das Programm nochmal Neu und Ordentlicher! schreiben damit kein Fehler mehr darin steckt.

    Wozu soll beim Ausschalten des Schalters der PLC-Variable YY dieses sowieso ausgeschaltete Bit zusätzlich nochmal rückgesetzt werden?
    Soll der Bildwechsel auch automatisch ausgeführt werden, wenn sich die PLC-Variable YY in der PLC ändert, ohne daß jemand den Schalter drückt?


    Nein der Bildwechsel findet nur aus dem Startbild statt und wird sonst auch nicht mehr aktiviert.

    Meinst Du "Start" bzw. "Stop" bei Eingeschaltet bzw. Ausgeschaltet auf der Schaltfläche anzeigt?


    Na klar
    mein Fehler

    Was heißt "hat bis vor 5min geklappt!"?
    Was hast Du seitdem gemacht?


    Das wüsste ich auch gerne!


    Danke auf jeden Fall für die Denkanstöße, hatte gedacht es hat irgendwas mit diesem "
    ProjectCharacteristics.rdf nicht gefunden" zu tun.

    Gruß



Ähnliche Themen

  1. Antworten: 2
    Letzter Beitrag: 31.10.2014, 10:02
  2. Fehlerhaftes Einloggen nach durchlaufenem Programm
    Von Gloria im Forum CODESYS und IEC61131
    Antworten: 14
    Letzter Beitrag: 27.02.2013, 19:51
  3. Antworten: 25
    Letzter Beitrag: 20.07.2009, 16:40
  4. AktiviereBild problem mit OP77
    Von Tiansen im Forum HMI
    Antworten: 1
    Letzter Beitrag: 05.06.2008, 14:42
  5. ein Fehlerhaftes SCL Programm
    Von Rose im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 06.06.2006, 13:26

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •