Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 5 von 5

Thema: KTP400 Comfort - LED der Tasten ansprechen, über Logo 8

  1. #1
    Registriert seit
    21.10.2003
    Beiträge
    157
    Danke
    3
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Gibt es eine Möglichkeit, die LED's der F-Tasten bei einem KTP400 Comfort über eine LOGO! anzusteuern?
    Würde diese halt gerne mit einbinden.

    Nutze TIA V11 und Logo Soft V8.


    Eine Step-by-Step Anleitung wäre von Vorteil.

    Im Grundbild habe ich diese LED's schon gefunden.
    Habe auch schon mit Variable versucht, doch irgendwie will es nicht.
    In der Hilfe steht halt etwas von einer "LED-Variable oder eine Array-Variable" ... Array verstehe ja mal garnicht.

    Möchte gerne die LEDs über eine Logo ansteuern, bzw. über die LED anzeigen, welches Menü gerade aktiv ist.
    ..im Grunde: F1 ruft ein Menü-Fenster auf, dies soll dann mit der LED der F1-Taste angezeigt werden.
    Mit F2 dann auch so.
    Versuch macht kluch...
    -----------------------------------------------------------------------
    Der Logo-Bus-Verstärker
    Zitieren Zitieren KTP400 Comfort - LED der Tasten ansprechen, über Logo 8  

  2. #2
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.163
    Danke
    921
    Erhielt 3.286 Danke für 2.655 Beiträge

    Standard

    Du könntest von der LOGO mit Merkern die LEDs steuern, mit Netz-Ausgängen NQx sollte es auch gehen.
    Ich habe kein TIA und kein LOGOsoft 8 zur Verfügung, habe die LED-Steuerung von einer LOGO auch noch nie gemacht, doch ich meine es müßte etwa so funktionieren:

    Angenommen Du nimmst die Merker M9 .. M16 (jede LED wird mit 2 aufeinanderfolgenden Bits gesteuert):
    Code:
    M9  + M10 = V1105.0 + V1105.1 --> LED_F1
    M11 + M12 = V1105.2 + V1105.3 --> LED_F2
    M13 + M14 = V1105.4 + V1105.5 --> LED_F3
    M15 + M16 = V1105.6 + V1105.7 --> LED_F4
    
    Die Zustände der je 2 Merker steuern die LEDs so:
     0  +  0  = LED Aus
     0  +  1  = LED blinken langsam
     1  +  0  = LED blinken schnell
     1  +  1  = LED Dauerlicht
    In TIA
    In der HMI erstellst Du eine Variable LED_Var (Byte) auf die Adresse VB1105. Falls man in dem TIA keine Byte-Variable bei der LED-Zuordnung angeben kann dann erstelle die Variable als Word mit der Adresse VW1104.

    Im "Globales Bild" des KTP400 ordne den F-Tasten die LED-Variable wie folgt zu:
    Softkey_F1: LED_Var ab Bit 0
    Softkey_F2: LED_Var ab Bit 2
    Softkey_F3: LED_Var ab Bit 4
    Softkey_F4: LED_Var ab Bit 6


    Beispiel: Zum Einschalten der LED_F1 M9 und M10 auf 1 steuern.
    Falls keine LED leuchten will, dann schalte mal testweise alle Merker M1..M16 auf 1.

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  3. #3
    Avatar von Nachbar
    Nachbar ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    21.10.2003
    Beiträge
    157
    Danke
    3
    Erhielt 1 Danke für 1 Beitrag

    Standard

    N'Abend....

    So hatte ich mir das auch gedacht.... und umgesetzt.
    Funktioniert nur nicht, k.a. woran es liegen kann.


    Edit:
    Hab's... für LED F1 sind es nicht Bit 0/1 sondern Bit 8/9 aus dem Word.


    Ok, so kann ich die LED's also per Logo ansprechen.
    Nun, wie bekomme ich das hin, daß die F1-LED leuchtet, wenn ich F1-Taste gedrückt habe und so ein Bild aufgerufen habe.
    Geändert von Nachbar (22.11.2015 um 21:02 Uhr)
    Versuch macht kluch...
    -----------------------------------------------------------------------
    Der Logo-Bus-Verstärker

  4. #4
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.163
    Danke
    921
    Erhielt 3.286 Danke für 2.655 Beiträge

    Standard

    Zitat Zitat von Nachbar Beitrag anzeigen
    Hab's... für LED F1 sind es nicht Bit 0/1 sondern Bit 8/9 aus dem Word.

    Steuerst Du M1+M2 statt M9+M10?
    Oder hat Siemens die Reihenfolge der Merker in V... oder gar die Endianness zwischen 0BA7 und 0BA8 geändert??

    Die VM-Zuordnung der Merker ist für die 0BA8 leider nicht eindeutig dokumentiert, im LOGO!Soft-8-Handbuch Kapitel 2.8.5.35 steht nur: Blocktyp M = VB1104..VB1117. Das sollte folgende Adressen ergeben (oder wie?):
    Code:
    0BA7                        | 0BA8
    ----------------------------+------------------------------
    M1  = V948.0 = VW948 Bit 8  | M1  = V1104.0 = VW1104 Bit 8
    ...                         | ...
    M8  = V948.7 = VW948 Bit 15 | M8  = V1104.7 = VW1104 Bit 15
    ...                         | ...
    M9  = V949.0 = VW948 Bit 0  | M9  = V1105.0 = VW1104 Bit 0
    ...                         | ...
    M16 = V949.7 = VW948 Bit 7  | M16 = V1105.7 = VW1104 Bit 7
    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  5. #5
    Avatar von Nachbar
    Nachbar ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    21.10.2003
    Beiträge
    157
    Danke
    3
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    N'Abend

    Zum Testen habe ich Merker M33 und M34 genommen.
    Dies ist dann VW 1108.
    Mittels des Onlinetest und Variablentabelle in der Logo, konnte ich sehen, welche Bit's reagierten.

    Jetzt kann ich damit weiter aufbauen.

    thx
    Versuch macht kluch...
    -----------------------------------------------------------------------
    Der Logo-Bus-Verstärker

Ähnliche Themen

  1. Antworten: 0
    Letzter Beitrag: 06.10.2015, 09:40
  2. Antworten: 8
    Letzter Beitrag: 05.08.2015, 14:20
  3. Biete : KTP400 Comfort Panel Neu
    Von jabba im Forum Suche - Biete
    Antworten: 0
    Letzter Beitrag: 24.01.2014, 09:57
  4. KTP400 Comfort Erste Schritte...
    Von gerdh im Forum HMI
    Antworten: 4
    Letzter Beitrag: 18.12.2013, 12:59
  5. LOGO! S7-200: AI-Led`s ansprechen
    Von bricktop im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 23.09.2005, 19:24

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •