Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 5 von 5

Thema: Drittes MP baut keine Verbindung zur CPU auf.

  1. #1
    Registriert seit
    18.05.2004
    Beiträge
    203
    Danke
    2
    Erhielt 2 Danke für 2 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    habe ein Problem, bei dem ich nicht mehr weiter komme.

    Habe eine CPU 316-2DP (6ES7-316-2AG00), einige EA-Module als dezentrale Peripherie und 3 MP270B am Profibus hängen. Programm paßt alles soweißt nur die MP270B machen schwierigkeiten. Es können immer nur 2 MP270 eine Verbindung zur CPU aufbauen. Dachte mir es sind nicht genügend frei Verbindungsresourcen vorhanden und habe im Reiter Kommunikation 3 OP Verbindung reserviert. Doch leider funktioniert das ganze trotzdem nicht. Es liegt nicht am MP, da ich schon ein anderes eingebaut habe bzw. wenn ich eins von den beiden das eine Verbindung aufgebaut hat, vom Profibus abstecke, dann kann das dritte Panel eine Verbindung aufbauen, dafür aber das nicht mehr, das ich abgesteckt habe. Alle 3 MP270 Projekte sind gleich und mit WinCC flexible 2005 SP1 Standard projektiert. Step 7 verwenden wir die Version 5.3. Die WinCC flexible Projekte sind im Simatic Manager integriert und vernetzt.

    Habe keine Ahnung woran das liegen kann bzw. ich weiß nicht an welcher "Schraube" ich noch drehen könnte!

    Weißt jemand von euch dazu Rat!!
    Vielen Dank

    Michael
    Zitieren Zitieren Drittes MP baut keine Verbindung zur CPU auf.  

  2. #2
    Registriert seit
    07.05.2004
    Ort
    Campbelltown
    Beiträge
    2.437
    Danke
    131
    Erhielt 276 Danke für 86 Beiträge

    Standard

    Hei,

    ich bin mir nicht sicher, ob überhaupt mehr als 2 OP angeschlossen werden können. Je nach Ausgabestand der 316 kann man die Kommunikation auch nicht verändern, hast du die Hardware genau mit der SPS abgeglichen? (V1.0/1.1/1.2)

    Setz doch mal auf 4 hoch und die Baiskommunikation runter.

    Gib auf jeden Fall mal Feedback.


    Gruß, pt
    Gegen Schwachsinn, Schwachköpfe und armselige Trittbrettfahrer kann man nicht argumentieren.

    Gott sieht alles, auch Signaturen in Geheimschrift,,... aber er petzt nicht.

  3. #3
    S7_Mich ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    18.05.2004
    Beiträge
    203
    Danke
    2
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Ja du hast recht, es war zuvor eine 315-2AF03 eingebaut. Bei dieser gibts keinen Reiter Kommunikation. Das liegt wie du schon gesagt hast andem Ausgabestand V1.0.0. Ab V1.1 gibts es den Reiter Kommunikation.

    Deshalb habe ich eine 316-2AG00 eingebaut, weil ich dachte es liegt daran, das zu wenig OP-Verbindungen vorhanden sind. Wenn ich mir die Verbindung Online anschaue, dann werden genau 3 belegt von OPs und 3 sind reservert. Außerdem sind ja noch 8 Verbindungen möglich. 12 sind insgesamt möglich 8 davon noch übrig. (eine PG Verbindung, und 3 OP Verbindung). Ich verstehe das ja so, wenn mehr als die möglichen Verbindungen überschritten werden, dann gilt erst die Reservierung. In meinem Fall sind ja immer noch 8 übrig. Versteh ich das so richtig?

    Ja in der HW ist genau der Ausgabestand projektiert.

    Kann doch nicht sein, das man bei ner 300 nur 2 OPs anschileßen kann oder? Ist die Beschränkung erst bei der 400-Reihe ausgeweitet?

    Gruß
    Michael

  4. #4
    S7_Mich ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    18.05.2004
    Beiträge
    203
    Danke
    2
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Hallo,

    das Problem hab ich jetzt behoben.
    Der Fehler lag wirklich in den Einstellungen für die reservierten Verbindungsresourcen.

    Da wir 3 MP270B über Profibus gekoppelt haben, dachte ich, es würden 3 reservierte OP-Verbindungen ausreichen. Da wir aber zusätzlich noch ein MP370 über Ethernet angeschlossen haben, zählt natürlich diese Visu auch zu den OP-Verbindungen. Habe den Wert auf 6 erhöht, somit haben wir jetzt auch noch zwei Reserven für Projektierungen (Runtime).

    Allerdings mußten wir die reservierten Verbindungen für S7-Basis Kommunikation verringern, um die max. Anzahl nicht zu überschreiten.

    Die Frage ist nun, was ist eine S7-Basis-Kommunikation. Jetzt ist der Wert 5 eingestellt. Hoffentlich reicht das aus. Online ist aber keine S7-Basis Kommunikation belegt, also wirds schon passen. Für was die aber ist, würd mich schon noch interessieren.

    Vielen Danke!

    Gruß
    Michael

  5. #5
    Registriert seit
    01.03.2006
    Beiträge
    21
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Bei der S7-Basiskommunikation handelt es sich um im Betriebssystem der CPU verankerte Kommunikationsfunktionen. Diese ermöglichen es z.B. über nicht projektierte Verbindungen Daten zwischen zwei vernetzten CPU's aus zu tauschen. Hierzu stellt die S7 spezielle Funktionsbausteine (PUT; GET) zur Verfügung.
    Beispiel:
    Zwei S7 werden über MPI vernetzt. In der 1. CPU wird mit GET der Auftrag angestossen Daten aus der 2. CPU zu lesen. Die 2. CPU arbeitet den Auftrag im Betriebssystem ab und gibt die Daten an die 1. CPU weiter. Hierzu ist keinerlei Projektierung auf der 2. CPU notwendig.

Ähnliche Themen

  1. Antworten: 3
    Letzter Beitrag: 02.12.2011, 16:30
  2. C#, NDde - Client baut Verbindung nicht richtig ab
    Von vierlagig im Forum Hochsprachen - OPC
    Antworten: 10
    Letzter Beitrag: 30.04.2011, 15:05
  3. keine Verbindung zur SPS
    Von woseitsihr im Forum Simatic
    Antworten: 14
    Letzter Beitrag: 31.08.2009, 13:19
  4. Keine Verbindung zu CPU 315-2 PN/DP
    Von NeuerSIMATICNutzer im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 28.07.2009, 10:40
  5. CP341 und RK512 Verbindung baut auf/ab
    Von Bender25 im Forum Simatic
    Antworten: 9
    Letzter Beitrag: 02.05.2008, 09:15

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •